Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

USB 3.0 wird nicht erkannt

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player und VMware Workstation Player.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 3
Registriert: 03.05.2019, 11:27

USB 3.0 wird nicht erkannt

Beitragvon steve9x » 03.05.2019, 19:40

Guten Tag,

zunächst meine Settings:
Ich nutze den VMPlayer 15.
Hostsystem: Windows 7
Guest: Ubuntu 16.04.4

Mein Problem:
In der VM werden an den USB 3.0 Ports keine USB Geräte jeglicher Art erkannt es wird direkt im Hostsystem angezeigt.
Alle USB 2.0 Ports funktionieren in der VM einwandfrei.

Was ich schon gemacht habe:
In den VW Settigns habe ich die USB compatibility auf: USB 3.0.
Meine Linux kernel version: 4.15.0-48-generic.

Kann mir da jemand helfen? Ich würde gerne ein Kamera mit USB 3.0 in der VM nutzen.

lg steve

King of the Hill
Beiträge: 13416
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: USB 3.0 wird nicht erkannt

Beitragvon Dayworker » 03.05.2019, 20:30

Sind die USB3.0-Ports nativ im Chipsatz oder per Zusatz-Chip realisiert?
Was hast du als Gast-OS eingestellt?
Welche v.HW-Version hast du konfiguriert?

Lade mal ein vollständiges "vmware.log" dieser VM hier hoch. Dann beantworten sich einige Fragen von selbst.

Member
Beiträge: 3
Registriert: 03.05.2019, 11:27

Re: USB 3.0 wird nicht erkannt

Beitragvon steve9x » 04.05.2019, 12:19

Zur 1. Frage:
Also meine USB 3.0 Ports sind direkt am Mainboard, wenn das die Frage beantwortet.

Zur 2. Frage:
Gast-OS: Ubuntu 16.04.4
Virtual_Machine_Settings.PNG
Zur Frage 2...


Zur 3. Frage:
Was genau meinst du mit v.HW?
Und wo soll das konfiguriert werden?

Ich habe jetzt in den Anhang eine .zip-Datei mit den 4 .log Dateien dieser VM hochgeladen.
Dateianhänge
vmware.log.zip
(125.94 KiB) 160-mal heruntergeladen

King of the Hill
Beiträge: 13416
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: USB 3.0 wird nicht erkannt

Beitragvon Dayworker » 05.05.2019, 00:37

2019-05-03T19:34:33.538+02:00| vmx| I125: DICT virtualHW.version = "16"

Bei dir hat die VM die v.HW-Version 16. Ich meine das entweder wir das Problem hier schon mal hatten oder ich im VMTN erst kürzlich darauf gestossen war. Die Lösung war meiner schwachen Erinnerung nach der Wechsel auf die 15. Blöd ist jetzt, daß VMware keinen einfachen Weg zurück über Player bzw Workstation Player vorsieht. Mit etwas Glück läßt sich das manuell nachholen, wenn die VMDK nicht gerade als "monolithicSparse" angelegt wurde. Das muß ich noch raussuchen.


2019-05-03T19:34:33.625+02:00| vmx| I125: DISKLIB-DSCPTR: Opened [0]: "Ubuntu_16.04.4_ 64-bit.vmdk" (0xa)
2019-05-03T19:34:33.625+02:00| vmx| I125: DISKLIB-LINK : Opened 'E:\Programme\VM\Ubuntu_16.04.4\Ubuntu_16.04.4_ 64-bit.vmdk' (0xa): monolithicSparse, 83886080 sectors / 40 GB.
2019-05-03T19:34:33.625+02:00| vmx| I125: DISKLIB-LIB : Opened "E:\Programme\VM\Ubuntu_16.04.4\Ubuntu_16.04.4_ 64-bit.vmdk" (flags 0xa, type monolithicSparse).
Mist, leider doch monolithicSparse und somit entfällt der leichte Weg über einen ASCII-Editor.
Schau mal nach, ob der "vmware-vdiskmanager" vom Player bzw Workstation-Player mitinstalliert wurde. Falls letzteres der Fall ist, könntest du die vDISK einfach in ein anderes Format konvertieren und die Änderung vornehmen. Neben der kleinen Beschreibungs-VMDK müßte man dann auch die VMX-Datei auf die 15 umschreiben.


2019-05-03T19:34:34.634+02:00| vmx| I125: USB: Found device [name:Razer\ Mamba\ Tournament\ Edition vid:1532 pid:0046 path:1/6/0 speed:full family:hid,hid-bootable instanceId:USB\\VID_1532&PID_0046\\5&270230AB&0&1 arbRuntimeKey:1 version:3]
2019-05-03T19:34:34.634+02:00| vmx| I125: USB: Found device [name:Razer\ BlackWidow\ X\ Chroma vid:1532 pid:0216 path:1/6/1 speed:full family:hid,hid-bootable instanceId:USB\\VID_1532&PID_0216\\5&270230AB&0&2 arbRuntimeKey:2 version:3]
2019-05-03T19:34:34.634+02:00| vmx| I125: USB: Found device [name:Virtual\ Bluetooth\ Adapter vid:0e0f pid:0008 speed:full family:wireless,bluetooth deviceType:virtual-bluetooth info:0000001 version:3]
Ich sehe nur diese 3 USB-Geräte und alle werden als Full-Speed eingeloggt. Um welche USB3.0-Geräte geht es genau?


Wieviel CPUs hast du der VM eigentlich gegönnt? Entweder bin ich zu blöd zum Log-Lesen oder VMware zieht da wieder irgendwelche Standardvorgaben heran, jedenfalls finde ich dazu keine direkten Einträge im Log.

Experte
Beiträge: 1788
Registriert: 04.10.2011, 14:06

Re: USB 3.0 wird nicht erkannt

Beitragvon JustMe » 05.05.2019, 10:10

"Standard" trifft's wohl ganz gut:

Code: Alles auswählen

...
2019-05-03T19:34:33.587+02:00| vmx| I125: vmm64-vcpus:   1
2019-05-03T19:34:33.597+02:00| vmx| I125: KHZEstimate 3214890
2019-05-03T19:34:33.597+02:00| vmx| I125: MHZEstimate 3215
2019-05-03T19:34:33.597+02:00| vmx| I125: NumVCPUs 1
...


Funktionieren die USB3-Ports, wenn die VM auf USB2 umgestellt ist (selbstverstaendlich hoechstens mit USB2-Speed)?

Eigentlich reicht "direkt am Mainboard" ja nicht; da koennen auch Chips aufgeloetet sein...

Member
Beiträge: 3
Registriert: 03.05.2019, 11:27

Re: USB 3.0 wird nicht erkannt

Beitragvon steve9x » 06.05.2019, 20:30

Schau mal nach, ob der "vmware-vdiskmanager" vom Player bzw Workstation-Player mitinstalliert wurde

Nein davon ist keine Spur. Kann man den nachtraglich installieren? Wenn ja von wo genau bekomme ich den?

Ich sehe nur diese 3 USB-Geräte und alle werden als Full-Speed eingeloggt. Um welche USB3.0-Geräte geht es genau?

Es sind stardardmäßige USB 3.0 und 2.0 Sticks die er nicht erkennt.

Wieviel CPUs hast du der VM eigentlich gegönnt?

Hatte immer eine. Habe es mal umgestellt hilft aber nichts um das Problem zu lösen

Funktionieren die USB3-Ports, wenn die VM auf USB2 umgestellt ist (selbstverstaendlich hoechstens mit USB2-Speed)?

Nein es wird auf den USB 3.0 Ports kein Gerät erkannt. Egal welche Einstellung vorgenommen wurde. :cry:


Zurück zu „VMware Player und VMware Workstation Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast