Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

VM Windows XP - mit SVGA Treiber nur 640x480

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player und VMware Workstation Player.

Moderatoren: Dayworker, continuum, Tschoergez, irix, stefan.becker

Member
Beiträge: 3
Registriert: 13.08.2018, 20:54

VM Windows XP - mit SVGA Treiber nur 640x480

Beitragvon holec » 13.08.2018, 21:12

Hallo,

ich bin neu hier und hoffe jemand hat eine Idee :-)

Ich habe einen alten PC mit Windows XP und dieses in eine VM kopiert (direkte Kopie von USB Festplatte) bzw. über VMWareConverter konvertiert.

Wenn ich die VM starte ist die Auflösung bei 1280x1024, auch im abgesicherten Modus. Wenn ich die VMWareTools installiere ist die Auflösung nur noch bei 640x480. Deinstalliere ich die VMWareTools kann ich die Auflösung wieder erhöhen.

Auf dem Windows XP lief früher ein VMWareServer. Diesen kann ich nicht deinstallieren, er bricht mit einer Fehlermeldung ab. Eine Bereinigung mit dem Cleaner von VMWare brachte nichts.

Auch die Auflösung in der Registry ändern brachte nichts.

z.B. "Attach.RelativeX" oder "DefaultSettings.XResolution"

Verwendet habe ich VMWare Player 14.

Bei anderen Windows XP PCs hat die Konvertierung bisher immer funktioniert.

Hat jemand vielleicht eine Idee?

Danke im Voraus!

Holger

Jenseits von Gut & Böse
Beiträge: 11459
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: VM Windows XP - mit SVGA Treiber nur 640x480

Beitragvon irix » 14.08.2018, 07:42

Zum eigentlichen Problem kann ich nichts sagen.

Der VMware Deinstaller prueft die gleichen Bedingungen ab wie der Installer und sollte er nun JETZT was antrefen was er nicht supportet so hoert er auf. Das laesst einen graue Haare wachsen wenn man nach erfolgreicher Installation spaeter mal eine andere Software installiert welche die Installerroutine vom VMware Produkt dann erkennt und nicht mehr funktioniert.

Gruss
Joerg

King of the Hill
Beiträge: 12343
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: VM Windows XP - mit SVGA Treiber nur 640x480

Beitragvon Dayworker » 14.08.2018, 10:24

Unter WS Pro und WS Player sollte folgende Einstellung funktioieren:

Code: Alles auswählen

svga.maxWidth = "1280"
svga.maxHeight = "1024"


Es ist eigentlich ungewöhnlich, daß der VMserver-Installer versagt. Welche genaue Version wurde denn damals installiert und wie lautet die Installer-Fehlermeldung genau? Der Installer hatte bei mir immer mit einer Nummer abgebrochen und mit der konnte man auch suchen gehen. Falls der Installer überhaupt nicht mehr will, bleibt dir noch die ganz harte Tour mit dem manuellen Entfernen aller VMware-Dateien und -Settings im Dateisystem und vor allem in der Registry. Nicht das sich VMserver-Settings und die der jetzt installierten Vmware-Tools überschneiden. Dürfte ja eigentlich nicht sein, aber wenn schon der VMserver-Installer abbricht...

Member
Beiträge: 3
Registriert: 13.08.2018, 20:54

Re: VM Windows XP - mit SVGA Treiber nur 640x480

Beitragvon holec » 16.08.2018, 11:15

Danke für die Hinweise.

Ich hab mir das Ganze nochmals genauer angesehen. Es dürfte sich um ein Problem mit Windows XP und den alten Grafikkartentreibern handeln.
Ich konnte ein altes Backup dieser Windows Installation wieder herstellen und dort eine höhere Ausflösung einstellen, mit dem VMWare SVGA Treiber.

Die Grafik in der VM funktioniert nicht wirklich, die Auflösung ist fest (wahrscheinlich die letzte vom realen PC) und keine 3D Unterstützung.

Auch wenn ich in der defekten VM die Registry bereinige, alle Dienste beende - die Auflösung bleibt bei 640x480.

Ich gehe davon aus, dass das Windows XP neu installiert werden muss. An der alten VM werde ich wohl nichts mehr reparieren können.

Die VMWServer Deinstallation bricht ab mit"Error 1316. A network error occured while attempting to read from the file C:\Windows\Installer\VMware Server.msi"

Die Datei gibt es auch nicht...

Viele Grüße

Holger

King of the Hill
Beiträge: 12343
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: VM Windows XP - mit SVGA Treiber nur 640x480

Beitragvon Dayworker » 26.08.2018, 00:54

Zieh dir nach Möglichkeit den Installer und pack den mit msi-Installer (msi-a falls ich mich nicht irre) aus, dann taucht die geforderte MSI-Datei wieder auf.
Alternativ laß dir im XP alle alten Geräte anzeigen und wirf dann alle alten Gerätschaften raus. Dafür haben die meisten VMware-Nutzer einen 3-Zeiler als BAT oder CMD, der im Anschluß den Gerätemanager startet:

Code: Alles auswählen

@echo off
set devmgr_show_details=1
set devmgr_show_nonpresent_devices=1
devmgmt.msc


Zurück zu „VMware Player und VMware Workstation Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast