Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

long mode Fehler (keine 64bit Unterstützung) info?id=152

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: Dayworker, continuum, Tschoergez, irix, stefan.becker

Member
Beiträge: 2
Registriert: 07.01.2013, 23:35

long mode Fehler (keine 64bit Unterstützung) info?id=152

Beitragvon volker1 » 09.01.2013, 22:12

Hallo,

ich hatte mein "echtes" 64bitVista virtualisiert, um es im neu installierten "echten" Win8 auf dem selben Rechner virtuell weiter nutzen zu können.

Nun bekomme ich die Fehlermeldung
Binary translation is incompatible with long mode on this platform. Disabling long mode. Without long mode support, the virtual machine will not be able to run 64-bit code. For more Details see http://vmware.com/info?id=152
und
This virtual machine is configured for 64-bit guest operating systems. However, 64-bit operation is not possible. This host does not support Inter VT-x.

Und wirklich: meine Laptop CPU (Intel Centrino Core Duo P7350@2Ghz) unterstützt long mode nicht.

2 Fragen:
damit ich wenigstens die Daten rüberkopieren kann: könnte ich eine 32-Bit Win-Vista Installation vornehmen (habe noch eine Lizenz dafür) und in dem 32-Bit-virtuellen System eine Virtuelle Umgebung einrichten (also emuliert VMWare eine long-mode-fähige CPU)?

Warum konnte ich denn vor einigen Monaten mal erfolgreich unter meinem alten "echten" WinVista in VMWare player ein Win8-64-Bit-System installieren? Das hätte doch auch schon bei der selben CPU versagen müssen???

Danke für die Aufmerksamkeit!

King of the Hill
Beiträge: 12227
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 09.01.2013, 22:57

VMware emuliert keine CPU-Features, entweder die CPU bringt sowas mit oder du hast Pech gehabt.

Deine Centrino Core2Duo CPU P7350 unterstützt zwar 64bit aber kein VT (-x). Wenn deine CPU einen eingebauten Speicherkontroller mitbringen würde, hättest du vermutlich auch ohne VT (-x) keine Probleme mit 64bit-Gästen. In deinem Fall bedeutet das, wie du schon am eignen Leib erfahren mußtest, daß du keine 64bit-Gäste starten kannst.

Ob dein Host-OS 32bit oder 64bit ist, spielt für dein 64bit-Gast keine Rolle. VMware kommuniziert für 64bit-Gäste immer VT-Support in HW sprich VT-x oder AMD-V.
Einige ältere Workstation/Player-Version sind aber manchmal etwas gnädiger hinsichtlich einzelner CPUs. Beispielsweise wurden einige AMD-CPUs der Phenom-Reihe fälschlicherweise mal als inkompatibel bzw nicht voll supportet gelistet und mit einer älteren WS/Player-Version liefen sie ohne Probleme.

Weshalb du unter deinem 64bit-Vista mit unbekannter Player-Version ein Win8-64bit-System zum laufen bekommen hast, kann dir wahrscheinlich nur VMware selbst erklären. Mir fällt dazu jedenfalls nichts ein.

Member
Beiträge: 2
Registriert: 07.01.2013, 23:35

Beitragvon volker1 » 10.01.2013, 23:38

vielen Dank für die superschnelle Antwort - du wohnst wohl wirklich hier ;-)

Da bringst du mich auf eine Idee - ich glaube ich hatte vorher Version 3.irgendwas (als mein selbst installierter Gast Win8-64Bit lief) und dann hatte ich einfach mal upgedated.

Danach ging dann Win8 nicht mehr - war mir aber nicht aufgefallen, weil gleichzeitig noch mein Win95Gast abgeraucht war und ich das auf die klackernde HD schob, weswegen ich ja neu meinen "echten" Rechner aufbaute...

ich teste die nächsten Tage mal Player 3.1 und poste - vielleicht hilft das Ergebnis ja mal irgendwem ;-)

Gut´s Nächtle!


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast