Die Foren-SW läuft schon geraume Zeit ohne erkennbare Probleme. Sollte etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

'Share bluetooth devices' geht nicht.

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player und VMware Workstation Player.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 5
Registriert: 11.01.2020, 18:49

'Share bluetooth devices' geht nicht.

Beitragvon 4tmelDriver » 11.01.2020, 19:11

Hallo,
ich habe den VMware Player auf einem Manjaro Linux.
Ich nutze eine VM, um unter Windows in OneNote zu schreiben und brauche dafür eine Bluetooth-Verbindung von dem Wacom-Tablet.
Nun gibt es ja die Möglichkeit den Bluetooth Adapter durchzuschleifen, und das funktioniert auch, aber ist immer sehr aufwendig, da auch jedes Mal die Bluetooth Geräte neu verbunden werden müssen und zudem auf dem Host nicht mehr zur Verfügung stehen.

Unter dem USB Tab gibt es ja die Einstellung 'Share bluetooth devides'. Wenn das Aktiviert ist, erscheint im Gast-System auch ein Bluetooth Adapter. Laut Dokumentation sollte ich jetzt in der VM Bluetooth Geräte ganz normal pairen können. Allerdings erscheinen keinerlei Geräte, wenn ich nach welchen suche (unabhängig davon, ob schon mit dem Host gekoppelt oder nicht).

Mein Bluetooth Adapter ist der "8087:0a2b Intel Corp."

Hat jemand eine Idee?
Gruß

King of the Hill
Beiträge: 12676
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: 'Share bluetooth devices' geht nicht.

Beitragvon Dayworker » 11.01.2020, 19:41

Ausgehend vom KB-Eintrag Sharing Bluetooth devices with a virtual machine (2005315) lassen sich nicht alle Arten von BT-Geräte durchreichen. In die VM wird unabhängig davon anscheinend immer nur ein generisches BT-Gerät durchgereicht und eine eventuell einzugebende PIN wird nur über den Host abgefragt, erst danach erscheint das Gerät im Gast.

Member
Beiträge: 5
Registriert: 11.01.2020, 18:49

Re: 'Share bluetooth devices' geht nicht.

Beitragvon 4tmelDriver » 11.01.2020, 19:54

Ich habe über 10 verschiedene Bluetooth Geräte in meiner näheren Umgebung, die auch alle vom Host gefunden werden. Nur der Gast findet gar kein Gerät.
Laut des Links sollte der Gast auch in der Lage sein nach Geräten zu suchen und nur der Paring-Vorgang wird dann über den Host abgewickelt.

Deswegen tippe ich vorerst auf ein anderes Problem.

King of the Hill
Beiträge: 12676
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: 'Share bluetooth devices' geht nicht.

Beitragvon Dayworker » 11.01.2020, 20:18

Du hast bisher nur wenig Infos zu den beteiligten Kernel- und VMware-Versionen geliefert oder zumindest mal ein "vmware.log" hier ins Forum geladen. VMware kommt allgemien mit RR-Distributionen eher schlecht zurecht, weil sich die Kernel-Einsprungpunkte gerne mal verändern. Daher sind da ggf noch ganz andere Probleme zu erwarten. Ich hatte bisher auch keinerlei Berührungspunkte mit Manjaro.

Member
Beiträge: 5
Registriert: 11.01.2020, 18:49

Re: 'Share bluetooth devices' geht nicht.

Beitragvon 4tmelDriver » 11.01.2020, 21:05

Danke für die Antwort.
Auf die Idee mit dem Log-File hätte ich auch kommen können... Sie ist jetzt im Anhang.

Ich nutze den VMware Player 15.5.1 und bin gerade auf dem Linux Kernel 5.4.6-2.

Gerne würde ich noch andere Distros ausprobieren (Debian) aber im Moment ist mir das nicht möglich.

Gruß
Dateianhänge
vmware.log
(159.53 KiB) 12-mal heruntergeladen

King of the Hill
Beiträge: 12676
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: 'Share bluetooth devices' geht nicht.

Beitragvon Dayworker » 11.01.2020, 22:50

In der Log-Datei werden 4 USB-Geräte aufgelistet:
2020-01-11T21:00:21.854+01:00| vmx| I125: VUsbUpdateVigorFieldsAndAutoconnect: New set of 4 USB devices
2020-01-11T21:00:21.854+01:00| vmx| I125: USB: Found device [name:SanDisk\ Ultra\ Fit vid:0781 pid:5583 path:2/2 speed:super family:storage,storage-bulk serialnum:4C531001560410116145 arbRuntimeKey:2 version:3]
2020-01-11T21:00:21.855+01:00| vmx| I125: USB: Found device [name:IMC\ Networks\ USB2.0\ VGA\ UVC\ WebCam vid:13d3 pid:5a09 path:1/5 speed:high family:video serialnum:0001 arbRuntimeKey:1 version:3]
2020-01-11T21:00:21.855+01:00| vmx| I125: USB: Found device [name:Intel\ Bluetooth\ Adapter vid:8087 pid:0a2b path:1/8 speed:full family:wireless,bluetooth arbRuntimeKey:3 version:3]
2020-01-11T21:00:21.855+01:00| vmx| I125: USB: Found device [name:Virtual\ Bluetooth\ Adapter vid:0e0f pid:0008 speed:full family:wireless,bluetooth deviceType:virtual-bluetooth info:0000001 version:3]
.
.
.
2020-01-11T21:00:22.005+01:00| vmx| I125: USB: Connecting device desc:name:Virtual\ Bluetooth\ Adapter vid:0e0f pid:0008 speed:full family:wireless,bluetooth deviceType:virtual-bluetooth info:0000001 version:3 id:0x700000010e0f0008
2020-01-11T21:00:22.005+01:00| vmx| I125: Policy_GetUSBDevAccess: checking usb devices at policy path: /vm/#_VMX/mvm/policyState/val/policySet/usbDevices/#
2020-01-11T21:00:22.005+01:00| vmx| I125: Policy_GetUSBDevAccess: allowConnect = YES
2020-01-11T21:00:22.005+01:00| vmx| I125: VUsbUpdateVigorFieldsAndAutoconnect: New set of 4 USB devices
2020-01-11T21:00:22.006+01:00| vmx| I125: USB: Found device [name:SanDisk\ Ultra\ Fit vid:0781 pid:5583 path:2/2 speed:super family:storage,storage-bulk serialnum:4C531001560410116145 arbRuntimeKey:2 version:3]
2020-01-11T21:00:22.006+01:00| vmx| I125: USB: Found device [name:IMC\ Networks\ USB2.0\ VGA\ UVC\ WebCam vid:13d3 pid:5a09 path:1/5 speed:high family:video serialnum:0001 arbRuntimeKey:1 version:3]
2020-01-11T21:00:22.006+01:00| vmx| I125: USB: Found device [name:Intel\ Bluetooth\ Adapter vid:8087 pid:0a2b path:1/8 speed:full family:wireless,bluetooth arbRuntimeKey:3 version:3]
2020-01-11T21:00:22.006+01:00| vmx| I125: USB: Found device [name:Virtual\ Bluetooth\ Adapter vid:0e0f pid:0008 speed:full family:wireless,bluetooth virtPath:usb:2 deviceType:virtual-bluetooth info:0000001 version:3], connected to usb:1 port 0.
Ich sehe leider auch auf dem zweiten Blick nicht, daß das Host-OS das BT-Gerät auch wirklich frei- und damit in die Obhut des Gast-OS übergibt.

Kannst du bitte die VM auf dem langen aber funktionalen Weg mit dem BT-Gerät versorgen und dann das Log wieder hochladen. Hoffentlich ergibt ich dann eine mögliche Ursache.

Member
Beiträge: 5
Registriert: 11.01.2020, 18:49

Re: 'Share bluetooth devices' geht nicht.

Beitragvon 4tmelDriver » 12.01.2020, 12:16

Hier die Logs, wenn ich den Adapter der VM übergebe und nicht die Funktion "Share bluetooth devices" nutze (ich hoffe das war gemeint).
Das funktioniert zwar, bringt aber die o.g. Probleme mit sich.
Dateianhänge
vmware.log
(163.09 KiB) 2-mal heruntergeladen

Member
Beiträge: 5
Registriert: 11.01.2020, 18:49

Re: 'Share bluetooth devices' geht nicht.

Beitragvon 4tmelDriver » 14.01.2020, 13:27

Inzwischen konnte ich auch ausprobieren, ob das Problem auf einem Ubuntu-System besteht (auf dem die Installation des VMware Players im Gegensatz zu Manjaro reibungslos ablief).
Auch hier werden keine Bluetooth Geräte innerhalb des Gasts gefunden. Die Identifikation des zu nutzenden Adapters scheint aber zu klappen, da wie zu erwarten dieser dann nicht mehr als durchschleifbares USB Gerät im VMware Player aufgelistet wird.

Gruß

King of the Hill
Beiträge: 12676
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: 'Share bluetooth devices' geht nicht.

Beitragvon Dayworker » 14.01.2020, 16:11

Zum Log bin ich noch nicht gekommen. Da dein Problem jedoch auch mit dem eher konservativen Ubuntu ebenfalls auftritt, könntest du einen Bug gefunden haben. Schau doch mal im offiziell von VMware unterhaltenen VMTN nach, ob das Problem vielleicht schon in der Beseitigung ist oder ob du der einzigste Nutzer bist.


Zurück zu „VMware Player und VMware Workstation Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast