Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

vCenter-Ldaps

Virtualisierungsmanagement, Servermanagement.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 12
Registriert: 18.11.2009, 14:45

vCenter-Ldaps

Beitragvon sanctuary » 13.03.2020, 12:23

Hallo zusammen,

ich versuche gerade ein vCenter 6.5.0 Build 15259038 nach dieser Anleitung auf ldaps umzustellen:

https://pradeeppapnai.com/2019/09/03/ad-ldaps-vcenter/

Die Angaben stimmen auch soweit und das Zertifikat wird auch eingelesen (grüner Haken mit Gültigkeit).
Leider bricht der Vorgang mit der Meldung:

Vorgang Identitätsquelle hinzuzufügen ist mit dem folgenden Fehler fehlgeschlagen:
"A vCenter Single-Sign-ON service error occurred"

Ich habe sowohl "beliebiger DC" als auch "bestimmter DC" versucht.

Kann es daran liegen, dass die bisherige Identitätsquelle (LDAP Maschinenkonto), die ja auf den gleichen DC verweist, parallel eingetragen ist?
Hat hier jemand einen Rat?

King of the Hill
Beiträge: 13079
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: vCenter-Ldaps

Beitragvon Dayworker » 15.03.2020, 00:30

Bei welchem Schritt und wo da genau kommt die Fehlermeldung? Hast du dich an die im Link ebenfalls aufgelisteten Namenskonventionen gehalten?
Ich würde versuchsweise die vCenter-Oberfläche auf Englsich umstellen, dann hat man meistens deutlich mehr Möglichkeiten zum Suchen in der Suchmaschine seiner Wahl.
Wenn ich dem Link unter Schritt 3 für vCenter6.5/6.7 folge, lande ich bei: "A vCenter Single Sign-On service error occurred", Unable to add or create an AD over LDAP Identity source with SSL protection enabled in vCenter Server 6.5/6.7 (2149697).

Member
Beiträge: 12
Registriert: 18.11.2009, 14:45

Re: vCenter-Ldaps

Beitragvon sanctuary » 16.03.2020, 14:43

Hi,

also ich habe die bestehende Ident.Quelle = AD Windows integriert gelöscht und nun AD über LDAP mit den entsprechenden Werten und einem Zertifikat eingebunden/gespeichert.

ein

Code: Alles auswählen

openssl s_client -connect fqdn.domain.tld:636 -showcert
s
vom ESX zeigt mir auch das Zertifikat an.

Allerdings kann man sich nicht mehr an der WebUI mit einem DomUser anmelden ("falscher Benutzername/Kennwort").
Einen kompletten Reboot der VCSA habe ich auch schon gemacht.
An was kann das liegen?


Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste