Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

VCenter upgrade 4.1 auf 5.1 fehler in der Oracel DB

Virtualisierungsmanagement, Servermanagement.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 26
Registriert: 24.06.2009, 14:24

VCenter upgrade 4.1 auf 5.1 fehler in der Oracel DB

Beitragvon eliottk » 12.12.2012, 09:25

Hallo,

ich bin gerade dabei unser VCenter von 4.1 auf 5.1 upzugraden. Leider hatte ich noch keinen upgrade der nicht mit Fehlern bestückt war, so auch bei diesem. Nun bin ich endlich soweit dass VCenter-Server installiert wurde nur lässt sich der Service nicht starten und es kommt im LOG folgnder Fehler:

2012-12-11T19:04:10.556+01:00 [03876 info 'profilemoHostProfileManager'] [MoHostProfileManager] reading metadata from file: C:\Program Files\VMware\Infrastructure\VirtualCenter Server\categorymeta_klnext.xml
2012-12-11T19:04:10.556+01:00 [03876 info 'profilemoHostProfileManager'] [MoHostProfileManager] reading metadata from file: C:\Program Files\VMware\Infrastructure\VirtualCenter Server\categorymeta_mn.xml
2012-12-11T19:04:10.556+01:00 [03876 info 'profilemoHostProfileManager'] [MoHostProfileManager] reading metadata from file: C:\Program Files\VMware\Infrastructure\VirtualCenter Server\componentmeta_klnext.xml
2012-12-11T19:04:10.556+01:00 [03876 info 'profilemoHostProfileManager'] [MoHostProfileManager] reading metadata from file: C:\Program Files\VMware\Infrastructure\VirtualCenter Server\componentmeta_mn.xml
2012-12-11T19:04:10.556+01:00 [03876 error 'vpxdvpxdMain'] [Vpxd::ServerApp::Init] Init failed: Column DESCRIPTION does not exist in table VPX_TASK
--> Backtrace:
-->
2012-12-11T19:04:10.556+01:00 [03876 warning 'VpxProfiler'] ServerApp::Init [TotalTime] took 7238 ms
2012-12-11T19:04:10.556+01:00 [03876 error 'Default'] Failed to intialize VMware VirtualCenter. Shutting down...
2012-12-11T19:04:10.556+01:00 [03876 info 'vpxdvpxdSupportManager'] Wrote uptime information
2012-12-11T19:04:15.439+01:00 [03588 warning 'VpxProfiler' opID=SWI-e7f6e1a5] VpxUtil_InvokeWithOpId [TotalTime] took 12012 ms
2012-12-11T19:04:27.451+01:00 [03588 warning 'VpxProfiler' opID=SWI-fd652708] VpxUtil_InvokeWithOpId [TotalTime] took 12012 ms
2012-12-11T19:04:39.463+01:00 [03588 warning 'VpxProfiler' opID=SWI-658cc8e8] VpxUtil_InvokeWithOpId [TotalTime] took 12012 ms
2012-12-11T19:04:51.474+01:00 [03588 warning 'VpxProfiler' opID=SWI-1581bce2] VpxUtil_InvokeWithOpId [TotalTime] took 12012 ms
2012-12-11T19:05:03.486+01:00 [03588 warning 'VpxProfiler' opID=SWI-e1a76163] VpxUtil_InvokeWithOpId [TotalTime] took 12012 ms
2012-12-11T19:05:04.064+01:00 [03876 info 'Default'] Forcing shutdown of VMware VirtualCenter now

Ich denke Primär geht es dabei um diese Zeile:

2012-12-11T19:04:10.556+01:00 [03876 error 'vpxdvpxdMain'] [Vpxd::ServerApp::Init] Init failed: Column DESCRIPTION does not exist in table VPX_TASK
--> Backtrace:


Das Problem ist nun dass in der DB die column "DESCRIPTION" vorhanden ist.

Ist schon mal jemand von euch auf dieses Problem aufgelaufen, bzw. hat einen Ansatz wie ich diesen beheben kann?

Die Gesamte Logdatei befindet sich im Anhang.
vpxd-13756.log


vielen Dank.

lg.
Eliottk

King of the Hill
Beiträge: 13079
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 12.12.2012, 09:40

Hier gibt es keine Dateianhänge, beim Hochladen müßtest du auch die übliche Entschuldigung dazu angezeigt bekommen haben.
Nimm also deinen eigenen Webspace oder einen Freehoster dafür. ;)

Benutzeravatar
Guru
Beiträge: 3129
Registriert: 22.02.2008, 20:01
Wohnort: Hessen

Beitragvon PeterDA » 12.12.2012, 13:49

Hi,
hört sich für mich etwas danach an das du den vCenter 5.1 nutzt und nicht die 5.1a.

Gruß Peter

Member
Beiträge: 26
Registriert: 24.06.2009, 14:24

Beitragvon eliottk » 12.12.2012, 14:19

Hallo,

diesen Verdacht hatte ich zuvor auch, es wurde aber definitiv die Version 5.1a heruntergeladen und installiert.

lg.
Eliottk

Profi
Beiträge: 535
Registriert: 04.01.2006, 12:06
Wohnort: Hamm

Beitragvon ostekl1 » 15.12.2012, 16:18

Ich hatte so einen Fehler beim Update von vCenter 4.1 auf 5.0.
Auch ein zweiter Installationsversuch schlug dann fehl, weil in der Oracle DB schon sowas wie "du bist jetzt schon 5.0" eingetragen war.

Einzig der Restore der Datenbank, eine komplette deinstallation vom vCenter incl. reboot mit anschließender Neuinstallation gegen die alte Datenbank hat dann alles wieder ins Leben geholt.
Weil ich zwischendurch immer auf Antworten von VMware Support gewartet habe dauerte dieses Update über 2 Tage.
Jetzt habe ich schon Herzklopfen wenn ich nur and das überfällige Update von 5.0 auf 5.1 denke ;(

King of the Hill
Beiträge: 13079
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 15.12.2012, 19:53

ostekl1 hat geschrieben:Jetzt habe ich schon Herzklopfen wenn ich nur and das überfällige Update von 5.0 auf 5.1 denke ;(
Wenn das 5.1er vCenter beim Funktionstest mit derselben Sorgfalt wie der ESXi5.1 bedacht wurde, würde ich mir das Update vorerst zumindest solange ersparen, bis du erste Server auf die 5.1er Version umgestellt hast. Denn intern hat sich weit mehr verändert, als es die kleine Versionserhöhung vermuten läßt...

Profi
Beiträge: 535
Registriert: 04.01.2006, 12:06
Wohnort: Hamm

Beitragvon ostekl1 » 12.01.2013, 18:53

es hat ja jetzt einen Patch 5.1.0b gegeben. Ist denn damit ggf. irgend etwas besser geworden?
Gibt es hier schon Erfahrungen damit? Vor Allem in größeren Umgebungen (mehr als 100 Hosts).

Experte
Beiträge: 1334
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 12.01.2013, 20:22

nicht das hier das Problem von der VM Service Hauptseite greift:

vCenter Server 5.0 and 5.1 with Oracle issue :
Customers running vCenter Server 5.0 and 5.1 should not patch their Oracle 11.2.0.3 instance to patch10 or later. For more details, see the KB article linked below.

KB 2039874
http://kb.vmware.com/kb/2039874


Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste