Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

SCSI Device für Cluster

Alles zum Virtualisierungsmanagement und Servermanagement, was nicht direkt in ein festes Version-Schema paßt.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 18
Registriert: 29.05.2012, 16:32

SCSI Device für Cluster

Beitragvon muetze87 » 10.08.2012, 08:56

Hallo zusammen,
wollte mal einen "virtuellen"-cluster erstellen.

Umgebung:
1 Host ESX 4.0
4 VM's CS, DC, Node1, Node2 (OS w2k8 R2)
Die nodes sind im Privat und Public Lan
Der Host hat zwei HBA's, insgesamt hängen 4 LUNs dran (gesamt 1TB)

Nun kurz mein Problem ^^
Für den Cluster benötige ich zwei shared disks.
Bin über edit settings gegangen und wollte ein scsi device hinzufügen, leider taucht im drop-down nur das CD/dvd Laufwerk auf.
Joa, wie komme ich nun an eine shared disk?

Gruß muetze

Benutzeravatar
Guru
Beiträge: 3131
Registriert: 22.02.2008, 20:01
Wohnort: Hessen

Beitragvon PeterDA » 10.08.2012, 09:26

Hi,
bist du das hier mal durchgegangen?

http://www.vmware.com/files/de/pdf/vsp_40_mscs_de.pdf

Da sollte alles drin erklärt sein wie es geht.

Gruß Peter

King of the Hill
Beiträge: 12450
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: SCSI Device für Cluster

Beitragvon irix » 10.08.2012, 09:26

muetze87 hat geschrieben:..
Joa, wie komme ich nun an eine shared disk?

Gruß muetze


In dem du die Eigenschaften des SCSI Controllers anpasst.

Gruss
Joerg

Member
Beiträge: 18
Registriert: 29.05.2012, 16:32

Beitragvon muetze87 » 10.08.2012, 10:13

also der scsi controller ist schon richtig erstellt.

Bekomme nun folgende fehlermeldung beim starten der vm's:

... cannot open the virtual disk .... for clustering. Please verify that the virtual disk was created using the 'thick' option. Cannot open the disk ... or one of the snapshot disks it depends on.
Reason: thin/tbz disks cannot be opened in multiwriter mode..

Habe eine neue virtuelle disk erstellt -> 40gb, thin provision, specific datastore -> scsi (0:1), mode: Independen - persistent

Danach bei der 2. vm: existing virtual disk -> pfad angegeben -> scsi (0:1), mode: independen - persistent

achja, habe es auch mit Thick Provision Lazy Zeroed und Thick Provision Eager Zeroed ausprobiert.

Member
Beiträge: 18
Registriert: 29.05.2012, 16:32

Beitragvon muetze87 » 10.08.2012, 10:27

sehr kurios.
Habe gerade den "ursprung" wiederhergestellt. Jetzt erscheind die gleiche Fehlermeldung (also ohne die neue "disk").
Nach dem ich den scsi controller wieder auf "none" gestellt habe, lies sich die vm starten.
ist das normal?

Member
Beiträge: 18
Registriert: 29.05.2012, 16:32

Beitragvon muetze87 » 10.08.2012, 12:52

mit folgender konfiguration funktioniert es:

scsi bus sharing: physical (wieso benutzt man nicht immer physical?)
VHD: Lazy zeroed, independen, peristent
"primäre" VHD (OS): Lazy zeroed

so die zweite platte musste nun als eager zeroed erstellt werden -.-
In der Übersicht steht bei "typ" trotzdem lazy zeroed oO


Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast