Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

vcenter Leistungsüberblick

Alles zum Virtualisierungsmanagement und Servermanagement, was nicht direkt in ein festes Version-Schema paßt.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 1
Registriert: 25.11.2011, 17:38

vcenter Leistungsüberblick

Beitragvon mb89 » 28.11.2011, 08:13

Hallo zusammen,

ich bekomme im vCenter im Leistungsüberblick ein "Die Navigation zur Webseite wurde abgebrochen". Die Registerkarte "erweitert" funktioniert.

Ich habe sämtliche Workarounds welche im Netz kursieren probiert, aber dabei keine Lösung gefunden.

Das Problem besteht seit dem vCenter Update auf die V5. Ich kann es auch schon eingrenzen: Der Std. Port 8443 wird nicht abgehört. Anbei die APACHE Logs:

commons-daemon
[2011-11-28 08:05:22] [info] Stopping service...
[2011-11-28 08:05:23] [error] Failed executing process
[2011-11-28 08:05:23] [error] Das System kann die angegebene Datei nicht finden.
[2011-11-28 08:05:23] [info] Service stopped.
[2011-11-28 08:05:23] [info] Run service finished.
[2011-11-28 08:05:23] [info] Commons Daemon procrun finished


vctomcat-stderr
2011-11-28 08:05:23 Commons Daemon procrun stderr initialized
28.11.2011 08:05:26 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\VMware\Infrastructure\tomcat\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\IBM\Director\bin;C:\Program Files\IBM\Director\tpm\tools
28.11.2011 08:05:26 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-127.0.0.1-8181
28.11.2011 08:05:28 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8443
28.11.2011 08:05:28 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 2047 ms
28.11.2011 08:05:28 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
28.11.2011 08:05:28 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.32
28.11.2011 08:05:28 org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor statsreport.xml
28.11.2011 08:05:30 com.vmware.vim.common.vdb.VdbConfig <init>
INFO: Config name=vcdb
28.11.2011 08:05:30 com.vmware.vim.common.vdb.VdbConfig <init>
INFO: Property file=C:\ProgramData\VMware\VMware VirtualCenter\vcdb.properties
28.11.2011 08:05:30 com.vmware.vim.common.vdb.VdbConfig <init>
INFO: Loaded props={dbtype=mssql, url=jdbc:sqlserver://localhost\SQLEXP_VIM;databaseName=VIM_VCDB;integratedSecurity=true, driver=com.microsoft.sqlserver.jdbc.SQLServerDriver, usevcdb=true}
28.11.2011 08:05:30 com.vmware.vim.common.vdb.VdbConfig <init>
INFO: Overrides=
28.11.2011 08:05:31 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory cim-ui
28.11.2011 08:05:31 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory eam
28.11.2011 08:05:40 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory health-ui
28.11.2011 08:05:40 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ls
28.11.2011 08:05:51 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ROOT
28.11.2011 08:05:51 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory sms
28.11.2011 08:06:04 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory vsm
28.11.2011 08:06:17 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory vws
28.11.2011 08:06:19 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-127.0.0.1-8181
28.11.2011 08:06:19 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8443
28.11.2011 08:06:19 org.apache.jk.common.ChannelSocket init
INFO: Port busy 8009 java.net.BindException: Address already in use: JVM_Bind
28.11.2011 08:06:19 org.apache.jk.common.ChannelSocket init
SCHWERWIEGEND: Can't find free port 8009 8009
28.11.2011 08:06:19 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/27 config=null
28.11.2011 08:06:19 org.apache.catalina.startup.Catalina start
INFO: Server startup in 51826 ms
28.11.2011 08:06:19 org.apache.catalina.core.StandardServer await
SCHWERWIEGEND: StandardServer.await: create[8005]:
java.net.BindException: Address already in use: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:383)
at java.net.ServerSocket.bind(ServerSocket.java:328)
at java.net.ServerSocket.<init>(ServerSocket.java:194)
at org.apache.catalina.core.StandardServer.await(StandardServer.java:406)
at org.apache.catalina.startup.Catalina.await(Catalina.java:676)
at org.apache.catalina.startup.Catalina.start(Catalina.java:628)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
28.11.2011 08:06:19 org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-127.0.0.1-8181
28.11.2011 08:06:19 org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8443
28.11.2011 08:06:20 org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina


vctomcat-stdout
2011-11-28 08:05:23 Commons Daemon procrun stdout initializedException in thread "Thread-28" java.lang.NullPointerException
at com.vmware.vsm.vc.VCenterListener.run(VCenterListener.java:272)
Exception in thread "Thread-63" java.lang.NullPointerException
at org.apache.log4j.LogManager.getLogger(LogManager.java:188)
at org.apache.log4j.Logger.getLogger(Logger.java:104)
at org.apache.commons.logging.impl.Log4JLogger.getLogger(Log4JLogger.java:289)
at org.apache.commons.logging.impl.Log4JLogger.error(Log4JLogger.java:257)
at com.vmware.vim.cimmonitor.qs.provider.impl.QsHelperImpl.createProviderClient(QsHelperImpl.java:432)
at com.vmware.vim.cimmonitor.qs.provider.impl.QsHelperImpl.access$000(QsHelperImpl.java:63)
at com.vmware.vim.cimmonitor.qs.provider.impl.QsHelperImpl$1.run(QsHelperImpl.java:296)
at java.lang.Thread.run(Thread.java:662)
Exception in thread "Thread-35" java.lang.NullPointerException
at org.apache.log4j.LogManager.getLogger(LogManager.java:188)
at org.apache.log4j.Logger.getLogger(Logger.java:104)
at org.apache.commons.logging.impl.Log4JLogger.getLogger(Log4JLogger.java:289)
at org.apache.commons.logging.impl.Log4JLogger.isErrorEnabled(Log4JLogger.java:307)
at com.vmware.vim.health.impl.HealthPollerImpl$PollerThread.run(HealthPollerImpl.java:64)
at java.lang.Thread.run(Thread.java:662)
Exception in thread "Thread-6" java.lang.NullPointerException
at com.vmware.eam.vc.VcListener.run(VcListener.java:366)
Exception in thread "Thread-61" java.lang.NullPointerException
at com.vmware.vim.cimmonitor.inventory.InventoryPoller$1.run(InventoryPoller.java:125)
at java.lang.Thread.run(Thread.java:662)


Kann mir jemand sagen, wie ich die Ports im nachhinein "ändern" kann oder woran es in diesem Fall liegt. Leider kann man die Leistungsindikatoren nicht wie in manchen Beiträgen beschrieben deinstallieren u. neuinstallieren. Wenn ich über Software gehe, kann ich nur den vCenter komplett deinstallieren, nicht aber einzelne Komponenten davon.

Danke für die Hilfe
MB

King of the Hill
Beiträge: 12413
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 28.11.2011, 08:22

Sowas ist ein Fall fuer den VMware Support.

Gruss
Joerg


Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast