Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

vCenter verliert Verbiundung zu Host

Virtualisierungsmanagement, Servermanagement.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 37
Registriert: 12.03.2011, 16:13
Wohnort: 127.0.0.1

vCenter verliert Verbiundung zu Host

Beitragvon pdcemulator » 20.05.2011, 18:41

Hallo,

ich habe einen ESXI 4.1 Host, auf diesem ist ein vCenter auf Win2k8 als Gast installiert. Wenn ich mich mit dem vSphere Client auf den vServer verbinde, verliert er in recht kurzen Abständen (1-2 Minuten) die Verbindung zum ESXi-Host. Nach einem Klick auf "neu verbinden" geht es wieder für ein paar Minuten.

Eine Parallele verbindung mit dem vSphere Client direkt auf den ESXi Host wird nicht unterbrochen.

Auf dem ESXi Host sind keine Fehler in den Ereignissen zu sehen.
Der vCenter loggt dabei immer das Ereigniss "Der Host xxx in xxx reagiert nicht".

Ich habe Host und vCenter mehrfach rebootet und den Host aus dem vCenter entfernt und neu hinzugefügt. Einmal mit DNS (FQDN) Name und auch mit der IP. Beide sind im gleichen Subnetz.

Die Windows-Firewall ist deaktiviert.

Benutzeravatar
Guru
Beiträge: 3129
Registriert: 22.02.2008, 20:01
Wohnort: Hessen

Beitragvon PeterDA » 21.05.2011, 09:09

Hi,
DNS funktioniert in beide Richtungen? Mit lagen und mit kurzen Namen?

Grus Peter

Member
Beiträge: 37
Registriert: 12.03.2011, 16:13
Wohnort: 127.0.0.1

Beitragvon pdcemulator » 22.05.2011, 08:31

Ja, das klappt. Sowohl vom ESXi via SSH als auch vom vCenter kann ich mit nslookup die Hostnamen und den FQDN auf die richtige IP auflösen.


Aus den Logs...

/var/log/vmware/vpx/vpxa.log
[2011-05-22 06:34:28.597 1B7AEB90 warning 'App'] [VpxaHalStats] Unexpected return result. Expect 1 sample, receive 2


/var/log/messages
May 22 06:33:24 Vpxa: [2011-05-22 06:33:24.691 1B934B90 error 'PropertyCache'] Failed to diff 64:datastore, had ManagedObjectReference[], got ManagedObjectReference[]
May 22 06:33:24 Vpxa: [2011-05-22 06:33:24.692 1B934B90 error 'PropertyCache'] Failed to diff 64:network, had ManagedObjectReference[], got ManagedObjectReference[]
May 22 06:33:24 Vpxa: [2011-05-22 06:33:24.692 1B934B90 error 'PropertyCache'] Failed to diff 64:resourcePool, had ManagedObjectReference, got ManagedObjectReference
[...]
May 22 06:37:58 Hostd: [2011-05-22 06:37:58.048 FFEDDB90 verbose 'Proxysvc Req01411'] New proxy client TCP(local=127.0.0.1:56913, peer=127.0.0.1:80)
May 22 06:37:58 Hostd: [2011-05-22 06:37:58.050 253B1B90 info 'Vmomi'] Activation [N5Vmomi10ActivationE:0x261e9320] : Invoke done [waitForUpdates] on [vmodl.query.PropertyCollector:ha-p
May 22 06:37:58 Hostd: [2011-05-22 06:37:58.050 253B1B90 verbose 'Vmomi'] Arg version:
May 22 06:37:58 Hostd: "252"
May 22 06:37:58 Hostd: [2011-05-22 06:37:58.051 253B1B90 info 'Vmomi'] Throw vmodl.fault.RequestCanceled
May 22 06:37:58 Hostd: [2011-05-22 06:37:58.051 253B1B90 info 'Vmomi'] Result:
May 22 06:37:58 Hostd: (vmodl.fault.RequestCanceled) {
May 22 06:37:58 Hostd: dynamicType = <unset>,
May 22 06:37:58 Hostd: faultCause = (vmodl.MethodFault) null,
May 22 06:37:58 Hostd: msg = "",
May 22 06:37:58 Hostd: }
May 22 06:37:58 Hostd: [2011-05-22 06:37:58.052 25E73B90 error 'App'] Failed to read header on stream TCP(local=127.0.0.1:50743, peer=127.0.0.1:0): N7Vmacore15SystemExceptionE(Connectio


Da scheint jemand ein ägnliches Problem zu haben, hat bei mir aber nicht geholfen... http://communities.vmware.com/message/1694296



Edit: Fehler gefunden. In den vCenter Einstellungen war eine falsche IP für den vCenter eingetragen. Ich frage mich wie die da rein kommt, hat es doch vorher funktioniert und an der IP des Hosts gab es keine Änderung. jetzt läuft es auf jeden Fall...


Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast