Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Automatisches anpassen von geklonten Win 2008 R2 Servern

Alles zum Virtualisierungsmanagement und Servermanagement, was nicht direkt in ein festes Version-Schema paßt.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 61
Registriert: 17.06.2006, 12:10

Automatisches anpassen von geklonten Win 2008 R2 Servern

Beitragvon brave_snoopy » 12.05.2011, 11:41

Hallo zusammen,

ich habe ein sehr interessantes Phänomen.
Habe einen Win 2008 R2 Server installiert, dann heruntergeladen und die VM in eine Vorlage konvertiert.

Anschließend habe ich eine neue virtuelle Maschine aus dieser Vorlage bereitgestellt und den Anpassungswizard durchlaufen lassen.

Beim 1. Start hat Windows auch schön sauber Sysprep ausgeführt und die VM angepasst.
diese Anpassungsdatei ist diese:
ich habe jeweils den encryption Key entfernt.
<ConfigRoot>
<_type>vim.CustomizationSpecItem</_type>
<info>
<_type>vim.CustomizationSpecInfo</_type>
<changeVersion>1305043004</changeVersion>
<description/>
<lastUpdateTime>2011-05-10T15:56:44Z</lastUpdateTime>
<name>test</name>
<type>Windows</type>
</info>
<spec>
<_type>vim.vm.customization.Specification</_type>
<globalIPSettings>
<_type>vim.vm.customization.GlobalIPSettings</_type>
</globalIPSettings>
<identity>
<_type>vim.vm.customization.Sysprep</_type>
<guiUnattended>
<_type>vim.vm.customization.GuiUnattended</_type>
<autoLogon>false</autoLogon>
<autoLogonCount>0</autoLogonCount>
<password>
<_type>vim.vm.customization.Password</_type>
<plainText>false</plainText>
<value>9676p8+nK9AIXNFp8RNufY0IaEdMTj9NXHcv2X9CBIkEjPae+MtmiRGBba3Ej9y+NPrvezRt+vwG+1AdoXmexX4lcxqKZxRC608h8FgszRkLJNME0dPKn2crD4Kw58TLim9ZLL4E6VcnCF/CdjYljDr5odfCR3fTavHjZSDayIiynSSxrdMxqabeudOvuDMkmwe6i7lG997AawjFR6019Qe2zW3QAxiDkXUoMDdqlCrUtoc3Yu4n1RubfQaoxYp1tys39Fo1cj8MWoBE2O2BtyBSO3gXmnT6brTvHSifFYeGgxvyEJ+R59NOnvR5SMRm15YY1Q40gE/6u2MsoBZpRg==</value>
</password>
<timeZone>110</timeZone>
</guiUnattended>
<identification>
<_type>vim.vm.customization.Identification</_type>
<joinWorkgroup>WORKGROUP</joinWorkgroup>
</identification>
<licenseFilePrintData>
<_type>vim.vm.customization.LicenseFilePrintData</_type>
<autoMode>perServer</autoMode>
<autoUsers>5</autoUsers>
</licenseFilePrintData>
<userData>
<_type>vim.vm.customization.UserData</_type>
<computerName>
<_type>vim.vm.customization.FixedName</_type>
<name>testserver</name>
</computerName>
<fullName>Test</fullName>
<orgName>test</orgName>
<productId/>
</userData>
</identity>
<nicSettingMap>
<_length>1</_length>
<_type>vim.vm.customization.AdapterMapping[]</_type>
<e id="0">
<_type>vim.vm.customization.AdapterMapping</_type>
<adapter>
<_type>vim.vm.customization.IPSettings</_type>
<ip>
<_type>vim.vm.customization.DhcpIpGenerator</_type>
</ip>
</adapter>
</e>
</nicSettingMap>
<options>
<_type>vim.vm.customization.WinOptions</_type>
<changeSID>true</changeSID>
<deleteAccounts>false</deleteAccounts>
</options>
</spec>
</ConfigRoot>


Einen Tag später wollte ich erneut einen Server aus der Vorlage bereit stellen. Habe den Wizard genutzt und nicht die abgespeicherte Anpassungsdatei genommen, sondern eine neue. Hiermit wird beim 1. Start des Server keine Anpassungs durchgeführt. Der Server fährt nur hoch und ist als geklonter Server vorhanden. Warum?

Nutz ich die andere Anpassungsvorlage wieder, dann funktioniert alles. Nur mit der neuen nicht mehr. Ich kann auch versuchen, was ich möchte, ich bekomme keine Anpassung mehr hin.
esx Server 4.1
vCenter 4.1 Build 258902

Jemand eine Idee? Hier die Anpassungsdatei, die nicht geht.

<ConfigRoot>
<_type>vim.CustomizationSpecItem</_type>
<info>
<_type>vim.CustomizationSpecInfo</_type>
<changeVersion>1305192179</changeVersion>
<description/>
<lastUpdateTime>2011-05-12T09:22:59Z</lastUpdateTime>
<name>testdemo</name>
<type>Windows</type>
</info>
<spec>
<_type>vim.vm.customization.Specification</_type>

<globalIPSettings>
<_type>vim.vm.customization.GlobalIPSettings</_type>
</globalIPSettings>
<identity>
<_type>vim.vm.customization.Sysprep</_type>
<guiUnattended>
<_type>vim.vm.customization.GuiUnattended</_type>
<autoLogon>false</autoLogon>
<autoLogonCount>0</autoLogonCount>
<password>
<_type>vim.vm.customization.Password</_type>
<plainText>false</plainText>
<value>vpSrELg5nej+Ei7i1A5ksZbDOt/y6yvM6h329io9ywo+2f6BP8fKWx7xvfEt7ke7P/wBPPSmnkTqwNmcp7zkuQ0gkifpgAUTgwZTi0UgY4XHyfCTnitKzvjZxDaTO2ujvwHbRiXcPHHap78EGejVELtg55ZSwO5U19N3n5dyBEOCr/pjYi6sXWEGVYBIRlmOG/mXHc9R6OrXyYwhG5ZogAGq6hrrTkaHNoDxwstNapm3T/mvhYXvFz7GZ11XgqeFI4moKGP7Sq+cH7Y8obRu92qPWoF71tYbOu9a5vAstR17J3kvwYjwtC4YI2XzCO8va6BUkRyPDltvzeEAelXQTA==</value>
</password>
<timeZone>110</timeZone>
</guiUnattended>
<identification>
<_type>vim.vm.customization.Identification</_type>
<joinWorkgroup>WORKGROUP</joinWorkgroup>
</identification>
<licenseFilePrintData>
<_type>vim.vm.customization.LicenseFilePrintData</_type>
<autoMode>perServer</autoMode>
<autoUsers>5</autoUsers>
</licenseFilePrintData>
<userData>
<_type>vim.vm.customization.UserData</_type>
<computerName>
<_type>vim.vm.customization.FixedName</_type>
<name>demotest</name>
</computerName>
<fullName>asd</fullName>
<orgName>asd</orgName>
<productId/>
</userData>
</identity>
<nicSettingMap>
<_length>1</_length>
<_type>vim.vm.customization.AdapterMapping[]</_type>
<e id="0">
<_type>vim.vm.customization.AdapterMapping</_type>
<adapter>
<_type>vim.vm.customization.IPSettings</_type>
<ip>
<_type>vim.vm.customization.DhcpIpGenerator</_type>
</ip>
</adapter>
</e>
</nicSettingMap>
<options>
<_type>vim.vm.customization.WinOptions</_type>
<changeSID>true</changeSID>
<deleteAccounts>false</deleteAccounts>
</options>
</spec>
</ConfigRoot>

Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast