Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

VCB Snapshot läuft nicht

Virtualisierungsmanagement, Servermanagement.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 68
Registriert: 02.03.2009, 09:17
Wohnort: Ruhrpott

VCB Snapshot läuft nicht

Beitragvon Zaphod.Beeblebrox » 18.05.2010, 09:38

Hallo,

Habe gerade unseren Backup Server neu aufgesetzt und auch das vcb neu installiert.
Ich nutze den vcbmounter in der Version 1.5.0 build-226297
Nach der Neuinstallation funktionieren alle Snapshots bis auf Einen wunderbar.
Bei folgendem Befehl
"C:\Program Files (x86)\VMware\VMware Consolidated Backup Framework\vcbmounter.exe" -h 10.25.10.26 -u XXX -p XXX -a ipaddr:10.25.10.31 -r c:\VMWARE_ORACLE\SMGE131 -t fullvm -m nbd
oder auch
"C:\Program Files (x86)\VMware\VMware Consolidated Backup Framework\vcbmounter.exe" -h 10.25.10.26 -u XXX -p XXX -a name:SMGE131 -r c:\VMWARE_ORACLE\SMGE131 -t fullvm -m nbd

kommt folgendes Ergebnis:

C:\SCRIPTS>"C:\Program Files (x86)\VMware\VMware Consolidated Backup Framework\v
cbmounter.exe" -h 10.25.10.26 -u XXX -p XXX -a name:SMGE131 -r c
:\VMWARE_ORACLE\SMGE131 -t fullvm -m nbd
[2010-05-17 16:13:41.887 'App' 4980 info] Current working directory: C:\SCRIPTS
[2010-05-17 16:13:41.895 'BaseLibs' 4980 info] HOSTINFO: Seeing Intel CPU, numCo
resPerCPU 2 numThreadsPerCore 1.
[2010-05-17 16:13:41.895 'BaseLibs' 4980 info] HOSTINFO: This machine has 1 phys
ical CPUS, 2 total cores, and 2 logical CPUs.
[2010-05-17 16:13:42.663 'BaseLibs' 4980 info] Using system libcrypto, version 9
0709F
[2010-05-17 16:13:42.685 'BaseLibs' 4980 warning] SSLVerifyCertAgainstSystemStor
e: Subject mismatch: VMware vs 10.25.10.26
[2010-05-17 16:13:42.717 'BaseLibs' 4980 warning] SSLVerifyCertAgainstSystemStor
e: The remote host certificate has these problems:

* The host name used for the connection does not match the subject name on the h
ost certificate

* A certificate in the host's chain is based on an untrusted root.
[2010-05-17 16:13:42.892 'BaseLibs' 4980 warning] SSLVerifyIsEnabled: failed to
read registry value. Assuming verification is disabled. LastError = 0
[2010-05-17 16:13:42.942 'BaseLibs' 4980 warning] SSLVerifyCertAgainstSystemStor
e: Certificate verification is disabled, so connection will proceed despite the
error
[2010-05-17 16:13:55.730 'vcbMounter' 4980 error] Error: Other error encountered
: Snapshot creation failed: Custom pre-freeze script failed.
[2010-05-17 16:13:55.836 'vcbMounter' 4980 error] An error occurred, cleaning up
...
Deleted directory c:\VMWARE_ORACLE\SMGE131

wobei die letzten Zeilen abweichen von den anderen Sicherungen:

[2010-05-17 16:13:55.730 'vcbMounter' 4980 error] Error: Other error encountered
: Snapshot creation failed: Custom pre-freeze script failed.
[2010-05-17 16:13:55.836 'vcbMounter' 4980 error] An error occurred, cleaning up
...

woran kann das liegen?

Hajo

Benutzeravatar
Moderator
Beiträge: 3476
Registriert: 23.02.2005, 09:14
Wohnort: Burgberg im Allgäu
Kontaktdaten:

Beitragvon Tschoergez » 18.05.2010, 23:03

Hi,

sind die VMware-Tools in der VM akutell?

was macht denn dein Pre-freeze-Script? liegt es an der richtigen Stellen?

sind die ESX-server entsprechend gepatched, dass die VCB-Version supported ist?

welche VCB-Version hattet ihr vorher im Einsatz? funktionierts mit der noch?

viele grüße,
jörg

Member
Beiträge: 68
Registriert: 02.03.2009, 09:17
Wohnort: Ruhrpott

Beitragvon Zaphod.Beeblebrox » 19.05.2010, 09:12

Hallo Jörg,

wunderbare Tipps, habe ich auch gefunden beim googlen ....

Besten Dank.

Also, die Tools waren aktuell, habe ich nochmals installiert, hat nichts gebarcht.

Die ESX Server sind gut, denn VCB lief ja vorher auch.

Die alte Version lief auch nimmer.

Des Rätsels Lösung erwähntest Du aber auch:
Ich habe das
Pre-freeze-Script
umbenannt und danach lief der Snapshot wunderbar.
Ist es schlimm, wenn es Keines gibt?

Da scheint sich Symantec unschön eingetragen zu haben.

Paul

Benutzeravatar
Moderator
Beiträge: 3476
Registriert: 23.02.2005, 09:14
Wohnort: Burgberg im Allgäu
Kontaktdaten:

Beitragvon Tschoergez » 19.05.2010, 22:01

kommt drauf an, was das pre-freeze-script macht :grin:

normalerweise wird hier dafür gesorgt, dass Gast-OS und v.a. die Applikation in einem konsistenten Zustand ist vor dem Erstellen des Snapshots (und damit das Backup auch konsistent ist).

Ist aber (dank VSS-Integration) nicht immer notwendig, das man ein pre-freeze-script braucht.

Du solltest auf jeden Fall im neuen System auch ausführlich mal restores testen!

viele grüße,
jörg


Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste