Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Gast von Host B nach A migrieren, Zeitüberschreitungsfehler

Virtualisierungsmanagement, Servermanagement.

Moderatoren: Dayworker, continuum, Tschoergez, irix, stefan.becker

Member
Beiträge: 68
Registriert: 19.11.2008, 11:39

Gast von Host B nach A migrieren, Zeitüberschreitungsfehler

Beitragvon netzlaff » 20.11.2008, 13:25

Hallo,

habe ein Problem beim Migrieren eines Gastes von Host B nach A. Der Vorgang springt sofort auf 10% und dann geschiet nichts mehr, bis VC mir den Fehler bringt: "Zeitüberschreitung beim Vorgang."

Unter Ereignisse steht zu diesem Vorgang folgendes:

20.11.2008 13:20:36, Gast wurde nicht von HostB nach HostA in MeinCluster migriert.
20.11.2008 13:19:29, Gast wird von HostB in MeinCluster migriert.
20.11.2008 13:19:11, Gast wird von HostB nach HostA in MeinCluster migriert
20.11.2008 13:19:11, Aufgabe: Virtuelle Maschine migrieren

Wie kann ich weitere Details zu diesem Vorgang einsehen, bspw. Fehlermeldungen etc.

Heute Vormittag habe ich die Maschine bereits erfolgreich von HostA zu HostB migriert, und das im laufenden Betrieb...

Kann mir jemand helfen?

Jenseits von Gut & Böse
Beiträge: 11513
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 20.11.2008, 13:37

In hostd.log und messages auf deinem ESX. Des Weiteren hilft es den VI Client in engl. Sprache zu betreiben weil man dann mit den Suchbefriffen in google und VMTN bzw. KB fuendig werden koennte.

Gruss
Joerg

Benutzeravatar
Moderator
Beiträge: 3476
Registriert: 23.02.2005, 09:14
Wohnort: Burgberg im Allgäu
Kontaktdaten:

Beitragvon Tschoergez » 20.11.2008, 14:27

und schau mal die vmkernel logs der ESX an. (var/log/vmkernel). da sieht man, ob der Ziel ESX die VM bekommt, usw...

Häufige Fehler:
Namensauflösung passt nicht
IP-Adressen /Netzwerkeinstellungen für den vmkernel Port passen nicht
nicht genügend Resourcen auf dem Ziel ESX

Viele Grüße,
Jörg

Member
Beiträge: 68
Registriert: 19.11.2008, 11:39

Beitragvon netzlaff » 20.11.2008, 14:35

Okay danke schon mal.

Es schein so, als würde HostB HostA nicht finden.

/var/log/vmkernel:

Code: Alles auswählen

Nov 20 14:28:00 vmware2 vmkernel: 0:02:58:10.299 cpu1:1025)StorageMonitor: 196: vmhba32:0:0:0 status = 24/0 0x0 0x0 0x0
Nov 20 14:28:06 vmware2 vmkernel: 0:02:58:16.495 cpu2:1093)Migrate: vm 1116: 7338: Setting migration info ts = 1227187693687500, src ip = <192.168.2.2> dest ip = <192.168.2.1> Dest wid = 1147 using SHARED swap
Nov 20 14:28:06 vmware2 vmkernel: 0:02:58:16.495 cpu2:1093)World: vm 1124: 900: Starting world migSendHelper-1116 with flags 1
Nov 20 14:28:06 vmware2 vmkernel: 0:02:58:16.495 cpu2:1093)World: vm 1125: 900: Starting world migRecvHelper-1116 with flags 1
Nov 20 14:28:06 vmware2 vmkernel: 0:02:58:16.496 cpu3:1124)WARNING: MigrateNet: 398: 1227187693687500: Connect to <192.168.2.1>:8000 failed: I/O error
Nov 20 14:28:06 vmware2 vmkernel: 0:02:58:16.496 cpu3:1124)WARNING: Migrate: 1243: 1227187693687500: Failed: I/O error (0xbad000a) @0x981d5f
Nov 20 14:28:06 vmware2 vmkernel: 0:02:58:16.496 cpu1:1116)WARNING: Migrate: 7054: No migration found for vmm leader 1116.


/var/log/vmware/hostd.log:

Code: Alles auswählen

[2008-11-20 14:28:06.507 'VMotion' 53570480 info] InitiateSource [1227187693687500], WID = 1147
[2008-11-20 14:28:06.507 'vm:/vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx' 53570480 info] GetWid: returning 1116
[2008-11-20 14:28:06.514 'vm:/vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx' 53570480 info] VMotionInitiateSrc (1227187693687500): wid=1147
[2008-11-20 14:28:06.515 'BaseLibs' 24927152 info] Disconnect check in progress: /vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx
[2008-11-20 14:28:06.557 'BaseLibs' 24927152 info] Disconnect check in progress: /vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx
[2008-11-20 14:28:06.557 'BaseLibs' 24927152 info] Disconnect check in progress: /vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx
[2008-11-20 14:28:06.557 'vm:/vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx' 29309872 info] Question info: Migration to host <192.168.2.1> failed with error I/O error (0xbad000a)
, Id: 4 : Type : 2, Default: 0, Number of options: 1
[2008-11-20 14:28:06.558 'BaseLibs' 24927152 info] Disconnect check in progress: /vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx
[2008-11-20 14:28:06.558 'VMotionSrc (1227187693687500)' 53570480 info] ResolveCb: VMX reports gone = false
[2008-11-20 14:28:06.558 'VMotionSrc (1227187693687500)' 53570480 info] ResolveCb: Failed with fault: (vmodl.fault.SystemError) {
   dynamicType = <unset>,
   reason = "Migration failed while copying data.  I/O error.
",
   msg = ""
}
[2008-11-20 14:28:06.558 'vm:/vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx' 53570480 info] State Transition (VM_STATE_EMIGRATING -> VM_STATE_ON)
[2008-11-20 14:28:06.559 'vm:/vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx' 53570480 info] VMotion cleanup completed
[2008-11-20 14:28:06.559 'vm:/vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx' 3076440992 warning] Received a duplicate transition from foundry: 1
[2008-11-20 14:28:06.559 'vm:/vmfs/volumes/492192e8-cdb9c423-64fe-001e4ffd13e2/router/router.vmx' 29309872 warning] Failed to find activation record, event user unknown.
[2008-11-20 14:28:06.560 'ha-eventmgr' 29309872 info] Event 45 : Message on router on vmware2.unitool-vm.local in ha-datacenter: Migration to host <192.168.2.1> failed with error I/O error (0xbad000a)

[2008-11-20 14:28:06.598 'TaskManager' 22219696 info] Task Created : haTask-ha-root-pool-vim.ResourcePool.updateConfig-1109
[2008-11-20 14:28:06.599 'TaskManager' 22219696 info] Task Completed : haTask-ha-root-pool-vim.ResourcePool.updateConfig-1109



Ich schätze dass ich beim VMotion VMKernel was falsch eingestellt habe. Aber warum ging es schon einmal? Ich vmware1(HostA) hat die 192.168.2.1 als IP-Adresse für VMotion und der vmware2 (HostB) die 2.2 beides ohne Gateway für den VMKernel.

Benutzeravatar
Moderator
Beiträge: 3476
Registriert: 23.02.2005, 09:14
Wohnort: Burgberg im Allgäu
Kontaktdaten:

Beitragvon Tschoergez » 20.11.2008, 15:04

probier mal mit
vmkping

jeweils die anderen kernel ports anzupingen, evtl. gibts ein problem mit dem netzwerk (danach siehts aus....)
grüße,
jörg

Member
Beiträge: 68
Registriert: 19.11.2008, 11:39

Beitragvon netzlaff » 20.11.2008, 15:08

Ja wie du schon sagst, liegt anscheinend daran. Kann nur die eigene IP über vnkping anpingen, die vom anderen ESX nicht. Wo liegt denn da der Schnitzer?

Benutzeravatar
Moderator
Beiträge: 3476
Registriert: 23.02.2005, 09:14
Wohnort: Burgberg im Allgäu
Kontaktdaten:

Beitragvon Tschoergez » 20.11.2008, 15:47

naja, das geht jetzt von netzwerkkabel defekt, über kaputten switch zu nicht im gleichen netzwerk verbdundenen netzwerkkarten und falschen nic teaming einstellungen.....

Da musst Du mehr über Deine Netzwerkkonfig erzählen, evtl. mal versuchen, den VMkernel port auf nen anderen vSwitch zu hängen, von außen die beiden ports anpingen versuchen usw.

Member
Beiträge: 68
Registriert: 19.11.2008, 11:39

Beitragvon netzlaff » 20.11.2008, 16:03

Echt merkwürdig. Habe den VMotion VMKernel jetzt von meinem vSwitch0 genommen und auf den vSwitch1, worauf auch mein iSCSI läuft, gelegt und dort jetzt eine Maschine von B nach A und von A nach B geschoben, das hat funktioniert. Warum auch immer...


Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste