Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Gateway bei NAT

VMware auf dem MAC

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 22
Registriert: 16.12.2009, 13:53

Gateway bei NAT

Beitragvon pronto » 16.12.2009, 14:10

Hi Community,

ich habe ein Windows Testsystem in Fusion 3 über NAT an das lokale LAN angebunden und wollte dieses Gastsystem vom lokalen LAN aus erreichen. Um die Routingtable eines Clients im LAN so zu modifizieren, dass das Fusion 3 gastsystem erreicht werden kann, wollte ich eine Route ins Fusion Netz 192.168.94.0/24 über die LAN IP des Hostsystems (als Gateway) eintragen. Bei der Kontrolle der Routingtable des Fusion Hostsystems ist dann aber etwas aufgefallen, was ich so nicht richtig deuten kann:

Code: Alles auswählen

dtps-Mac-mini:~ dtp$ netstat -r
Routing tables

Internet:
Destination        Gateway            Flags        Refs      Use   Netif Expire
default            192.168.110.199    UGSc           43        2     en0
127                localhost          UCS             0        0     lo0
localhost          localhost          UH              0      288     lo0
169.254            link#4             UCS             0        0     en0
172.16.208/24      link#7             UC              0        0  vmnet1
192.168.94         link#8             UC              0        0  vmnet8
192.168.110        link#4             UCS             5        0     en0
galaxy-1.kastner.l 0:30:48:81:e6:8c   UHLWI           6     1132     en0   1170
galaxy-2.kastner.l 0:30:48:80:b2:20   UHLWI          10       92     en0   1197
universe-1.kastner 0:30:48:2d:78:42   UHLWI           0     1817     en0   1190
192.168.110.101    0:c0:ee:33:7a:ac   UHLWI           0      252     en0   1042
192.168.110.185    localhost          UHS             0        0     lo0
192.168.110.199    0:30:48:73:6d:3a   UHLWI          43        1     en0    908

Internet6:
Destination        Gateway            Flags         Netif Expire
localhost          localhost          UH              lo0
fe80::%lo0         localhost          Uc              lo0
localhost          link#1             UHL             lo0


Was bedeutet der Gateway Eintrag link#4, link#7 bzw. link#8? Hier hätte ich eine Hostadresse erwartet.

Hier noch der Vollständigkeit wegen der Output von ipconfig auf dem VM Windows Testsystem:

Code: Alles auswählen

Windows-IP-Konfiguration

   Hostname  . . . . . . . . . . . . : VMWIN-7
   Prim„res DNS-Suffix . . . . . . . :
   Knotentyp . . . . . . . . . . . . : Hybrid
   IP-Routing aktiviert  . . . . . . : Nein
   WINS-Proxy aktiviert  . . . . . . : Nein
   DNS-Suffixsuchliste . . . . . . . : localdomain

Ethernet-Adapter LAN-Verbindung:

   Verbindungsspezifisches DNS-Suffix: localdomain
   Beschreibung. . . . . . . . . . . : Intel(R) PRO/1000 MT-Netzwerkverbindung
   Physikalische Adresse . . . . . . : 00-0C-29-4B-A4-D7
   DHCP aktiviert. . . . . . . . . . : Ja
   Autokonfiguration aktiviert . . . : Ja
   IPv4-Adresse  . . . . . . . . . . : 192.168.94.128(Bevorzugt)
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0
   Lease erhalten. . . . . . . . . . : Mittwoch, 16. Dezember 2009 13:42:11
   Lease l„uft ab. . . . . . . . . . : Mittwoch, 16. Dezember 2009 14:27:12
   Standardgateway . . . . . . . . . : 192.168.94.2
   DHCP-Server . . . . . . . . . . . : 192.168.94.254
   DNS-Server  . . . . . . . . . . . : 192.168.94.2
   NetBIOS ￾ber TCP/IP . . . . . . . : Aktiviert

Tunneladapter isatap.localdomain:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix: localdomain
   Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter
   Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP aktiviert. . . . . . . . . . : Nein
   Autokonfiguration aktiviert . . . : Ja

Tunneladapter LAN-Verbindung* 4:

   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP aktiviert. . . . . . . . . . : Nein
   Autokonfiguration aktiviert . . . : Ja
   IPv6-Adresse. . . . . . . . . . . : 2001:0:d5c7:a2d6:18db:1611:3f57:a17f(Bevorzugt)
   Verbindungslokale IPv6-Adresse  . : fe80::18db:1611:3f57:a17f%12(Bevorzugt)
   Standardgateway . . . . . . . . . : ::
   NetBIOS ￾ber TCP/IP . . . . . . . : Deaktiviert


und eines ifconfig auf dem Hostsystem:

Code: Alles auswählen

dtps-Mac-mini:VMware Fusion dtp$ sudo ifconfig -a
Password:
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
   inet6 ::1 prefixlen 128
   inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
   inet 127.0.0.1 netmask 0xff000000
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
   inet 192.168.110.185 netmask 0xffffff00 broadcast 192.168.110.255
   ether 00:26:4a:0d:c0:1c
   media: autoselect (100baseTX <full-duplex,flow-control>) status: active
   supported media: none autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,flow-control> 10baseT/UTP <full-duplex,hw-loopback> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,flow-control> 100baseTX <full-duplex,hw-loopback> 1000baseT <full-duplex> 1000baseT <full-duplex,flow-control> 1000baseT <full-duplex,hw-loopback>
en1: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
   ether 00:26:08:eb:c2:3b
   media: autoselect (<unknown type>) status: inactive
   supported media: autoselect
fw0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 4078
   lladdr 00:26:4a:ff:fe:0d:c0:1c
   media: autoselect <full-duplex> status: inactive
   supported media: autoselect <full-duplex>
vmnet1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
   inet 172.16.208.1 netmask 0xffffff00 broadcast 172.16.208.255
   ether 00:50:56:c0:00:01
vmnet8: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
   inet 192.168.94.1 netmask 0xffffff00 broadcast 192.168.94.255
   ether 00:50:56:c0:00:08
dtps-Mac-mini:VMware Fusion dtp$


Wie muss ich das Routing zu einer geNATteten VM einstellen?

Danke fürs Lesen und By Tom

Member
Beiträge: 22
Registriert: 16.12.2009, 13:53

Beitragvon pronto » 16.12.2009, 21:57

Hi,

ich muss meinen eigenen Holzweg korrigieren - so sorry. Über NAT kann per Definition gar nicht geroutet werden sondern muss über NAT Port Forwarding gemanaged werden. Manchmal ist es besser mal etwas Abstand zu den Bäumen zu haben um den Wald zu sehen... ;-)

Das Portforwarding kann in der /Library/Application Support/VMware Fusion/vmnet8/nat.conf eingestellt werden.

Bye Tom


Zurück zu „Fusion“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast