Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Solaris 10 und SSH Problem

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 9
Registriert: 13.09.2006, 10:39

Solaris 10 und SSH Problem

Beitragvon Manu64 » 13.09.2006, 10:58

Hallo,
ich habe ueber VMWARE Server auf XP Solaris 10 installiert.
Das System laeuft ueber ein LAN, wobei der Solaris ueber DHCP konfiguriert wurde.
Nun ich kann dareueber mein Gateway, der ein Debian Kiste ist anpingen und
auch ueberall ins Netz gehen. Aber nicht im LAN.

Das Problem liegt daran, dass ich kein SSH Verbindung zum Gateway(Debian) aufbauen kann.

Daemon fuer SSH auf beide Kisten laufen.
Paar Infos vom Solaris:

# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
inet 127.0.0.1 netmask ff000000
e1000g0: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 2
inet 192.168.10.128 netmask ffffff00 broadcast 192.168.10.255
ether 0:c:29:3a:8d:c0

# netstat -rn

Routing Table: IPv4
Destination Gateway Flags Ref Use Interface
-------------------- -------------------- ----- ----- ------ ---------
192.168.10.0 192.168.10.128 U 1 3 e1000g0
224.0.0.0 192.168.10.128 U 1 0 e1000g0
default 192.168.10.10 UG 1 21 e1000g0
127.0.0.1 127.0.0.1 UH 27 3438 lo0

# nslookup www.google.de
Server: 192.168.10.10
Address: 192.168.10.10#53

Non-authoritative answer:
www.google.de canonical name = www.google.com.
www.google.com canonical name = www.l.google.com.
Name: www.l.google.com
Address: 66.249.85.99
Name: www.l.google.com
Address: 66.249.85.104

# ps -eaf | grep ssh
root 353 1 0 11:22:06 ? 0:00 /usr/lib/ssh/sshd
root 839 832 0 11:50:07 pts/4 0:00 grep ssh

# ssh localhost klappt auch.

# ping 192.168.10.10
192.168.10.10 is alive

#ssh 192.168.10.10 klappt nicht.

Waere fuer jede Hilfe Dankbar.

Gruss
Manu

Benutzeravatar
Moderator
Beiträge: 14752
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 13.09.2006, 14:54

Hi
poste doch mal die sshd.conf oder wie das Teil unter Solaris heisst ...

Ulli

Member
Beiträge: 9
Registriert: 13.09.2006, 10:39

Beitragvon Manu64 » 13.09.2006, 16:11

continuum hat geschrieben:Hi
poste doch mal die sshd.conf oder wie das Teil unter Solaris heisst ...

Ulli


Hallo Ulli,
anbei die sshd_conf. Ich habe die Kommentaren drin gelassen.
Ist es richtig, dass ich von der virt. Maschine in dem Fall Solaris mit der IP 192.168.10.128 die pysikalische Kiste also XP mit der IP 192.168.10.20
anpingen kann, soll? Denn es klappt auch nicht.

Vielen Dank und GRuss
Manu


----------------------------------------------------------------------------------------------------------------------------
# Copyright 2004 Sun Microsystems, Inc. All rights reserved.
# Use is subject to license terms.
#
# ident "@(#)sshd_config 1.8 04/05/10 SMI"
#
# Configuration file for sshd(1m)

# Protocol versions supported
#
# The sshd shipped in this release of Solaris has support for major versions
# 1 and 2. It is recommended due to security weaknesses in the v1 protocol
# that sites run only v2 if possible. Support for v1 is provided to help sites
# with existing ssh v1 clients/servers to transition.
# Support for v1 may not be available in a future release of Solaris.
#
# To enable support for v1 an RSA1 key must be created with ssh-keygen(1).
# RSA and DSA keys for protocol v2 are created by /etc/init.d/sshd if they
# do not already exist, RSA1 keys for protocol v1 are not automatically created.

# Uncomment ONLY ONE of the following Protocol statements.

# Only v2 (recommended)
Protocol 2

# Both v1 and v2 (not recommended)
#Protocol 2,1

# Only v1 (not recommended)
#Protocol 1

# Listen port (the IANA registered port number for ssh is 22)
Port 22

# The default listen address is all interfaces, this may need to be changed
# if you wish to restrict the interfaces sshd listens on for a multi homed host.
# Multiple ListenAddress entries are allowed.

# IPv4 only
#ListenAddress 0.0.0.0
# IPv4 & IPv6
ListenAddress ::

# Port forwarding
AllowTcpForwarding no

# If port forwarding is enabled, specify if the server can bind to INADDR_ANY.
# This allows the local port forwarding to work when connections are received
# from any remote host.
GatewayPorts no

# X11 tunneling options
X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes

# The maximum number of concurrent unauthenticated connections to sshd.
# start:rate:full see sshd(1) for more information.
# The default is 10 unauthenticated clients.
#MaxStartups 10:30:60
# Banner to be printed before authentication starts.
#Banner /etc/issue

# Should sshd print the /etc/motd file and check for mail.
# On Solaris it is assumed that the login shell will do these (eg /etc/profile).
PrintMotd no

# KeepAlive specifies whether keep alive messages are sent to the client.
# See sshd(1) for detailed description of what this means.
# Note that the client may also be sending keep alive messages to the server.
KeepAlive yes

# Syslog facility and level
SyslogFacility auth
LogLevel info

#
# Authentication configuration
#

# Host private key files
# Must be on a local disk and readable only by the root user (root:sys 600).
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key

# Default Encryption algorithms and Message Authentication codes
#Ciphers aes128-ctr,aes128-cbc,arcfour,3des-cbc,blowfish-cbc
#MACS hmac-md5,hmac-sha1,hmac-sha1-96,hmac-md5-96

# Length of the server key
# Default 768, Minimum 512
ServerKeyBits 768

# sshd regenerates the key every KeyRegenerationInterval seconds.
# The key is never stored anywhere except the memory of sshd.
# The default is 1 hour (3600 seconds).
KeyRegenerationInterval 3600

# Ensure secure permissions on users .ssh directory.
StrictModes yes

# Length of time in seconds before a client that hasn't completed
# authentication is disconnected.
# Default is 600 seconds. 0 means no time limit.
LoginGraceTime 600

# Maximum number of retries for authentication
# Default is 6. Default (if unset) for MaxAuthTriesLog is MaxAuthTries / 2
MaxAuthTries 6
MaxAuthTriesLog 3

# Are logins to accounts with empty passwords allowed.
# If PermitEmptyPasswords is no, pass PAM_DISALLOW_NULL_AUTHTOK
# to pam_authenticate(3PAM).
PermitEmptyPasswords no

# To disable tunneled clear text passwords, change PasswordAuthentication to no.
#IgnoreUserKnownHosts yes

# Is pure RSA authentication allowed.
# Default is yes
RSAAuthentication yes

Benutzeravatar
Moderator
Beiträge: 14752
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 13.09.2006, 16:24

Hi
was hat dein Solaris fuer eine vmnet Konfiguration?
bridged,nat oder was?

Member
Beiträge: 9
Registriert: 13.09.2006, 10:39

Beitragvon Manu64 » 13.09.2006, 16:59

continuum hat geschrieben:Hi
was hat dein Solaris fuer eine vmnet Konfiguration?
bridged,nat oder was?


NAT

Gruss
Manu

Member
Beiträge: 9
Registriert: 13.09.2006, 10:39

Beitragvon Manu64 » 13.09.2006, 17:20

Ich habe den SSH debugget und bekam die Meldung
-----------------------------------------------------------------------------------------------------------------
Sun_SSH_1.1, SSH-Protokolle 1.5/2.0, OpenSSL 0x0090704f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: ssh_connect: needpriv 0
debug1: Connecting to 192.168.10.10 [192.168.10.10] port 22.
debug1: Connection established.
debug1: identity file /home/manu/.ssh/identity type -1
debug1: identity file /home/manu/.ssh/id_rsa type -1
debug1: identity file /home/manu/.ssh/id_dsa type -1
ssh_exchange_identification: Verbindung wurde durch entfernten Host beendet
debug1: Calling cleanup 0x8070c6c(0x0)
-------------------------------------------------------------------------------------------------------------------------
Was mir aufgefallen ist, liest er wohl die ssh_config und da ist alles auskommeniert.
Hmmm ich dachte, dass er die sshd_config liest...


Gruss
Manu

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 13.09.2006, 18:18

Warum denn NAT? Gib dem armen Solaris doch ein bridged Interface.
Ein Server-OS mit DHCP? Strange... Ich verwende bei Solaris immer nur feste IPs. Bei festen Ips sind folgende Files wichtig:

-1-
/etc/resolv.conf => hier DNS-Server, Solaris prüft, ob es beim DNS auch registriert ist, sonst meckert es

Bsp:
domain local
nameserver 192.168.0.1

-2-
/etc/hosts

Bsp:
127.0.0.1 localhost
192.168.0.6 saturn loghost

-3-
/etc/defaultrouter

Bsp:
192.168.0.1

-4-
/etc/hostname.e1000g0

Bsp:
saturn

-5-
Damit der SSHD laufen kann, braucht Du hostkeys. Hast Du dir welche generiert?

ssh-keygen -t rsa -N '' -f /etc/ssh/ssh_host_rsa_key

Nochwas: Solaris hat einen eigenwillen SSH-Client. Versuch mal die Option -y in der Kommandozeile.
Martin

Member
Beiträge: 9
Registriert: 13.09.2006, 10:39

Beitragvon Manu64 » 13.09.2006, 20:35

Ich werde verrueckt. Vielen Dank Martin. Es hat geklappt....
Diese Schritte habe ich gemacht.
Fuer alle die eventuell das Problem haben koennten
1. VMWARE auf Bridge umgestellt.
2. Solaris gestartet.
3. Erwartungegemaess hat ifconfig -a nichts gehabt.
4. netstat -rn hat auch nichts angezeigt.
5. ifconfig <interface> <feste ip> <netmask> eingeben.
6. ifocnifg <interface> up eingeben.
7. route add default gw<ip> eingeben.

SSH und sontiges laeuft.
Meine Frage nun.
Wie kann ich die DHCP Config im Solaris fuer immer los werden?
Wie kann ich die Aenderungen fuer fixed IP belassen?

Danke und GRuss
Manu

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 14.09.2006, 08:39

Hallo,
da müsste ein File namens /etc/dhcp.e1000g0 sein, das löschen und dhcp ist ausgeschaltet (nach reboot).
Dann musst Du aber die oben genannten Files pflegen.
Martin

Member
Beiträge: 9
Registriert: 13.09.2006, 10:39

Beitragvon Manu64 » 14.09.2006, 11:23

MSueper hat geschrieben:Hallo,
da müsste ein File namens /etc/dhcp.e1000g0 sein, das löschen und dhcp ist ausgeschaltet (nach reboot).
Dann musst Du aber die oben genannten Files pflegen.
Martin


Euch beiden Martin, Ulli einen herzlichen Dank.
Es laeuft alles bestens.

Gruss
Manu.


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste