Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Dual Boot mit OpenSuse10 auf schon existenter Partition

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 3
Registriert: 07.04.2006, 17:21

Dual Boot mit OpenSuse10 auf schon existenter Partition

Beitragvon p_lombris » 07.04.2006, 17:27

Hallo!

Ich habe auf meinem Rechner die folgenden Partitionen:
1) WindowsXP
2) Linux (mit OpenSuse10; /dev/hda2)
3) Linux Swap / Solaris (/dev/hda3)

Ich evaluiere gerade Vmware Workstation und wollte ausprobieren, ob ich die schon installierte Linux-Version starten kann. Unter "custom" habe ich unter "physical disk" die beiden Linux-Partitionen angegeben, doch beim Booten von Suse kommt die folgende Fehlermeldung:
"waiting for device to /dev/hda2 appear"

Auch die andere Partition findet er nicht ... Irgendwelche Tips?

Danke!

Benutzeravatar
Moderator
Beiträge: 1599
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 07.04.2006, 19:38

Hast du SATA Platten im Host oder normale IDE? Was hast du für einen IDE Controller im Host? In der initrd sollten alle in VMware benötigten IDE Treiber drinnen sein!
Greif mal unter SuSE als root zu vim

"vi /etc/sysconfig/kernel" bei INITRD_MODULES trag mal zusätzlich zu dem was da schon steht "ide_cd piix ide_disk" ein. Mit dem Befehl mkinitrd werden dann in /boot neue initrd's gebaut. Der Linuxkernel ist eigendlich monolithisch, heutzutage wären dann aber die Kernelimages so riesig das erstens Probleme auftauchen das System überhaupt zu starten, zum anderen wären dann 200 Hardwaretreiber im Arbeitspeicher geladen die Hardwaremässig gar nicht existent sind. Moderne Kernel können daher so erzeugt werden das sie externe Treibermodule laden können. So können Kernel erzeugt werden die wirklich nur die Treiber und Funktionen können die sie unbedingt benötigen um sich selbst und eine Initial Ramdisk (kurz initrd) betreiben zu können. Die INITRD enthält dann eine Art von Minimalsystem die extern vom Kernel alle Treiber lädt und Funktionen bereitstellt um das eigendliche System hochfahren zu können.

Member
Beiträge: 3
Registriert: 07.04.2006, 17:21

Beitragvon p_lombris » 11.04.2006, 10:00

Hallo,

danke für Deine Tips. Ich habe eine normale IDE Platte und kann ide_cd in /etc/sysconfig/kernel eintragen. piix_disk kann nicht gefunden werden und macht schon nach mkinitrd Fehler. Ich habe danach "gegoogelt" und keine Einträge gefunden. Liegt da vielleicht ein Fehler vor?

Grüße!

Benutzeravatar
Moderator
Beiträge: 1599
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 11.04.2006, 19:10

Ja,

"ide_cd piix ide_disk"

Äuglein auf, dann klappt das auch mit dem Lesen, hi hi hi :D

Melde dich dann beim nächsten prob :) Du kannst auch "ide-cd piix ide-disk" schreiben, aber keine Kommas zwischen den Modulnamen!

Member
Beiträge: 3
Registriert: 07.04.2006, 17:21

Beitragvon p_lombris » 19.04.2006, 14:00

Ja, das mit dem Lesen hilft ... und Dein "anderer" Tip hat auch geholfen! Nach ein paar Einstellungen zum Xserver läßt sich OpenSuse jetzt starten. Danke!


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste