Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

VMware 5.5 partimage restore -> bootet nicht

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 5
Registriert: 05.02.2004, 18:25

VMware 5.5 partimage restore -> bootet nicht

Beitragvon rain » 09.02.2006, 14:29

Hallo!

Ich habe ein Image von einem realen Server gezogen.
DAnach eine VMware Linux VM erstellt. Mit Knoppix gebootet. Danach mit partimage restore das image des realen Server in die VM eingespielt.

Bis dahin hat alles geklappt.
Doch das Linux bootet nicht.
Daher habe ich den grub aufgerufen und folgende Befehle ausgeführt:

root (hd0)
...filesystem type is reiser ....
setup (hd0)

danach neugebootet und dann kommt folgender Fehler:

kernel (hd0,0)/boot/vmlinuz root=/dev/hda vga=0x314 splash=silent desktop resume=/dev/hda2 showopts
Error 22: no such partition

Besten dank im Voraus

Thomas

Benutzeravatar
Moderator
Beiträge: 1599
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 09.02.2006, 16:24

Sollte so nicht gehen, probier mal so
hda ist erste Platte mit MBR von dem gebootet wird. Wenn du ins System chrootest vergiss nicht /sys und /proc zu mounten!

Code: Alles auswählen

grub> device (hd0,0) /dev/hda1

grub> device (hd0) /dev/hda

grub> root (hd0,0)
 Filesystem type is fat, partition type 0x6

grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... yes
 Checking if "/grub/stage2" exists... yes
 Checking if "/grub/fat_stage1_5" exists... yes
 Running "embed /grub/fat_stage1_5 (hd0)"...  15 sectors are embedded.
succeeded
 Running "install /grub/stage1 (hd0) (hd0)1+15 p (hd0,0)/grub/stage2 /grub/menu
.lst"... succeeded
Done.


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste