Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Compilierfehler auf Fedora Core 4

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: continuum, irix, Dayworker

Member
Beiträge: 1
Registriert: 01.10.2005, 11:30

Compilierfehler auf Fedora Core 4

Beitragvon ajung » 01.10.2005, 11:36

Hallo,

ich habe FC4 laufen mit dem aktuellen Kernel 2.6.13-1.1555_FC5.

Die letzten Kernelupgrades liefen ohne Probleme und vmware-config.pl
lies sich korrekt starten um die Module neu zubauen. Jedoch gibt es jetzt einen Fehler:

Mware 2 or VMware Express detected, building for VMware 2, VMware Express and VMware Workstation 4.0.x.
Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config5/vmnet-only'
make -C /lib/modules/2.6.13-1.1555_FC5/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/kernels/2.6.13-1.1555_FC5-i686'
CC [M] /tmp/vmware-config5/vmnet-only/driver.o
In file included from /tmp/vmware-config5/vmnet-only/vnet.h:14,
from /tmp/vmware-config5/vmnet-only/vnetInt.h:10,
from /tmp/vmware-config5/vmnet-only/driver.c:40:
/tmp/vmware-config5/vmnet-only/vm_atomic.h:56:5: warning: "_MSC_VER" is not defined
In file included from /tmp/vmware-config5/vmnet-only/vm_oui.h:14,
from /tmp/vmware-config5/vmnet-only/vnetInt.h:11,
from /tmp/vmware-config5/vmnet-only/driver.c:40:
/tmp/vmware-config5/vmnet-only/vm_basic_asm.h:50:5: warning: "_MSC_VER" is not defined
/tmp/vmware-config5/vmnet-only/driver.c: In function 'VNetProcessOwnsPort':
/tmp/vmware-config5/vmnet-only/driver.c:1816: error: 'struct files_struct' has no member named 'max_fds'
make[2]: *** [/tmp/vmware-config5/vmnet-only/driver.o] Error 1
make[1]: *** [_module_/tmp/vmware-config5/vmnet-only] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.13-1.1555_FC5-i686'
make: *** [vmnet.ko] Error 2
make: Leaving directory `/tmp/vmware-config5/vmnet-only'
Unable to build the vmnet module.

Ich bin zwar in C fit aber für das 'max_fds' Problem hab ich keine Lösung gefunden.

Gruß,
Andreas

Benutzeravatar
Profi
Beiträge: 992
Registriert: 07.08.2003, 09:32

Beitragvon looping » 01.10.2005, 11:54

das ist jetzt nur so ein schuss ins blaue - dir ist klar, das fc4 bereits mit gcc4 arbeitet? soweit ich weiß erwartet vmware noch eine 3'er-version.

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 01.10.2005, 15:55

Das sieht nach nem Aufruf des vmware-any-any* Patches aus. Siehe obige Beiträge hier im Forum.

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 01.10.2005, 15:58



Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste