Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

USB Geräte ( Drucker ) und VMware

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 2
Registriert: 17.09.2005, 11:52

USB Geräte ( Drucker ) und VMware

Beitragvon Stegi » 17.09.2005, 12:08

Hi,

ich bin erst vor kurzen auf Linux umgestiegen benötige aber für verschiedene Zwecke noch Windows. Ich habe schon stundenlang gefriemelt, aber ich kriege es nicht hin.
Ich habe VMware 5.0 und Suse 9.3 installiert. Jedesmal wenn ich ein virtuelles System starte (bei mir jetzt winXP) erkennt er keine USB Geräte. Die Fehler meldung die besagt, das die Module nicht schon im Wirtsystem geladen seinen dürfen habe ich ja verstanden, aber selbst die Hinweise die ich bis jetzt fand (google und "Linux Intern") haben nicht funktioniert! Dort hieß es man solle die Module der USB Geräte bevor man VMwarte startet entladen. (mit rmmod usb_storage) welcher für USB zuständig sein soll. Ich will zwar mein USB Drucker dort nutzen, was denk ich mal dann usblp wäre, aber der USB Stick funktioniert ebenfalls nicht.

Das habe ich auch versucht, aber das hat nicht funktioniert bei mir.

Desweiteren stand in dem Artikel das man das ganze unter Suse 9.3 automatisieren könne in dem man folgende Zeile in das Script "/etc/hotplug/usb/50-usb.hotplug" einträgt.
ps aux |grep -i vmware| grep -v "grep" &>/dev/null/ && exit 0

Ich wuste zwar nicht wo ich es in dem Script schreiben sollte, aber ich habe es einfachmal in die erste codezeile geschrieben, aber auch das hat überhaut nicht gebracht. Zumal dieses Script bei mir auch nicht unter /etc/hotplug/usb sonder unter /etc/hotplug.d/usb existiert!

Jemand von euch dabei, der mir helfen kann?

Benutzeravatar
Moderator
Beiträge: 1599
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 17.09.2005, 17:29

Trage einfach die Treiber die nicht geladen werden sollen in /etc/hotplug/blacklist ein. Bei Systemstart werden die Treiber nicht von Hotplug geladen. Natürlich kannst du deinen SuSE rechner mit wenigen Handgriffen auch zu Printserver befördern

http://www.debianforum.de/wiki/?page=CUPS+einrichten
http://www.debianforum.de/wiki/SambaPrintserver

Member
Beiträge: 51
Registriert: 29.03.2004, 19:52

Beitragvon Looki » 17.09.2005, 19:29

Für den Anfang (oder auch erste Erfolge) reicht aber auch
"rmmod usblp" (rmmod usb_storage ist für USB-Speicher)
Damit wird der Treiber für den USB Drucher entladen, danach kannst du den Drucker in VMware aktivieren.
Nach Gebrauch kannst du den Drucker-Treiber wieder mit "modprobe usblp" aktivieren.

Looki

Member
Beiträge: 2
Registriert: 17.09.2005, 11:52

Beitragvon Stegi » 18.09.2005, 11:55

Die sache mit dem entlade über rmmod usblp habe ich ja schon versucht, aber es klappt nicht, dannach will vmware das ich usb_storage entlade und selbst wenn ich das noch mache, da mein Durcker ein kartenlaufwerk hat, funkts. immer noch net.

ICh habe ein Multifunktionsgeräte (Drucker, Scanner, Kopierer, Fax und Kartenlese gerät in einem) Canon MP730. Ob es daran liegen könnte!

Warum den ganzen terz? Weil ich unter Linux keinen Treiber find. Auch der ersatz Treiber von Turbo Print hat nicht alle funktionen. zb. Dublex was ich haber haben will, so wolte ich das über windows laufen lassen.

Jemand noch ne Idee?

Benutzeravatar
Moderator
Beiträge: 1599
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 18.09.2005, 19:17

mach mal "lsmod | grep usb" Damit erhalst du me Liste mit geladenen USB Treibern. Wetten das die Übeltäter dabei sind. Achtung, HID ist für Tastatur und Maus!


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste