Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Fehler bei QNX Installation

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 3
Registriert: 07.08.2005, 17:06

Fehler bei QNX Installation

Beitragvon yello » 07.08.2005, 17:36

hallo in die runde,

da ich noch ein anfänger, mit dem umgang von VMware bin stehe ich vor einen problem und hoffe es kann mir einer helfen:
habe VMware 5 auf einen XP-System installiert alles soweit i.o und wollte nun eine kostenfreie QNX version installieren auch soweit i.o beim Neustart des virtuellen qnx-systems bleibt der bootvorgang stehen und es
erscheint folgende meldung: you do not appear to be running the VMware Tools package inside this virtual maschine.the package is necessary for your guest operating system to run at resolutions higher than 640x480 with 16 colors. choos VM Install VMware Tools.... after your guest operating system has finished booting.if you like,VMware con remind you to install the VMware Tools package when you power on. select ok to enable the reminder.

ach so mein qnx system bleibt beim booten mit diesen eintrag stehen:
Running crttrap, please wait...
/usr/photon/bin/devgt-iographics -dldevg-vesabios.so -I0 -d0x15ad, 0x0405


danach erscheint die oben beschriebene Fehlemeldung!

vielen dank schon mal im vorraus gruß

yello
[/list]

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 07.08.2005, 18:11

Hallo yello,
die Fehlermeldung bzgl. der vmware Tools kannste erstmal ignorieren. Die Tools enthalten die Treiber für die virtuelle HW und erlauben u.a. eine bessere Graphik als VGA.
Das Deine VM hängt hat damit nichts zu tun.

Da ich selbst QNX nur vom hörensagen her kenne, hier nen Zitat einer Web-Seite:
When we reboot, we are going to boot into a safe mode so we have to hit space bar to input boot options. Once the menu is displayed we are going to select “F1” to get to the safe modes menu and select F3 “F2 plus do not start photon”. VMWare has a problem with Photon initially that we are going to hack around. I look forward to when this hack is no longer necessary, however, for the time being it works.

After selecting F3, press enter twice to continue the boot process. You might see a few error messages which you can safely ignore. At the end of the boot process you will have a login prompt. Go ahead and log in and change to the “/lib/dll” directory. Here we are simply going to rename the “devg-vesabios.so” library to “devg-vesabios.so.bak” . VMWare has a problem when the vesa library is loaded and basically performs its equivalent of a “Panic” and shuts down.

Once you’ve renamed this file, you can reboot and install QNX as normal whether it be QNX NC, QNX SE, or QNX PE. The only thing that you’ll notice is that when you initially start the installation, you can only select VGA 640x480. After you log in, you can configure the graphics to any SVGA resolution.

Now, as an aside, one thing that I’ve found really useful about using VMWare is the ability to take a PCMCIA compact flash adapter and tell QNX that its an actual IDE drive by adding another drive and selecting the “RAW” mode. This is decidedly useful for me since I normally work on a Toshiba laptop that doesn’t seem to like a real QNX installation.

Quelle: http://www.openqnx.com/Article182.html

Versuchs mal so. Ggf. hilft das ja schon.
Schönen Sonntag noch.
Martin

Member
Beiträge: 3
Registriert: 07.08.2005, 17:06

Beitragvon yello » 07.08.2005, 19:56

vielen dank für die schnelle antwort,

werde dein tipp gleich austesten, qnx habe ich (zu testzwecken mal auf Vmware 3 installiert) da lief es auch nicht reibungslos, kam aber schon mal bis zu login :-))
naja das mit qnx scheint nicht so einfach zu sein...

nochmal danke werde mich melden ob es was gebracht hat

gruß yello

Member
Beiträge: 3
Registriert: 07.08.2005, 17:06

QNX unter VMware

Beitragvon yello » 11.08.2005, 08:26

hallo martin,

bin deinen link gefolgt und habe unter qnx die datei devgt-iographics umbenannt in devgt-iographics.bak. laut aussage der qnx spezis läßt diese datei (wenn sie orginal belassen wird) die VM crashen.

Nach der ähnderung läuft alles prima :) .

Danke nochmal!!

gruß yello


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste