Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

WindowsXP Prof. -> VMware -> Suse 9.0 -> Webserver

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 6
Registriert: 24.07.2005, 10:09

WindowsXP Prof. -> VMware -> Suse 9.0 -> Webserver

Beitragvon dslthomas » 24.07.2005, 10:28

Ich habe ein kleines Problemchen was sich wiefolgt äußert:

Rechner1=Server
IP: 192.168.0.1
Aufgabe: Internetzugang und Datenserver mit WinXP Prof.

Rechner2=Laptop Vaio FS115Z
IP: 192.168.0.6
VMnet0: 192.168.0.128
VMnet1: 192.168.0.129
Betriebssystem: WinXP Prof.
VMware mit Suse 9.0

Mein Problem:
Ich habe unter Linux einen Webserver eingerichtet. Rufe ich unter Linux die 192.168.0.128 im Browser auf, dann gelange ich zur Apache Testseite. Rufe ich diese IP vom Server aus auf, dann erhalte ich ebenfalls die Seite des Apache. Wenn ich nun aber auf dem Laptop unter WinXp während Suse läuft diese IP aufrufe passiert nichts! Auch wenn ich von Linux aus auf das Laptop zugreifen will funzt das nicht. Gleiches gild auch anders herum. Also weder der Webserver unter Linux noch der Netzwerkzugriff funktioniert auf dem Laptop zwischen den beiden Systemen. Auf den Server kann ich aber von beiden Systemen aus zugreifen. Was habe ich falsch gemacht? Ich hoffe mir kann hier jemd weiter helfen!?

Ein weiteres Problem stellen die VMware-Tools dar. Wofür genau sind diese und wie zum Geier nochmal kann ich die unter Suse 9.0 installieren?

Ich bin verzweifelt....... so blöde kann ich doch nicht sein......

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 24.07.2005, 11:26

Hallo,
nutzt Du vmnet0 und vmnet1? Wenn ja, dann hat ja der Linux-Server zwei IPs im gleichen Bereich!

Die VMWare Tools ermöglichen grob folgendes:
- bessere Oberfläche (mehr Farben, höhere Auflösung), da sie die Grahik-Treiber für die virtuelle Graphik-Karte enthalten. SUSE 9.x erkennt bisweilen die Karte als VESA-Karte und kann von allein höhere Auflösungen als 640x480x16. Nur Fit Guest, etc. geht dann nicht
- Sound-Treiber, Suse erkennt die Sound-Karte es1371 aber auch so.
- Die Uhrzeit geht bei Suse Linux ohne die Tools notorisch verkehrt.
- Bei dyn. wachenden Platten, haben die Tools eine Option die Platte zu schrumpfen.
- Datenaustausch Host <=> Gast

Du brauchst die Tools also nicht wirklich. Wenn Du aber dennoch die Tools installieren willst:

1. GCC installieren
2. passende Kernel-Sourcen installieren
3. Die CD (ISO-Image) mit den Tools aus dem Ordner vmware mounten
4. Die tar.gz Datei in $HOME/user kopieren oder nach /tmp oder so und das vmware-...pl Skript ausführen.

Grüße, Martin

Member
Beiträge: 6
Registriert: 24.07.2005, 10:09

Beitragvon dslthomas » 24.07.2005, 12:20

MSueper hat geschrieben:Hallo,
nutzt Du vmnet0 und vmnet1? Wenn ja, dann hat ja der Linux-Server zwei IPs im gleichen Bereich!

Grüße, Martin


Ahhhhhh....... wie blöde..... Ich dachte man muß dem Netzwerkadapter unter Windows die gleiche IP geben wie unter Linux sodass beide Adapter die gleiche IP haben.............

Unter Windows habe ich nun den VMware-Netzwerkadaptern automatische IP´s zuweisen lassen und unter Linux habe ich nun die 192.168.0.128 manuell zugewiesen.

Ein Problem habe ich aber noch: Ich kann nach wie vor nicht über Netzwerk von linux auf Win zugreifen und anders herum. Auf den Server zugreifen geht, aber nicht von Windows->laptop auf Linux->Laptop und anders herum. Von beiden Systemen kann ich aber auf den Server zugreifen. Hat da jemand noch einen Tip!?


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste