Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Hilfe! Virtual Disk startet nicht mehr!

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 23
Registriert: 21.03.2004, 17:03

Hilfe! Virtual Disk startet nicht mehr!

Beitragvon GLehnhoff » 25.05.2005, 16:10

"Unable to change virtual machine power state: Check for missing files failed: The file specified is not a virtual disk.." -- Dies ist die Meldung, die ich bekomme, wenn ich meine Virtual Disk starten will.

"Unable to get information for disk (SCSI 0:0)
Unable to open file "/data2/vmware/W2k/Windows 2000 Professional-000011.vmdk": The parent of this virtual disk could not be opened.. -- Dies ist die Meldung, die ich bekomme, wenn ich in die "Settings" will.

Wie kam es dazu?

Ich löschte alte Snap-Shots. Danch startete mein Win2000-guest mit einer blue screen. Ich wechselte zu einem existierenden Snap-Shot. Gleiches Resultat. Ich startete VMware neu und von da an erschien die obige Meldung.

Host: Suse9.3.
VMware: 5.x
Guest: Win2000

Ich bin ziemlich abhängig von VMware, da ich es beruflich nutze.

Alle Dateien sehen für mich normal aus

Kann jemand helfen?

Benutzeravatar
Moderator
Beiträge: 14752
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 25.05.2005, 18:01

Hi
dafuer dass du abhaengig von deinen VMs bist - gehst du ja ziemlich laessig mit den Dateien um. Jedenfalls hast du scheinbar wahllos alte Dateien geloescht.
Ob etwas fehlt kann man mit den Angaben nicht beurteilen - wenn wir mal nachschauen sollen poste:
ls /data/vmware/W2k
Windows2000Professional.vmdk
und die zugehoerige *.vmx

Ulli

Member
Beiträge: 23
Registriert: 21.03.2004, 17:03

Beitragvon GLehnhoff » 25.05.2005, 18:41

Na, du bist ja schnell mit Schlüsse ziehen.

Nein, nichts habe ich gelöscht, von den Snap-Shots abgesehen. Aber die habe ich nicht selbst gelöscht, sondern aus dem VMware heraus. Dort kann man alte Snap-Shots löschen. Ich werde mich hüten, irgendwo im Dateisystem rumzulöschen!


Hier die Dateiliste:
============

media:/hdc7/vmware/W2k/564db276-9b96-1c1f-4df3-d92dca71ce72.vmem
media:/hdc7/vmware/W2k/vmware-0.log
media:/hdc7/vmware/W2k/vmware-1.log
media:/hdc7/vmware/W2k/vmware-2.log
media:/hdc7/vmware/W2k/vmware.log
media:/hdc7/vmware/W2k/Windows 2000 Professional-000001-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000001-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000001-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000002-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000002-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000002-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000003-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000003-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000003-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000004-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000004-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000004-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000004.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000005-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000005-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000005-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000005.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000006-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000006-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000006-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000006.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000007-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000007-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000007-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000007.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000008-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000008-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000008-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000008.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000009-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000009-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000009-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000009.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000010-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000010-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000010-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000010.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000011-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000011-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000011-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-000011.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-0-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-0-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-0-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-0.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-1-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-1-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-1-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-1.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional.nvram
media:/hdc7/vmware/W2k/Windows 2000 Professional-s001.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-s002.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-s003.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional-Snapshot11.vmsn
media:/hdc7/vmware/W2k/Windows 2000 Professional-Snapshot13.vmsn
media:/hdc7/vmware/W2k/Windows 2000 Professional-Snapshot14.vmsn
media:/hdc7/vmware/W2k/Windows 2000 Professional-Snapshot15.vmsn
media:/hdc7/vmware/W2k/Windows 2000 Professional-Snapshot16.vmsn
media:/hdc7/vmware/W2k/Windows 2000 Professional-Snapshot17.vmsn
media:/hdc7/vmware/W2k/Windows 2000 Professional.vmdk
media:/hdc7/vmware/W2k/Windows 2000 Professional.vmsd
media:/hdc7/vmware/W2k/Windows 2000 Professional.vmx
media:/hdc7/vmware/W2k/yyyWindows 2000 Professional.vmsd
media:/hdc7/vmware/W2k/yyyWindows 2000 Professional.vmx


Hier die vmdk:
=========

# Disk DescriptorFile
version=1
CID=773c83e7
parentCID=ffffffff
createType="twoGbMaxExtentSparse"

# Extent description
RW 4192256 SPARSE "Windows 2000 Professional-s001.vmdk"
RW 4192256 SPARSE "Windows 2000 Professional-s002.vmdk"
RW 4096 SPARSE "Windows 2000 Professional-s003.vmdk"

# The Disk Data Base
#DDB

ddb.virtualHWVersion = "4"
ddb.geometry.cylinders = "522"
ddb.geometry.heads = "255"
ddb.geometry.sectors = "63"
ddb.adapterType = "buslogic"
ddb.toolsVersion = "5184"


Und die zugehörende vmx:
=================

#!/usr/bin/vmware
config.version = "8"
virtualHW.version = "4"
scsi0.present = "TRUE"
memsize = "176"
scsi0:0.present = "TRUE"
scsi0:0.fileName = "Windows 2000 Professional-000011.vmdk"
ide1:0.present = "FALSE"
ide1:0.fileName = "/dev/cdrom"
ide1:0.deviceType = "cdrom-raw"
floppy0.fileName = "/dev/fd0"
Ethernet0.present = "TRUE"
sound.present = "TRUE"
displayName = "Windows 2000 Professional"
guestOS = "win2000pro"
priority.grabbed = "normal"
priority.ungrabbed = "normal"

sound.virtualDev = "es1371"

ide1:0.startConnected = "TRUE"
Ethernet0.addressType = "generated"
uuid.location = "56 4d 67 a2 f3 1a d7 6e-36 66 41 86 fb a4 1c b1"
uuid.bios = "56 4d 24 31 13 af 3a 4d-8f e6 c0 d8 a7 68 48 e2"
sharedFolder.maxNum = "3"
ethernet0.generatedAddress = "00:0c:29:68:48:e2"
ethernet0.generatedAddressOffset = "0"
tools.syncTime = "TRUE"
sharedFolder0.present = "TRUE"
sharedFolder0.enabled = "TRUE"
sharedFolder0.readAccess = "TRUE"
sharedFolder0.writeAccess = "TRUE"
sharedFolder0.hostPath = "/home/GLehnhoff/"
sharedFolder0.guestName = "LinuxHome"
sharedFolder0.expiration = "never"
sharedFolder1.present = "TRUE"
sharedFolder1.enabled = "TRUE"
sharedFolder1.readAccess = "TRUE"
sharedFolder1.hostPath = "/windows/C/Documents and Settings/GLehnhoff/My Documents/"
sharedFolder1.guestName = "MyAsus Win Documents"
sharedFolder1.expiration = "never"
sharedFolder2.present = "TRUE"
sharedFolder2.enabled = "TRUE"
sharedFolder2.readAccess = "TRUE"
sharedFolder2.writeAccess = "TRUE"
sharedFolder2.hostPath = "/windows/D/"
sharedFolder2.guestName = "MyAsus Win D"
sharedFolder2.expiration = "never"

sound.fileName = "/dev/dsp"

undopoints.seqNum = "0"
scsi0:0.mode = "persistent"
undopoint.restoreFromCheckpoint = "FALSE"
undopoint.checkpointedOnline = "FALSE"

scsi0:0.redo = ""

undopoint.protected = "FALSE"
gui.restricted = "FALSE"

powerType.powerOff = "soft"
powerType.reset = "soft"

uuid.action = "keep"

sharedFolder1.writeAccess = "TRUE"

scsi0:1.present = "TRUE"
scsi0:1.fileName = "Windows 2000 Professional-1.vmdk"
scsi0:1.mode = "independent-persistent"

scsi0:2.present = "FALSE"
scsi0:2.fileName = "/dev/cdrom"
scsi0:2.deviceType = "scsi-cdrom"

scsi0:2.startConnected = "TRUE"

gui.exitAtPowerOff = "FALSE"

ide0:0.present = "TRUE"
ide0:0.fileName = "/dev/cdrom"
ide0:0.deviceType = "cdrom-raw"

ide0:0.startConnected = "TRUE"
tools.remindInstall = "FALSE"

Ethernet0.connectionType = "nat"

Ethernet0.virtualDev = "vlance"

debug = "FALSE"

nvram = "Windows 2000 Professional.nvram"
scsi0:0.deviceType = "disk"
scsi0:1.deviceType = "disk"

scsi0:1.redo = ""

checkpoint.vmState = ""

--------------------

Trotzdem danke für die Hilfe.

Ich glaube, dass nach dem Löschen einiger alter Snap-Shots VMware sich irgendwie verabschiedet hat, obwohl die Daten noch da zu sein scheinen.

mfg gl

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 25.05.2005, 21:26

N'Abend,
Du hast offensichtlich noch die Snapshots 11-17. Ich nutze Snapshots eher selten, also alles, was ich sage mit Vorsicht betrachten:
ich fürchte, snapshots müssen angewandt werden, bevor man sie gefahrlos löschen kann. Du hast jetzt eine Lücke in den "Redo-Informationen". Versuch doch mal folgendes (Backup vorher machen!!):

-1- die verbliebenen Snapshots umbennen und
-2- die VM mit der ursprünglichen vmdk starten

Damit sind dann alle Änderungen seit dem ersten Snapshot futsch, aber ich denke mal so kriegst Du die VM gestartet.
Ggf. weiss aber jedmand genauer Bescheid.
Grüße, Martin

PS: Rechtschreibfehler hängen mit meiner neuen Tastatur zusammen. Die tausche ich gleich am Freitag um...

Member
Beiträge: 23
Registriert: 21.03.2004, 17:03

Beitragvon GLehnhoff » 26.05.2005, 17:21

Hallo MSueper,

habe schon versucht, die ursprüngliche vmdk zu starten. Gleiches Problem.

mfg gl


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste