Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Frage zu Netzwerkeinstellungen

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 52
Registriert: 08.02.2004, 15:05

Frage zu Netzwerkeinstellungen

Beitragvon pix » 03.03.2005, 13:21

Hallo,

möchte mich vorneweg bei allen bedanken, die sich die Mühe machen mein Kauderwelsch zu lesen und versuchen herauszufinden was ich meine.

Mein Ziel:
Kurzfassung:
Ermittlung der IP-Adressen vom Host-BS und dem Gast-BS und gegenseitiger Datentausch

Langfassung.
Ich möchte von Win XP (Host-BS) das Gast-BS (Win2000) anpingen können, und auch umgekehrt. Hintergrund ist das Testen von iptables Regeln (allerdings unter Linux), wobei das Gast-BS das Internet und das Host-BS mein privaten Rechner simulieren soll.

Der Rechner ist ein Stand-Alone PC ohne Anbindung an ein Netz.

Problem:
Ich habe absolut keine Ahnung welche Einstellungen ich wo und wie vornehmen muss, um mein Ziel zu erreichen

Ich habe mich soweit belesen, dass es günstig ist die Einstellung auf NAT zu setzten.
Unter dem Menü ‚VM’ -> Settings steht NIC1 auf NAT: Used to share the host’s IP Adress.

Damit sich Host und Gast gegenseitig erreichen muss ich die IP vom Host und Gast kennen.
Führe ich ein ‚ipconfig /all’ unter dem Gast-BS aus, kommt diese Meldung1 .

Führe ich denselben Befehl unter dem Gast-BS (Win2000) aus bekomme ich Meldung 2.

Führe ich vom Host-BS aus einen ping auf 192.168.237.131 kommt „Zielhost nicht erreichbar“.

Führe ich vom Gast_BS einen ping auf die Adressen 192.168.0.1 und 92.168.193.1 aus, dann klappt es.

Warum kann ich von den Gast-BS aus den Host nicht erreichen?

Danke Dirk


Meldung 1:

Microsoft Windows XP (Host-BS)

C:\>ipconfig /all

Windows-IP-Konfiguration

Hostname. . . . . . . . . . . . . : schlafkammer
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Unbekannt
IP-Routing aktiviert. . . . . . . : Ja
WINS-Proxy aktiviert. . . . . . . : Nein

Ethernetadapter VMware Network Adapter VMnet8:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet8
Physikalische Adresse . . . . . . : 00-50-56-C0-00-08
DHCP aktiviert. . . . . . . . . . : Nein
IP-Adresse. . . . . . . . . . . . : 192.168.0.1
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . :

1Ethernetadapter VMware Network Adapter VMnet1:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet1
Physikalische Adresse . . . . . . : 00-50-56-C0-00-01
DHCP aktiviert. . . . . . . . . . : Nein
IP-Adresse. . . . . . . . . . . . : 192.168.193.1
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . :

Ethernetadapter LAN-Verbindung:

Medienstatus. . . . . . . . . . . : Es besteht keine Verbindung
Beschreibung. . . . . . . . . . . : Realtek RTL8139-Familie-PCI-Fast Ethernet-NIC
Physikalische Adresse . . . . . . : 00-30-84-3E-01-E8


Meldung 2:

Microsoft Windows 2000 (Gast-BS)

C:\>ipconfig /all

Windows 2000-IP-Konfiguration

Hostname. . . . . . . . . . . . . : kammer
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybridadapter
IP-Routing aktiviert. . . . . . . : Nein
WINS-Proxy aktiviert. . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : localdomain

Ethernetadapter "LAN-Verbindung":

Verbindungsspezifisches DNS-Suffix: localdomain
Beschreibung. . . . . . . . . . . : Ethernetadapter der AMD-PCNET-Familie
Physikalische Adresse . . . . . . : 00-0C-29-0C-99-5C
DHCP-aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
IP-Adresse. . . . . . . . . . . . : 192.168.237.131
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.237.2
DHCP-Server . . . . . . . . . . . : 192.168.237.254
DNS-Server. . . . . . . . . . . . : 192.168.237.2
Primärer WINS-Server. . . . . . . : 192.168.237.2
Lease erhalten. . . . . . . . . . : Donnerstag, 3. März 2005 12:50:50
Lease läuft ab. . . . . . . . . . : Donnerstag, 3. März 2005 13:20:50

C:\>

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 03.03.2005, 20:59

Hallo,

Der Rechner ist ein Stand-Alone PC ohne Anbindung an ein Netz.


Wieso denn NAT?

HOSTONLY ist das einzige erfolgversprechende. Wenn Dein Rechner an keinem Netzelement (Hub, Switch, Router, ...) hängt ist die physikalische NIC down! Hostonly ist der vmnet1 Adapter.

Host vmnet1 : 192.168.x.y und
Gast IP: 192.168.x.(y+1)

Netmask 255.255.255.0 bei beiden. Den Host als Gateway im Gast eintragen, wenn der mal in I-Net soll.

Grüße, Martin

Member
Beiträge: 52
Registriert: 08.02.2004, 15:05

Beitragvon pix » 04.03.2005, 12:42

Danke Martin !!

Das mit dem NAT habe ich aus pdf-Dokus die sich mit vmware beschäftigen, und wo der Aufbau eines Netzwerkes mit vmware erklärt ist.

Aber um ehrlich zu sein, vom Thema Netzwerk habe ich nicht allzu viele Ahnung, und darum dachte ich es wird schon so okay sein.

Werde es mit deiner Erklärung versuchen und mich nochmal melden.

Dirk

Member
Beiträge: 52
Registriert: 08.02.2004, 15:05

Beitragvon pix » 04.03.2005, 18:54

Hallo Martin,

habe deine Einstellungen in Host und Gast vorgenommen.
Kann nun beide anpingen.

Habe aber dennoch ein Problem. Bei diesen Einstellungen kann ich nicht mehr
vom Gast-BS aus im Internet surfen.

Gibt es da Hilfe?

Dirk

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 04.03.2005, 19:25

Hallo Pix,
ja, wie ist denn Deine Konfig.?

Ich unterstelle mal, dass der Host die I-Net-Verbindung aufbaut.
Also versuche folgendes:
benötigte SW:
- Proxy Server (z.B. jana2 Server, der ist gut und frei)
VMWare Netz:
- Host-Only Verbindung wählen (haste ja schon)
- nur eine NIC dem Gast geben (ist auch so hoffe ich mal)
Gast:
- IP-Adresse 192.168.0.2 Mask 255.255.255.0 wählen
- Gateway 192.168.0.1 einstellen
- im Web-Browser: Proxy 192.168.1.1 Port 3128 einstellen
Host:
- dem Modem/DSL-Anschluß (weiss nicht genau, wie dass bei Dir aussieht) die IP 192.168.1.1 geben Mask 255.255.255.0
- der VMWare Netzschnittstelle VMWare Network Adapter VMnet1 die IP 192.168.0.1 Mask 255.255.255.0 verpassen
- Jana2 Server installieren (im Admin-HTML-Dialog unter Einstellungen => Administrator => Konfiguration => IP-Adressen die Adresse 192.168.1.1 ergänzen und einen Haken bei HTTP-Proxy unter dieser machen, übernehmen klicken und jana2 durchstarten)
- Internetverbindungsfreigabe ankreuzen beim Modem/DSL-Adapter
- einwählen und gut iss

Ggf. kannst Du ohne Jana2 klarkommen. Bei mir ist der aber nötig.
Grüße, Martin

PS: diese Antwort habe ich hier nur rein kopiert. Such mal im Forum, Dein Problem ist hier eines der am häufigsten diskutierten. Vielleicht findest Du noch beesere Tipps oder weiterführendes.


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste