Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Kann WinXP nicht als VM installieren

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 8
Registriert: 06.01.2005, 13:01
Wohnort: Potsdam

Kann WinXP nicht als VM installieren

Beitragvon Abby » 06.01.2005, 13:04

Hallo,
ich habe unter Suse 9.0 VMWare 4.5 installiert und möchte nun WinXP als VM installieren. Bei der Installation bekomme ich immer die Fehlermeldung: cannot allocate memory.

Abby

Benutzeravatar
Moderator
Beiträge: 14745
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 06.01.2005, 15:42

Hi
ist das alles was du uns zu sagen hast ?
Wann,
wieso,
wieoft,
warum,
wie teuer,
mit oder ohne Gummi,
alles das bleibt im Dunkeln!

Mal im Ernst - so kann man nur raten!
Wann genau passiert das, was hast du fuer einen Hostrechner und ein log von dem Vorgang waeren hilfreich.

Ulli

Member
Beiträge: 8
Registriert: 06.01.2005, 13:01
Wohnort: Potsdam

Beitragvon Abby » 07.01.2005, 11:49

Hallo Ulli,
ich installierte heute noch einmal von vorn VMWare Workstation 4.5. Der Host ist Suse 9.0, Kernel 2.4.21-266, i686 und WinXP soll als Gast laufen.
Beim Laufen von vmware-config.pl baute vmmon neue Module, da für den Kernel keine vorhanden ware. Dies geschah ohne Fehlermeldung. Auch der Rest lief ohne Fehler durch.
Als ich nun WinXP als VM installieren wollte, brach die Installation beim Formatieren ab. Danach hatte ich auch Probleme mit der Tastatur. Ein Neustart von Linux brachte folgende Fehlermeldungen:
kernel:/dev/vmmon:VMMON CPUID: Unrecognized CPU
VMware[init]:/usrt/bin/vmware.nmbd:error whiel loading shared libaries: libpopt.so.0: cannot open shared objekt files: No such file or directory. Dabei habe ich diese Libary noch einmal geupdatet um die neuere Version drauf zu haben.
Die Fehlermeldung von gestern kam nicht noch einmal.

Beim Starten von WinXP kam die Fehlereldung: Fehler beim Laden des BS.

Soll ich jetzt noch die gesamte vmware.log posten oder benötigst Du nur bestimmte Ausschnitte?
Was bnötigst Du noch?

Martina

Benutzeravatar
Moderator
Beiträge: 14745
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 09.01.2005, 20:57

Hi Martina
sorry - leider verwendest du Suse - bei Kernel 2.4 ist das zwar noch nicht sp problematisch - trotzdem kann ich dir hier nicht weiterhelfen. Ich denke mal die Grundinstallation von VMware ist schon fehlgeschlagen - bist du dir sicher dass deine Kernelquellen synchron zu dem verwendeten Kernel sind - bei anderen Distributionen ist das in der Regel kein Problem - bei Suse ist das aber scheinbar die Regel. Spaetestens nach dem ersten automatischem Update muss man damit rechnen, das Sourcen und Kernel nicht mehr synchron sind - wodurch dann die VMware-installation scheitert.
Auch ein updaten einzelner libraries kann die VMware-installation unbrauchbar machen.
Tut mir leid ...
Ulli

Benutzeravatar
Moderator
Beiträge: 1599
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 09.01.2005, 21:11

Was verwendest du für ein Dateisystem ? Bei einem Crash kannst du unter Umständen mit reiserfs etwas verloren haben. Alternativ in Uli's Kerbe gehauen Debian ist recht gut.. Auf www.ubuntu.com kannst du dier ein von Debian abstammendes System kostenlos als CD Image downloaden. Wenn du Internetseitig dazu nicht in der Lage bist, ja nicht alle haben DSL und ne Flat, schicken die dier die CD kostenlos zu dier nach Hause.

Member
Beiträge: 8
Registriert: 06.01.2005, 13:01
Wohnort: Potsdam

Beitragvon Abby » 11.01.2005, 14:28

Also, ich hatte jetzt Suse 9.0 neu installiert - gleiche Problem. Darauf installierte ich Suse 8.1 - wieder an der selben Stelle der Abbruch.
Die Installation von VMWare lief jedesmal ohne Probleme durch. Die Suse-Versionen waren ohne irgendein Update.
Kann lieder icht auf eine andere Linux-Distribution umsteigen.

Wer weiß Rat?

Danke,
Martina

Benutzeravatar
Moderator
Beiträge: 14745
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 11.01.2005, 21:59

Hi
also die 8.1 sollte eigentlich laufen - wie installierst du den eigentlich? RPM- oder tarball oder wie?
Was hast du ergentlich fuer eine CPU?
Kannst du abgesehen von XP auch sonst keine Gaeste laufen lassen? Laeuft ein DOS ohne Zicken?

Poste doch mal ein vmware.log nach dem naechsten Crash.

Ulli

Member
Beiträge: 8
Registriert: 06.01.2005, 13:01
Wohnort: Potsdam

Beitragvon Abby » 13.01.2005, 13:06

Hi,
die CPU ist ein Pentium III, 866MHz. Ich habe mit RPM instaliiert.
Dos läuft ohne Probleme.
Die vmware.log hat 227 Zeilen. Soll ich die ganze Datei reinkopieren?

Martina

Member
Beiträge: 8
Registriert: 06.01.2005, 13:01
Wohnort: Potsdam

Beitragvon Abby » 20.01.2005, 09:37

Hallo Uli,
noch ien Versuch. Jetzt installierte ich VMWare mit dem tar.zg-file. Das Ergebnis war wieder das gleiche.
Von der vmware.log poste ich mal die letzten Zeilen:

Code: Alles auswählen

Jan 19 15:26:18: vmx| Backtrace:
Jan 19 15:26:28: vmx| Backtrace[0] 0xbfffef78 eip 0x805a99c
Jan 19 15:26:28: vmx| Backtrace[1] 0xbfffef98 eip 0x8055c7e
Jan 19 15:26:28: vmx| Backtrace[2] 0xbfffefb8 eip 0x81f0fee
Jan 19 15:26:28: vmx| Backtrace[3] 0xbfffefc8 eip 0x81f11fe
Jan 19 15:26:28: vmx| Backtrace[4] 0xbfffefe8 eip 0x81d213b
Jan 19 15:26:28: vmx| Backtrace[5] 0xbffff248 eip 0x81d1dd7
Jan 19 15:26:28: vmx| Backtrace[6] 0xbffff298 eip 0x81d14d4
Jan 19 15:26:28: vmx| Backtrace[7] 0xbffff308 eip 0x805b1f0
Jan 19 15:26:28: vmx| Backtrace[8] 0xbffff328 eip 0x805b14c
Jan 19 15:26:28: vmx| Backtrace[9] 0xbffff358 eip 0x8059ef6
Jan 19 15:26:28: vmx| Backtrace[10] 0xbffff3a8 eip 0x804fb1d
Jan 19 15:26:28: vmx| Backtrace[11] 0xbffff3d8 eip 0x804e927
Jan 19 15:26:28: vmx| Backtrace[12] 0xbffff408 eip 0x401fe4a2
Jan 19 15:26:28: vmx| Backtrace[13] 00000000 eip 0x804d981
Jan 19 15:26:28: vmx| Core dump limit is 0 kb.
Jan 19 15:26:29: vmx| Attempting to dump core...
Jan 19 15:26:30: vmx| Child process 3761 failed to dump core (status 0x6).


Martina


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste