Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

debian + x + maus

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: Dayworker, continuum, Tschoergez, irix, stefan.becker

Member
Beiträge: 2
Registriert: 05.06.2004, 02:49

debian + x + maus

Beitragvon bog » 05.06.2004, 03:00

n'abend die damen, folgendes problem:

ich habe als hostsystem ein windows xp und als gast ein debian woody 3rc1 unter vmware workstation 4.5.1 laufen, funktioniert alles wie gehabt. problematisch wird es, wenn ich hingegen x starte: cursor ist da, laesst sich aber nicht benutzen; weder klicken noch bewegen ist drin.

nun hatte ich vorher ein redhat-linux laufen, welches scheinbar die x-einrichtung von selbst hinbekommen hat im gegensatz zu debian, wo ich das meiste noch selbst eintragen musste, bis es (mit ausnahme der maus) lief. nun war es halt so, dass unter redhat sogar die maus lief. also sass ich an meinem debian und hab mir ueberlegt, redhat nochmal draufzukloppen und dann einfach die x-konfiguration entsprechend zu adaptieren. gesagt getan, x-konfiguration gebackupt und dann die in debian entsprechend angepasst. lief bloederweise immernoch nicht mit der maus. ich hab mir dann nen neuen kernel kompiliert (die vmware tools mochten das -bf24 an der kernel-source nicht) und die vmware tools installiert. bei meinem maus-problem hat das dummerweise auch nicht geholfen.

die maus ist ne logitech mx700 und laeuft aufm usb port. da das teil in redhat, freebsd sowie windows 2000 einwandfrei zu funktionieren scheint, schliesse ich mal nicht irgendwelche inkompatibilitaeten von vmware her aus. ich hab im internet in foren und in der vmware-knowledgebase keine passenden problembeschreibungen gelesen.
mit der suchfunktion hab ich dann hier im forum hab ich 2 threads gefunden, der eine hatte gar keine antworten und beim anderen wurde das problem geloest, indem die x-konfiguration einfach nochmal angepasst wurde, weil sie vom vmware tool-installer abgeaendert wurde. da ich das bei uns aber ausschliessen konnte sitz ich ratlos vor dem problem.

any clues?


aight, bevor ich's vergesse, meine XF86Config:
Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

EndSection
Section "InputDevice"

Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "500 30"

Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "de"

EndSection

Section "Module"
Load "dbe" # Double buffer extension
SubSection "extmod"
EndSubSection
Load "type1"
Load "freetype"
# Load "glx"
EndSection


Section "ServerFlags"
# Option NoTrapSignals
EndSection


Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
# Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"
# Option "ChordMiddle"
EndSection

Section "Monitor"
Identifier "vmware"
VendorName "VMware, Inc"
HorizSync 1-10000
VertRefresh 1-10000

ModeLine "640x480" 100 640 700 800 900 480 500 600 700
ModeLine "800x600" 100 800 900 1000 1100 600 700 800 900
ModeLine "1024x768" 100 1024 1100 1200 1300 768 800 900 1000
ModeLine "1152x864" 100 1152 1200 1300 1400 864 900 1000 1100
ModeLine "1152x900" 100 1152 1200 1300 1400 900 1000 1100 1200
ModeLine "1280x1024" 100 1280 1300 1400 1500 1024 1100 1200 1300
ModeLine "1376x1032" 100 1376 1400 1500 1600 1032 1100 1200 1300
ModeLine "1600x1200" 100 1600 1700 1800 1900 1200 1300 1400 1500
ModeLine "2364x1773" 100 2364 2400 2500 2600 1773 1800 1900 2000
EndSection

Section "Device"
Identifier "VMware SVGA"
Driver "vmware"

EndSection

Section "Screen"
Identifier "Screen 1"
Device "VMware SVGA"
Monitor "vmware"


Subsection "Display"
# VGA mode: better left untouched
Depth 4
Modes "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 8
Modes "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 15
Modes "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1024x768"
ViewPort 0 0
EndSubsection
EndSection

Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Benutzeravatar
Moderator
Beiträge: 1598
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 05.06.2004, 16:02

Du benötgst XFree 4.2 füge folgende Zeilen in /etc/apt/sources.list zu dann apt-get update und apt-get upgrade zur Sicherheit wäre noch ein apt-get install x-window-system-core sinnvoll

# Für XFree4.2
deb http://www.fs.tum.de/~bunk/debian woody/bunk-1 main contrib non-free
deb-src http://www.fs.tum.de/~bunk/debian woody/bunk-1 main contrib non-free

# Für GNOME 2.2
deb http://ftp.acc.umu.se/mirror/mirrors.ev ... orts/woody gnome2.2/
deb-src http://ftp.acc.umu.se/mirror/mirrors.ev ... orts/woody gnome2.2/

Wenn die Kernelsourcen nicht genommen werden kannst du dier auch einen eigenen Kernel erzeugen. Wenn du zu Booten keine initrd benötiigst reicht ein entpacken der Kernelsources ( z.B. von www.kernel.org ) dann ein

cp /boot/config-kernelaktuell /usr/src/linux-2.4.26/.config

dann ein make-kpkg kernel_image --revision mein-geiles-deb.01

das deb kannst du dann mit dpkg --install /Pfad/zum/deb installieren

alien kernelpackage libc6-dev gcc.2.95 make binutils usw sollten allerdings vorher schon installiert sein.

Member
Beiträge: 2
Registriert: 05.06.2004, 02:49

Beitragvon bog » 06.06.2004, 01:09

probier ich direkt aus, danke erstmal.


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast