Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

VMWare's System BEEP - bitte um hilfe

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 3
Registriert: 15.04.2004, 00:18

VMWare's System BEEP - bitte um hilfe

Beitragvon mehli2002 » 22.04.2004, 15:38

Hallo zusammen!

Host-System: Dell Inspiron 8500, 2,5GHz, 1GB Ram, WinXP Home, VMware 4.5
Gast-Systeme: Win2003, Suse 9, Trustix (Linux).

Habe ein Problem bei sämtlichen virtuellen Systemen. Und zwar kommt z.B. bei Linux-Gastsystemen ständig ein lautes "BEEEP" aus irgendeinem internen Lautsprecher.
Soundkarte & PC Speaker sind im Gerätemanager deaktiviert, sollten es also nicht sein.

Wenn man in der Linux-Konsole z.B. mit den Cursortasten in eine Richtung drück für die keine Aktion verfügbar ist (beispielsweise im VI), dring ein lautes BEEP nach außen, obwohl weder systemkritische Zustände herrschen noch sonst ein Problem besteht. Ich weiß das vmware die fehler-codes der virtuellen maschinen nach außen weitergibt, aber das kann ja nicht sien, dass das unbeeinflussbar stattfindet. Im amerikanischen VMWare Forum habe ich eine Nachricht gefunden, dass man irgendwie die VMX-Dateien editieren kann so dass die Soundkarten-Lautstärke nicht mehr verändert wird und System Beeps abgeschaltet werden können.
Die nervigen Piepser kommen bei Linux u.A. auch nach jedem shutdown befehl. Eine .rc<irgendwie> datei im homeverzeichnis in der "bell-style:none" defininert ist, ist eingerichtet und hat einige der Beeps auch eliminiert. Dito unter W2003 in der Registry.(Beep=off)
Kann man VMware generell verbieten Geräusche zu machen oder gibts einen inoffiziellen VMX-Dateien-Eintrag der das Problem behebt?
Das Piepsen geht echt auf den Wecker und man kann damit echt nicht unter Leuten arbeiten, weil das Piepsen unverhätnismäßig laut ist (dafür dass es nur ein Notebook ist).

Bei anderen Leuten die kenne macht vmware in der hinsicht keine Probleme, deswegen denk ich schon fast, dass es an einer OEM-Einstellung des Notebook liegen könnte.
Ich möchte das Problem aber möglichst ohne XP Neuinstallation in den Griff bekommen...


Ich hoffe jemand hat(te) ähnliche Probleme,

BEEEEEEP,

Jochen

Member
Beiträge: 9
Registriert: 25.04.2004, 15:29

Peeper ausschalten

Beitragvon RnB » 25.04.2004, 15:59

Hi,

ich denke mit diesen Regeintrag sollte es ruhiger werden :-)

Yes=Aktiviert
No=Deaktiviert
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Sound]
"ExtendedSounds"="No"

der stellt den PC Speaker ab.

habe das Prob. auch.
Kam allerdings noch nicht dazu es auszuprobieren!
vielleicht schreibst, ob es geklappt hat.

Gruss, RnB

Benutzeravatar
Moderator
Beiträge: 14752
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 25.04.2004, 16:50

Hi
probier mal diesen Eintrag in der vmx
pciSound.enableVolumeControl = FALSE

Sag bitte Bescheid wenn das hilft.

Continuum

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 08.06.2005, 19:37

Hallo,
schade das hilft nicht. Der Piep-Ton ist immer noch sehr laut und lang.
Grüße, Martin

Benutzeravatar
Moderator
Beiträge: 14752
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 09.06.2005, 16:37

... und wie ists hiermit?
mks.noBeep = "TRUE"

Member
Beiträge: 1
Registriert: 13.04.2005, 13:47

Beitragvon milch-extra » 18.08.2005, 12:11

Ahoi,
bei mir hat der Eintrag
mks.noBeep = "TRUE"
in der "C:\Documents and Settings\All Users\Application Data\VMware\VMware Workstation\config.ini"
bei VMware Workstation 5.0 Windows für Stille gesorgt. Der Gegentest mit auskommentiertem Eintrag hat es bestätigt.
siehe www.vmware.com/community/...threadID=14981

In 5.5.x ist es offenbar der gleiche Eintrag. Aber in der userspezifischen
"%APPDATA%\VMware\preferences.ini"

Viel Freude

milch-extra

Member
Beiträge: 89
Registriert: 16.07.2004, 14:54

Beitragvon TheProdigy » 19.08.2005, 18:33

Jetzt hast du ja schon die richtige Antwort gefunden. Mittlerweile spricht sich die Lösung rum ;)

Mich hat es zu Zeiten von VMware 4.0 noch Tage gekostet, diese Lösung zu finden (mit Hilfe von NG, Forum und Google) :?

Benutzeravatar
Moderator
Beiträge: 1599
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 19.08.2005, 22:58

als Root "rmmod pcspkr"

Wenn Hotplug verwendet wird dann noch in /etc/hotplug/blacklist dieses Treibermodul eintragen. Nach erneutem Systemstart sollte es nicht mehr automatisch geladen werden. Noch einfacher, das Treibermodul schlicht löschen. Doof nur wenn der Treiber im Kernel monolithisch kompeliert wurde, allerdings macht das bei Distrubtionskerneln keinen Sinn. Beepen in der Bash kann man auch in der bashrc abklemmen


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste