Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

kein Schreibzugriff :(

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: Dayworker, continuum, Tschoergez, irix, stefan.becker

Benutzeravatar
Member
Beiträge: 19
Registriert: 18.04.2004, 12:07
Wohnort: München

kein Schreibzugriff :(

Beitragvon StefanT » 18.04.2004, 21:14

Hallo, ich hoffe, hier bin ich im richtigen Forum.
Unter Suse Linux 9.0 habe ich vmware 4.5.1 erfolgreich installiert.
Unter W2k bin ich bis zum Lesezugriff gekommen, aber mit dem Schreibzugriff auf die Shares komme ich auf keinen grünen Ast.
Ich habe host-only und bridged network aktiviert.
Meine vmnet1 smb.conf im Anschluss...
(Leicht gekürzt, ich will mehrere Laufwerke einbinden)
Bei /mnt/hdc7/ handelt es sich um ein Fat32-Laufwerk
Was mache ich falsch? In W2k habe ich einen user mit dem gleichen Namen wie unter samba
Das Passwort habe ich auch in beiden gleich gesetzt mit
vmware-smbpasswd vmnet1 -a beispiel , user und Passwd in kleinbuchstaben.
Ich komme nicht weiter. So weit war ich vor Jahren schon mal und habe dann vmware aufgegeben und bin bei Windows geblieben :roll:
Dank vorab Stefan
PS.: Ich kürze etwas - hab's hinbekommen :) :)
;
; Configuration file for Samba operating on vmnet1.
;
; Global settings
[global]
;
; Identity
;
; Allow several Samba servers on different subnet without conflicts
socket address = 172.16.138.1
interfaces = 172.16.138.0/255.255.255.0
bind interfaces only = yes
; Workgroup the host belongs to
workgroup = EGAL
; SMB name of the host (the hostname by default)
; netbios name =
; Description of the host
server string = VMware hust
;
; Access
; Allow connections from
; Beware: if we use this directive, smbd will try to do a reverse resolution
; Authentication scheme
security = user
encrypt passwords = yes
;
; Options
;
; Automatically load the printer list (from /etc/printcap by default)
load printers = yes
; Gives better performance
socket options = TCP_NODELAY
;
; Files and directories
;
; Locks
lock directory = /etc/vmware/vmnet1/smb/var/locks

; SMB passwords
smb passwd file = /etc/vmware/vmnet1/smb/private/smbpasswd

; VMware extension to use codepages in a different directory
code page directory = /usr/lib/vmware/smb/codepages
;
; Name browsing
;
; Allow the host to participate in master browser elections
local master = yes

; Force a local browser election upon startup
preferred master = yes
; Do not try to resolve SMB names via DNS
dns proxy = no
;
; Shared resources
; Home directories
[homes]
comment = Home directories
browseable = no
writable = yes
; mein Laufwerk F
[Foto]
comment = Fotos
path = /mnt/hdc7/
public = yes
read only = no
browseable = yes
printable = no

; Printers
[printers]
comment = All printers
path = /var/lpd
browseable = no
guest ok = no
writable = no
printable = yes

[HostFS]
;natürlich Blödsinn, war nur zum Testen:
comment = VMware host filesystem
path = /
public = no
writeable = yes
printable = no

Benutzeravatar
Profi
Beiträge: 992
Registriert: 07.08.2003, 09:32

Beitragvon looping » 19.04.2004, 00:25

ob das hier das richtige forum ist lässt sich bestreiten - vmware benutzt zwar samba um datenfreigaben auf linux-maschinen zu setzten, aber dein problem ist wahrscheinlich kein vmware, sondern ein samba problem. meine vermutung ist, das der samba-user auf dem linux-host keinen schreibzugriff auf das freigegebene verzeichnis hat - das muss er aber, denn samba leitet die unix/linux datei- und verzeichnis-rechte nur weiter. sinnvoll ist es eine entsprechende gruppe zu erstellen (z.b. share), den benutzer in die gruppe share aufzunehmen und der gruppe lese/schreibrechte auf dem freigegebenen verzeichnis zu geben.

grundsätzlich solltest du das mit den shares aber vergessen und stattdessen einen echten sambaserver aufsetzen - das vmware-model ist irgendwie eigenartig, komisch, suspekt und macht mehr probleme als es hilft.

mein tip: lad dir samba 3.0x und setzt samba als daemon oder zur not auch als bestandteil der inetd/xinetd auf.

mfg

looping

EDIT:/ das komplette root ( / ) als writeable zu setzen ist eine denkbar schlechte idee - erstens funktioniert das nur als root, zweitens unterminiert das jeglichen sicherheitsgedanken eines netzwerkbetriebssystems: denke daran, auch die verzeichnisse /home, /etc, /root, /sbin liegen in der root ( / ) - das kann so nicht klappen.

Benutzeravatar
Member
Beiträge: 19
Registriert: 18.04.2004, 12:07
Wohnort: München

Es funktioniert :-)

Beitragvon StefanT » 21.04.2004, 01:00

Danke. Prima Tipp. Ich dachte, man müsse die vmware-eigene samba-Engine verwenden :roll:
Normales Samba ist schneller :) Der Schreibzugriff auf die FAT-Laufwerke funktioniert, indem ich in der fstab für diese statt defaults uid=user,gid=gruppe,fmask=0640,dmask=0750 aufgenommen habe. Die Signatur kann ich auch anpassen :D
Gruss Stefan


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste