Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

vmware Workstation 4.0 Win verliert Shares

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation und VMware Workstation Pro.

Moderatoren: Dayworker, continuum, Tschoergez, irix, stefan.becker

Member
Beiträge: 11
Registriert: 16.02.2004, 13:46

vmware Workstation 4.0 Win verliert Shares

Beitragvon Gerd » 16.02.2004, 14:07

Hallo erstmal,

nun suche ich schon einige Zeit nach einer Lösung für mein Problem.
Eine Antwort habe ich hier nicht gefunden. Sollte es sie doch schon geben, so bitte ich um Entschuldigung.

Die Konfiguration:
vmware 4.0 Workstation auf einem Win2k-Rechner als Gast.
Der Rechner ist Client eines Win2k-Servers.
Als Connection habe ich "bridged" gewählt.
In den Eigenschaften des Netzwerkadapters habe ich "VMware Bidge Protocol" aktiviert und bei "VMNet Number =" "0" gewählt.
Bei den Adapter "VMNet1" und "VMNet8" habe ich "VMware Bidge Protocol" jeweils deaktiviert.
Ich nutze verschiedene Win-Betriebssysteme unter vmware mit denen ich auch auf die Shares des W2k-Servers zugreifen kann.

Dann und wann verliere ich auf dem Gastrechner, also nicht innerhalb einer VMWare-Sitzung, die Shares und erhalte folgende Meldung:

"Fehler beim Wiederherstellen der Verbindung von x: \\server\share .
Microsoft Windows Netzwerk: Der lokale Gerätename wird bereits verwendet. Diese Verbindung wurde nicht wiederhergestellt."

Das Problem tritt unregelmäßig und offenbar unabhängig von anderen Aktionen auf. DAs Problem exisitiert erst seit der VMWare Installation und taucht auch allen Rechnern auf.

Mir fehlt jeder Ansatz.
Hat jemand Hilfe parat?

Gruß, Gerd

Benutzeravatar
Moderator
Beiträge: 14693
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 16.02.2004, 15:56

Hi
ueberpruef mal folgende Geschichte und zwar sowohl fuer deinen Host als auch fuer die virt. Maschinen

please power down the VM
edit the configuration and remove any virtual adapters
power on the VM
follow the following instructions to clean up hidden NIC adapters:
To show hidden devices option in the device manager does not always show the
old virtual NIC that uses up that IP Address.

Microsoft KB 269155 addresses this issue in
http://support.microsoft.com/?kbid=269155
To resolve this problem, uninstall the ghosted network adapter from the
registry:
Click Start, click Run, type cmd.exe, and then press ENTER.
Type set devmgr_show_nonpresent_devices=1, and then press ENTER.
Type Start DEVMGMT.MSC, and then press ENTER.
Click View, and then click Show Hidden Devices.
Expand the Network Adapters tree.
Right-click the dimmed network adapter, and then click Uninstall.
END_______________

power down the VM
edit the configuration, and add a bridged NIC adapter, please do not use the
custom option!

das passiert manchmal nach irgendwelchen Netzwerk-konstellationsaenderungen. Ist aber nichts ernstes.

Ansonsten glaube ich nicht, dass es so eine gute Idee ist bei vmnet1 und 8 das VMware-Bridge Protokoll zu deaktivieren. Entweder lass es mitlaufen oder deaktiviere die kompletten Karten wenn du sie nicht brauchst.

Gruss Ulli Hankeln

Member
Beiträge: 11
Registriert: 16.02.2004, 13:46

Beitragvon Gerd » 16.02.2004, 16:55

Hi Ulli,

> ueberpruef mal folgende Geschichte und zwar sowohl fuer deinen Host > als auch fuer die virt. Maschinen

meine Probleme treten aber völlig unabhängig davon auf, ob eine virtuelle Maschine lief, oder läuft.

> please power down the VM
> edit the configuration and remove any virtual adapters

Verstehe ich das richtig? Gemeint ist:
=> Edit
=> Virtual Network Settings
=> Host Virtual Adapters

Da habe ich dann VMNet1 und VMNet2.
Die soll ich löschen?!

> power on the VM
> follow the following instructions to clean up hidden NIC adapters:
> To show hidden devices option in the device manager does not always > show the old virtual NIC that uses up that IP Address.
> ...
> Click Start, click Run, type cmd.exe, and then press ENTER.
> Type set devmgr_show_nonpresent_devices=1, and then press ENTER.
> Type Start DEVMGMT.MSC, and then press ENTER.
> Click View, and then click Show Hidden Devices.
> Expand the Network Adapters tree.
> Right-click the dimmed network adapter, and then click Uninstall.
> ...

> power down the VM edit the configuration, and add a bridged NIC
> adapter, please do not use the custom option!

> das passiert manchmal nach irgendwelchen Netzwerk-
> konstellationsaenderungen. Ist aber nichts ernstes.

Sorge bereitet mir, daß das Problem an verschiedenen Rechnern auftritt.

> Ansonsten glaube ich nicht, dass es so eine gute Idee ist bei vmnet1
> und 8 das VMware-Bridge Protokoll zu deaktivieren. Entweder lass es
> mitlaufen oder deaktiviere die kompletten Karten wenn du sie nicht
> brauchst.

Ok.

Danke schon jetzt.

Gruß, Gerd

Benutzeravatar
Moderator
Beiträge: 14693
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 16.02.2004, 17:07

Hi
das Problem das du schilderst kann von Netzwerkkartenlaichen kommen.
Aus irgendwelchen Gruenden passiert das manchmal.

Du musst erst an der Kommandozeile anfordern, dass diese versteckten Karten angezeigt werden - und falls du welche findest - das gilt auch fuer den Host - musst du diese Laichen entsorgen.

Das machst du so:
> Click Start, click Run, type cmd.exe, and then press ENTER.
> Type set devmgr_show_nonpresent_devices=1, and then press ENTER.
> Type Start DEVMGMT.MSC, and then press ENTER.
> Click View, and then click Show Hidden Devices.
> Expand the Network Adapters tree.
> Right-click the dimmed network adapter, and then click Uninstall.

Da deine Beschreibung typisch fuer diese Geschichte ueberpruef das bitte als erstes.
Wenn das bei dir nicht zutrifft und du keine grauen Karten im Geraetemanager siehst muessen wir mal weitersehen.

Bis spaeter. ...

Ulli

Member
Beiträge: 11
Registriert: 16.02.2004, 13:46

Beitragvon Gerd » 17.02.2004, 09:14

Hallo Ulli,

> das Problem das du schilderst kann von Netzwerkkartenlaichen
> kommen.
> Aus irgendwelchen Gruenden passiert das manchmal.

mir ist eh schleiferhaft, warum man nicht standardmäßig an diese Laichen kommt.

> Du musst erst an der Kommandozeile anfordern, dass diese
> versteckten Karten angezeigt werden - und falls du welche findest - das > gilt auch fuer den Host - musst du diese Laichen entsorgen.

> Das machst du so:
> Click ...

Das habe ich probiert. Da waren keine Laichen.
Zunächst habe ich jetzt mal das "VMware Bridge Protocol" bei den Adaptern 1 und 8 aktiviert und bei "VMNet Number" jeweils eine "0" angegeben.
IMHO waren die Standardmäßig deaktiviert.

> Da deine Beschreibung typisch fuer diese Geschichte ueberpruef das
> bitte als erstes.
> Wenn das bei dir nicht zutrifft und du keine grauen Karten im
> Geraetemanager siehst muessen wir mal weitersehen.

Da waren keine grauen Karten, aber wie gesagt. Das Problem tritt an 4 Rechnern auf, die eigentlich nur gemeinsam haben, daß sie Client des gleichen Servers sind. Ich warte jetzt mal ab, ob die Aktivierung des "VMware Bridge Protocols" etwas gebracht hat.
Der Fehler tritt ja leider?! nur sporadisch auf.

Gruß, Gerd

Benutzeravatar
Moderator
Beiträge: 14693
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 17.02.2004, 18:19

Hi
hat der Host oder VMware nicht gemeckert, weil du versucht hast mehrere vmnets auf Bridge0 zu legen.
Ich glaub wir haben uns ein bisschen missverstanden. Unter deaktiviert hatte ich verstanden, dass du sie ganz abgeschaltet haettest.
Wenn du die VMwarenetzwerkeinstellungen mit dem GUI machst - dann ist bei den Netzwerkeinstellungen ein leeres Kaestchen die richtige Wahl.

Hast du eigentlich shared folders an? Kommt sich da irgendetwas mit den Laufwerksbuchstaben in die Quere?
Ansonsten hilft vielleicht auch wenn du die Rechner gegenseitig in der hosts-Datei eintraegst.
Achte mal auf deine Host-systemlogs wenn das Netz beim naechsten Mal aussetzt.

Ulli


Zurück zu „VMware Workstation und VMware Workstation Pro“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast