Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Wieso wird der NFS-Speicher bei Autostart Einstellung von VMs nicht mehr gemountet ?

Alles zum Thema vSphere 6.5, ESXi 6.5 und vCenter Server.

Moderatoren: irix, continuum, Dayworker, Tschoergez

Member
Beiträge: 3
Registriert: 15.01.2018, 22:06

Wieso wird der NFS-Speicher bei Autostart Einstellung von VMs nicht mehr gemountet ?

Beitragvon Rikereal » 10.02.2018, 23:58

Hallo,

nach langer Überlegung habe ich mir nun die Flashstation FS1018 von Synology zugelegt, ich persönlich finde es ist ein wirklich tolles Gerät und möchte es auch nicht mehr missen....

Jedoch hat die Flashstation für mein Vorhaben leider einen zu schwachen Prozessor, darum nutze ich diesen für meine Virtualisierungsumgebung als einfachen NFS Server ( aber die Flashstation kommt bei mir noch in vielen weiteren Bereichen zum Einsatz, wo sie sehr gute Dienste vollbringt...) .

Die Flashstation hat aktuell 4 SSD Festplatten ( Raid 10 ) .

Im Netzwerk läuft ein Exsi Server welcher für mein Vorhaben gut ausgestattet ist ( Starker Prozessor und genug Arbeitsspeicher ) .

Nun habe ich bereits alles soweit konfiguriert und habe auch schon eine Virtuelle Maschine angelegt auf welcher Win 10 Proffesional installiert ist.

Soweit so gut und läuft auch alles wunderbar, allerdings möchte ich das die Virtuelle Maschine nach dem Start des Exsi Servers automatisch gestartet wird und habe die Autostart Funktion aktiviert und den Exsi Server neu gestartet .... leider ohne Erfolg, denn wenn die Autostart Funktion aktiviert ist dann wird der NFS Speicher nicht gemountet was zur Folge hat das natürlich die Virtuelle Maschine auch nicht gestartet werden kann aber sobald ich den Autostart deaktiviere ist das Mounten vom NFS Speicher wieder problemlos möglich.

Kann mir hier jemand von euch weiterhelfen ?

Benutzeravatar
King of the Hill
Beiträge: 12163
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Wieso wird der NFS-Speicher bei Autostart Einstellung von VMs nicht mehr gemountet ?

Beitragvon Dayworker » 11.02.2018, 01:54

Fang doch bitte mal von vorne an und teile uns deine genaue vSphere-Version inklu Patchlevel mit. Bei den kostenfreien Versionen ist die HTML5-Oberfläche extremst vom Patchstand abhängig, ob darin alle angebotenen Einstellmöglichkeiten auch wirklich am ESXi gesetzt werden, ggf hilft da bereits ein Update von https://labs.vmware.com/flings/esxi-embedded-host-client.

Experte
Beiträge: 1272
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Re: Wieso wird der NFS-Speicher bei Autostart Einstellung von VMs nicht mehr gemountet ?

Beitragvon Supi » 11.02.2018, 11:09

Hat der ESXI Host auch Lokalen Speicher?
https://www.virtualistic.nl/2012/09/20/ ... nfs-share/
Dummy VM als erstes von dort starten lassen

https://communities.vmware.com/thread/399159
ScratchConfig auf das NAS legen soll ggf. auch helfen ohne die Dummy VM
https://kb.vmware.com/s/article/2145171

ein 4 SSD Raid-10 erscheint mir aber ein wenig overkill. Ein Raid-5 würde die Performance sichern nicht wesentlich einschränken, dafür aber noch die Kapazität um 50% erhöhen.

Benutzeravatar
King of the Hill
Beiträge: 12163
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Wieso wird der NFS-Speicher bei Autostart Einstellung von VMs nicht mehr gemountet ?

Beitragvon Dayworker » 11.02.2018, 12:46

Supi hat geschrieben:Hat der ESXI Host auch Lokalen Speicher?
https://www.virtualistic.nl/2012/09/20/ ... nfs-share/
Dummy VM als erstes von dort starten lassen

Danke "Supi", das nenn ich mal Böse Falle. Mein ESXi startet weiterhin von USB2.0. Die nappit-Appliance als NFS-Server liegt auf einer kleinen SATA2-HDD und wird ala Dummy-VM immer als erstes gestartet...

Member
Beiträge: 3
Registriert: 15.01.2018, 22:06

Re: Wieso wird der NFS-Speicher bei Autostart Einstellung von VMs nicht mehr gemountet ?

Beitragvon Rikereal » 11.02.2018, 13:52

Hallo,

ich hoffe Ihr seit etwas nachsichtig :) , bin noch sehr frisch was das Thema VMware angeht und noch kräftig am einlesen... zumindest macht das Thema sehr viel Spass und das ist die Hauptsache ;)

Also ich nutze nur den EXSI Server 6.5.0 (VMKernel Release Build 5969303), dieser ist in meinem Fall auf einem USB Stift installiert ( Hintergrund ist die Ausfallzeit bei jeglichem crash vom Server auf einem Minimum zu reduzieren, ich habe sozusagen zwei kopien vom USB Stift einen vor Ort und einer wird außerhalb der Firma aufbewahrt, welche ich jederzeit im Notfall an einen anderen Rechner hängen kann und der Ausfall wäre innerhalb von max. 1-2 Minuten behoben....) und greife darauf über den Webbrowser zu, ansonsten keine weitere Software ( versuche zusätzliche Software weitestgehend zu vermeiden ).

Was ich nicht ganz verstanden habe ... was meinst du mit "vSphere-Version inklu Patchlevel" und wo kann ich mir die Informationen über diese einsehen ?


@supi bin mit dem Thema RAID nicht so vertraut und habe das nur schnell überflogen und mich für RAID 10 entschieden. Für mich war es wichtig das das die Geschwindigkeit passt und das die Datensicherheit gewährleistet ist, deshalb habe ich mich für RAID 10 entschieden. Außerdem exsitiert noch eine Sicherung der kompletten Filestation auf einer weiteren Disk welche ich außerhalb der Firma aufbewahre, damit im Fall der Fälle die Daten problemlos hergstellt werden können.

Experte
Beiträge: 1272
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Re: Wieso wird der NFS-Speicher bei Autostart Einstellung von VMs nicht mehr gemountet ?

Beitragvon Supi » 11.02.2018, 14:17

Natürlich bietet ein Raid-10 eine bessere Ausfallsicherheit und höhere Performance als Raid-5. Nur bei SSDs merkt man den Unterschied zum Teil nicht mehr so.
Lösungsvorschlag:
https://cloudarchitectblog.wordpress.co ... load-page/
Laden und als OVA importieren auf lokalen Speicher. ggf. auch deinem USB Stick.
https://www.youtube.com/watch?v=m7Nb3e_OMR8

Diese dann als erste VM starten lassen mit 300 Sekunden Verzögerung und es sollte passen.

Experte
Beiträge: 1272
Registriert: 30.03.2009, 17:13

Re: Wieso wird der NFS-Speicher bei Autostart Einstellung von VMs nicht mehr gemountet ?

Beitragvon UrsDerBär » 12.02.2018, 08:52

Ist zwar OT, aber auch noch mein Senf dazu: Tja und ich würde immer RAID 10 gegenüber RAID 5 bevorzugen wenn man das Geld dazu hat. So gehen die Meinungen auseinander. Die Diskussion RAID 5 zu RAID 10 ist so alt wie die RAID-Level selbst, die Argumenation heute die gleiche wie früher.

Daher: Wer die Kapazität und die Kohle über hat, baut sich ein RAID 10 oder sogar mehr als einen Spiegel pro Platte. Bei den heutigen Kapazitäten erschlägt man ja die typischen KMU-Kapazitäten sowieso mit ner Handvoll Platten.

Ein paar Gründe.
1. Die CPU wird deutlich weniger belastet, insbesondere bei den NAS-Boxen nicht unerheblich
2. Ein Rebuild ist durch die lausige CPU-Performance der meisten NAS viel schneller mit R10
3. Ein Rebuild braucht beansprucht genau eine Platte, nicht das komplette stripe
5. Die Performance ist besser, insbesondere der Latenzdurchschnitt. Das äussert sich zwar nicht unbedingt immer im Durchsatz, sehr wohl aber in der gefühlten Geschwindigkeit


Zurück zu „vSphere 6.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast