Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

APC PCNS in HA Cluster

Moderatoren: irix, continuum, Dayworker, Tschoergez

Experte
Beiträge: 1077
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

[Solved] APC PCNS in HA Cluster

Beitragvon Supi » 12.06.2014, 12:51

So, ich kämpfe auch gerade mit der Appliance. Aber Version 3.1 unter ESX 5.5.

im Vcenter wird immer folgendes gelogt:

Anmelden von Domain\Administrator@192.168.101.25 nicht möglich. 192.168.101.25 ist die IP vom der APC PCNS Appliance.

Der Shutdown funktioniert aber.

Bild

Das Vcenter läuft als Appliance. Wie kommt der da auf @IP?

Benutzeravatar
Jenseits von Gut & Böse
Beiträge: 11839
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 12.06.2014, 18:05

Sollte unter 5.5 nicht die Anmeldung über admin@system-domain laufen?

Jenseits von Gut & Böse
Beiträge: 10606
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 12.06.2014, 18:14

Dayworker hat geschrieben:Sollte unter 5.5 nicht die Anmeldung über admin@system-domain laufen?


Doppelt nein.
1. Unter SSO von 5.1 hies der lokale Hauptuser "admin@system-domain"
2. Unter SSO von 5.5 wurde dieser umbenannt in "administrator@vsphere.local" und der andere verbleibt als alias (beim Upgrade)

Davon losgeloest will man diese Accounts niemals verwenden um den Zugriff von 2nd. oder 3rd. Party Tools bzw. Anwendungen zu ermoeglichen.

Ich habe Tools gesehen welche mit einer Domain Anmeldung nicht umgehen konnten und es musste ein lokaler Account verwendet werden. Bei denen welche es doch konnten fuehrt manchmal user@domain oder domain\user zum Ziel. Ich kann da noch keinen Fehler sehen. Mir war es damals nicht vergoennt die APC Appliance ans vCenter zu bringen.

Davon abgesehen gilt immer die Empfehlung einen seperaten Benutzer anzulegen welcher im Log eindeutige Spuren hinterlaesst und im besten Falle eine Role hat welche nur Rechte enthaelt dir er braucht fuer seine Arbeit.

Gruss
Joerg

Experte
Beiträge: 1077
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 12.06.2014, 19:13

Hallo Jörg und Daywalker,

erst mal danke fürs Feedback.

Also, Domain\Administrator@192.168.101.25 war als Synonym zu verstehen. Da steht Firma-Standort\Administrator@ 192.x.x.x.

In der Vcenter Appliance ist das AD bzw. der "Domain\Administrator" eingetragen.
Auch in der APC Appliance ist als Login für das Vcenter der Domain Admin (also Firma-Name\Admin) eingetragen.

vielleicht sollte ich es mal mit diesen administrator@vsphere.local versuchen.

Aber ich sehe, das ist wohl noch ein recht neues Terrain.

Mal so zum Finden:

Installations Guide PCNS 3.1 http://www.apcmedia.com/salestools/PMAR ... _R0_EN.pdf

User Guide PCNS 3.1 :
http://www.apcmedia.com/salestools/PMAR ... _R0_EN.pdf

Wobei der User Guide auf den Application Note verweist im AD Umfeld:

http://www.apc.com/prod_docs/results.cf ... &Value=127

http://www.apcmedia.com/salestools/SJHN ... _R2_EN.pdf


Supi hat geschrieben:.... liegt es ggf. daran, dass ich die AD Domäne nicht als Primäre Domäne im Vcenter SSO definiert habe? Denn als Indentitätsquelle ist die Domäne eingerichtet. (Sonst könnte ich mich auch nicht am Vcenter mit dem Domain Account anmelden.)



Video gucken: http://tv.schneider-electric.com/site/s ... Mb_5kQUJn0

----------------------

http://forums.apc.com/message/63104#63104

Bei Einsatz eines lokalen Users gilt wohl folgendes :

Have done some further tests and the solution involving vMA and scripting is not required. The PowerChute Virtual appliance or vMA can be used.

The vCenter Server account configured in PowerChute Network Shutdown must have Administrator permissions on vCenter Server and on each of the ESXi hosts being managed by PowerChute. This can be an Active Directory account or a local user account.

When using a local user account, see the instructions below:

Log in to vCenter Server machine and add a user via Computer Management -> Local Users and Groups for Windows. On Linux/vCenter Server Appliance use the terminal commands “useradd” and “passwd”.
Log in to vCenter Server using the vSphere Client and click on the Permissions tab at the root inventory level.
Right click and select Add Permission.
In the Assign Permissions dialog click Add.
Select (server) under domain, select the User that was added in step 4 and click Add.
Click OK.
Change the Assigned role to Administrator.
Select “Propagate to Child Objects” and Click OK.
Log in to each ESXi host using the vSphere client and click on Local Users and Groups tab.
Right click and select Add…
Enter the same username and password that was used when adding the local user to vCenter Server.
Click on the Permissions tab.
Right click and select Add Permission.
In the Assign Permissions dialog click Add.
Select (server) under domain, select the User that was added in step 11 and click Add.
Click OK.
Change the Assigned role to Administrator.
Select “Propagate to Child Objects” and Click OK.

When using Active Directory VMware provides a default AD Group account called "ESX Admins". This group is automatically added to each ESXi host joined to the domain and is granted administrator rights by default.


Note:
1. This group does not exist in Active Directory by default. It needs to be created by an Administrator via Active Directory Users and Groups. Once created any users that are added to that group will have VMware administrator access.
2. The name of this group and automatic assigning of administrator privileges can be modified via VMware Advanced Settings:


Config.HostAgent.plugins.hostsvc.esxAdminsGroup
Config.HostAgent.plugins.hostsvc.esxAdminsGroupAutoAdd


---------------------------

Hm, ich nutze doch aber den AD Account.

Jenseits von Gut & Böse
Beiträge: 10606
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 12.06.2014, 19:22

"....Server and on each of the ESXi hosts being managed by PowerChute"

1. Pruefe nach ob die Meldungen daher kommen das sich jemand versucht AM HOST anzumelden
2. Per default und auch unabsichtlich ist der HOST nicht mit dem AD verbunden und folglich kann sich auch DIREKT AUF DEM HOST keiner mir domain\user anmelden


Loesung:
- Lokalen User verwenden welcher im vCenter UND auf dem Host gleichlautet
oder
- ESXi Hosts mit an AD

Gruss
Joerg

Experte
Beiträge: 1077
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 12.06.2014, 21:40

@Joerg:

Danke fürs Feedback.

Der AD Join der ESXi Host hat ein wenig gebracht.... eine andereMeldung:

Benutzer @192.168.101.25 konnte nicht
angemeldet werden: Keine Berechtigung
Fehler
12.06.2014 21:20:01
esx01.domain.local
...Ok, Gruppe ESX Admins im AD angelegt.

Bei einem Host hat nun die Anmeldung geklappt, bei dem anderen aber nicht.

So ein Mist
.... jetzt ist erst mal Fussball dran.

Experte
Beiträge: 1077
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 13.06.2014, 09:52

irix hat geschrieben:Loesung:
- Lokalen User verwenden welcher im vCenter UND auf dem Host gleichlautet
oder
- ESXi Hosts mit an AD

Gruss
Joerg


Da das mit dem AD nicht will, versuche ich den Lokalen User. Ja, in der Vcenter Appliance muss ich den ja auch per ssh anlegen.
Wie bescheuert komplex soll ich denn da das PW definieren?
Edit... ok, Case sensitiv.

Experte
Beiträge: 1077
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 13.06.2014, 12:29

Also ich gebe es auf.
Als der Techniker auf ESXi 5.5 upgedated hat, funktioniert es ja. (getestet)
Vielleicht findet sich ja demnächst mal wieder ein Zeitfenster.

Als lokaler User pcnsadmin (in der Vcenter Appliance und den ESXi Host angelegt) klappt jetzt die Anmeldung, nur die APC Appliance meldet immer alle 5 minuten:

apc pcns Attempting to power on VMs on Host XXXX that did not start.

Wieder zurück auf Domain\Admin in der APC Software umgestellt meldet Host 1 Fehlerhafte logins von Domain\Administrator... aber auch, das es mit dem Account mal klappt.
Dazu aber noch erfolgreiche Logins vom pcnsadmin?!
Beim andere Host klappt es mit dem Domain\Administrator gar nicht (immer failed), dafür klappt es ebenso weiter mit dem "lokalen" pcnsadmin Account.

Wie geschrieben, in der APC Appliance aber auf Domain\Administrator umgestellt.

Zumindest log die APC PCNS Appliance nicht mehr " apc pcns Attempting to power on VMs on Host that did not start. " :roll: :roll:

Experte
Beiträge: 1077
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 20.06.2014, 08:57

So, das APC Forum war hilfreich.
http://forums.apc.com/message/63514#63514

Wer auch die Meldung von/in der Appliance bekommt :

"Attempting to power on VMs on Host esx_xx.domain.local that did not start"

einfach mal per ssh bei der Appliance anmelden und hier nachschauen:
/opt/APC/PowerChute/group1/VirtualizationFileStore.properties

In der Datei hatte ich noch Einträge, und die VM's wollte die Appliance wohl neustarten.
Einfach mal gelöscht und alles wieder gut.
Warum die da aber nicht von allene rausfallen, keine Ahnung.

EDIT: Kann also geschlossen werden.


Zurück zu „vSphere 5 / ESXi 5 und 5.1“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast