Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

immer wieder: USB in VMware ... Kaufberatung

Ältere Postings, aber zu Schade zum Vergessen...

Moderatoren: irix, continuum, Dayworker, Tschoergez

Benutzeravatar
Moderator
Beiträge: 14648
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

immer wieder: USB in VMware ... Kaufberatung

Beitragvon continuum » 25.04.2004, 13:25

USB in VMware

es steht zwar deutlich in den VMware-specifikations aber da niemand diese zu lesen scheint hier noch einmal:

USB 2 Geräte werden von VMware NICHT unterstützt.

USB 1.1 Geräte werden unterstützt.

USB 2 Geräte - die auch in einem USB 1.1 Compatibility-Modus laufen koennen - können eventuell benutzt werden.

64bit- Hosts unterstützen zur Zeit überhaupt kein USB.


Leute - lest das Handbuch bevor ihr euch irgendwelche Geräte kauft, die nachher nicht laufen.


Falls ihr auch meint, es sollte eine Liste geben, die brauchbare Geräte aufführt, dann meckert bitte hier :
http://www.vmware.com/community/thread. ... 7&tstart=0

Wenn jeder, der diesen Post liest, seine USB Geräte, die laufen hier melden würde, dann gäbe es sicher viel weniger Fehlkäufe.

Ulli

Benutzeravatar
Moderator
Beiträge: 14648
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Eumex 504PC USB - ISDN Telefonanlage

Beitragvon continuum » 31.10.2004, 04:09

Host: 2k, XP
Gast: Win98, 2k
Gerät: Eumex 504PC USB
VMware: WS3.2 und höher

Gäste können ISDN über COM oder USB unabhängig vom Host verwenden.
Verwaltung der Telefonanlage funktioniert

(bitte beim Posten an die Suchmaschine denken - Gerät und Stichwort USB in den Titel setzen)

Benutzeravatar
Profi
Beiträge: 992
Registriert: 07.08.2003, 09:32

Fritz! Card USB 2.0

Beitragvon looping » 31.10.2004, 11:11

bei einem bekannten läuft folgende konstillation:

vmware workstation 4.5.1-7568

host: xp-pro + sp1
gast: windows me

usb-hardware: Fritz! Card USB 2.0

die hardware wird komplett vom gast übernommen und startet die autoinstallation. dazu ist jedoch notwendig, das die maschine vor beendigung des bootvorganges angehalten wird (z.b. pause-taste während der post meldung), die usb-hardware virtuell übernommen wird und windows die hardware noch während des bootvorgangs erkennt. da es jedoch offentsichtlich mehrere versionen dieser Fritz! Card mit unterschiedlicher firmware gibt, kann ich nichts grundsätzliches versprechen.

mfg

looping

Member
Beiträge: 2
Registriert: 12.10.2005, 14:23

Beitragvon endo » 19.10.2005, 12:36

Also, ich hab als Host & Guest Win2000 SP4 unter VMware 5.0
und habe über USB getestet:

Acer ISDN 128 Surf Mini USB (ohne Erfolg)
AVM Fritz! Card USB Version 2.1 (mit noch weniger Erfolg)

Das Acer wurde wenigstens als richtiges USB-Device erkannt und installiert. Die Fritz!Card wollte trotz USB-Trick von Looping auf dem Guest nicht richtig funktionieren, wohl ein USB-Problem. AVM gibt sich laut deren Hotline übrigens nicht mit Tests auf VMware ab.

Mich nervt das wahnsinnig denn ohne ISDN im Guest darf ich jetzt die Applikation auf nem anderen Server unterbringen, ohne schönes VMware.
Wenigstens war das AVM nur ne kostenlose Teststellung.

Experte
Beiträge: 1188
Registriert: 08.11.2005, 13:08
Wohnort: bei Berlin

VM 4.5.2 USB Fritz!XISDN + Scanner Host Suse9.2 Gast Win98

Beitragvon e-e-e » 08.11.2005, 16:04

Hallo,

in meiner Anordnung klappt das Ganze, ich muß allerdings beim booten des Hosts und des Gasts den USB-Stecker draußen lassen (Problem hotplug von Suse) und wenn alle hochgefahren sind, USB stecken, Erkennung läuft und funktioniert.
In anderer VM habe ich einen Epson Perfection 1250 installiert, hier kann der Stecker gesteckt bleiben, nach dem booten nur VM->USB Port1->Epson Scanner aktivieren und gut.

MfG

Member
Beiträge: 1
Registriert: 14.11.2005, 10:55

Re: VM 4.5.2 USB Fritz!XISDN + Scanner Host Suse9.2 Gast Win

Beitragvon hohony » 14.11.2005, 11:11

e-e-e hat geschrieben:Hallo,

in meiner Anordnung klappt das Ganze, ich muß allerdings beim booten des Hosts und des Gasts den USB-Stecker draußen lassen (Problem hotplug von Suse) und wenn alle hochgefahren sind, USB stecken, Erkennung läuft und funktioniert.

MfG


DAS war für mich der ultimative Trick!
Habe mit erheblichem Aufwand Fritz!Card USB V1.0 unter VMWare 5.0 und Asterisk@home installiert, alles war toll, CAPI integriert, keine Fehlermeldungen. Allein, es gab keine Connection.

Jetzt klappt es: USB-Stecker aus der FritzCard 'raus, VM starten, Focus auf VM, USB-Stecker wieder rein --- und die Fritz!Card USB LÄUFT endlich!!!

Seit Tagen daran rumgefrickelt.
DANKE!!!

Member
Beiträge: 46
Registriert: 29.10.2004, 09:12
Wohnort: Fürth

Re: Fritz! Card USB 2.0

Beitragvon Kossner » 17.11.2005, 15:06

looping hat geschrieben:bei einem bekannten läuft folgende konstillation:

vmware workstation 4.5.1-7568

host: xp-pro + sp1
gast: windows me

usb-hardware: Fritz! Card USB 2.0

die hardware wird komplett vom gast übernommen und startet die autoinstallation. dazu ist jedoch notwendig, das die maschine vor beendigung des bootvorganges angehalten wird (z.b. pause-taste während der post meldung), die usb-hardware virtuell übernommen wird und windows die hardware noch während des bootvorgangs erkennt. da es jedoch offentsichtlich mehrere versionen dieser Fritz! Card mit unterschiedlicher firmware gibt, kann ich nichts grundsätzliches versprechen.

mfg

looping


Host: XPSP2 + VMware Workstation 5.0
Guest: XPSP2
AVM Fritz! Card USB 2.0

Habe es auch nach der Methode probiert, aber das Gerät lässt sich leider nicht im Gerätemanager in der VM starten!

Kann man nur hoffen das das endlich von VMware mal vernünftig integriert wird und bei 5.5 nicht wieder nur ein paar Pseudo-Neufunktionen, die zu keinem teuren Update berechtigen!

Member
Beiträge: 46
Registriert: 29.10.2004, 09:12
Wohnort: Fürth

Beitragvon Kossner » 17.11.2005, 17:01

Update:

Muss meine Kritik für die V5.5 zurückziehen. Mit V5.5 RC2 funktioniert das ganze! :D

Member
Beiträge: 383
Registriert: 03.10.2005, 03:29

Beitragvon al!ve » 11.12.2005, 02:31

sagt mal, was haltet ihr denn von device-servern?
http://www.silexeurope.de/euro/products ... 000u2.html
hier mal beschreibung und ne zeichnung zur funktionsweise.

kurze erklärung: die geräte tragen usb-ports, werden allerdings nicht in den rechner gesteckt sondern ins netzwerk gehängt. über treiber können dann rechner im netzwerk die usb-ports des device-servers so nutzen wie lokale usb-ports.

klar, 130€ sind nicht wenig, aber wenn dafür die beschränkung des "erst vm booten, dann vm in den fokus, dann usb-gerät anstecken" wegfällt könnte man sich das durchaus überlegen.

Member
Beiträge: 42
Registriert: 20.10.2005, 16:54

Beitragvon tomasf » 22.12.2005, 16:05

Schade dass hier noch keiner Erfahrungen zum Silex SX-2000U2 USB Device Server berichten kann. Der Adapter scheint eine akzeptable Lösung für das VMWARE-USB-Dilemma zu sein. (Scanner etc)

Hier ein kurzer Testbericht
http://www.everythingusb.com/silex_sx-2000u2_usb_device_server.html

Member
Beiträge: 19
Registriert: 12.01.2006, 12:21

Beitragvon Hausrocker » 12.01.2006, 12:26

Der SX-2000U2 als auch der SX-2000WG funktionieren einwandfrei unter VM Ware.
Ich nutze Version 5.5.0 mit verschiedenen Betriebssystemen: XP home und pro, Windows 2000.
Es klappt einwandfrei sich zu verbinden, man sollte den punkt bei der Netzwerkkonfiguration wählen, dass das Guest OS direkten Zugriff zum Netzwerk haben soll.
Grundsätzlich ist es so, dass Geräte, die mit dem Betriebssystem so funktionieren und auch so unter VM Ware lokal laufen auch mit dem SX-2000U2 oder WG laufen.

Scanner und MFP's sind kein Problem.
Die Lösung empfiehlt silex für Linux Benutzer, da es die Software SX-VL nicht für Linux gibt. Mit dem Umweg VMWare und Guest OS Windows geht es dann.

Wo man die Geräte kaufen kann: Klick zur silex Homepage
Wenn noch jemand Fragen hat zur Einrichtung helfe ich gerne.

Member
Beiträge: 383
Registriert: 03.10.2005, 03:29

Beitragvon al!ve » 17.02.2006, 03:33

http://www.sphinxcomputer.de/produktdb/ ... kt_ID=1173

http://www.keyspan.com/products/usb/server/
http://www.keyspan.com/support/linux/

diese dinger hab ich bisher noch ausfindig machen können. beide -- was mir relativ wichtig war -- mit linux-support. da der conline recht "lapprig" aussieht hab ich ja die hoffnung, dass ich da mit weniger als 120€ rauskomme. wenn das teil für 100€ oder drunter und einzeln käuflich zu erwerben ist werd ich mir mal sowas besorgen und ausprobieren glaub ich.

sollte hier noch jemand erfahrungen mit zeugs dieser art gesammelt haben bitte nur raus damit :D.


frage zum bisher genannten sx-gerät:
wann muss ich das teil einer vm zuweisen? kann ich einmal bei der installation zu meinem betriebssystem sagen "da is was im netz, das nimmst du gefälligst" und ab dann ist es wie ein normaler usb-port zu bedienen, oder muss ich einzelne usb-geräte zuweisen? konkret will ich nen wts aufsetzen und den usern so n teil auf den schreibtisch stellen, damit se nach bedarf nen usb-stick reinstecken können. außerdem spiel ich mit dem gedanken, mir ne vm mit asterisk aufzusetzen, dann würd ich zwei avm fritzcard usb geräte an sowas klemmen und das als voip tk-anlage nutzen. voraussetzung natürlich dass die geräte ohne weiteres zutun auch nach nem eventuellen neustart einwandfrei funktionieren.

Member
Beiträge: 8
Registriert: 21.07.2004, 15:12

Beitragvon TobiKarl » 22.02.2006, 16:56

Hallo zusammen.

Ich hatte auch die vergangenen Tagen mit USB-Scannern zu kämpfen. Irgendeiner der tollen Chefs hier kam auf die Idee Scanner für die CeBIT anzuschaffen ohne mich vorher zu fragen, ob diese für VMware (Präsentationsumgebungen) überhaupt geeignet sind.

:roll:

Ergebnis: Bluescreen in der VM bzw. grottenlangsames Scannen

Um das Problem kurzfristig zu lösen, haben wir mit einer PCMCIA-SCSI-Adapter gearbeitet, der den Scanner einfach als SCSI-Scanner an die VM durchschleift. Sicher keine mega-geniale Lösung. Hat mir aber den Arsch gerettet, weil wir wissen ja, wer schuld gewesen wäre, wenn sich der Einkauf des Chefs als blödsinnig herausgestellt hätte... richtig ich. :grin:

Also in diesem Sinne.... Lasst euch von euren Chefs nicht anfucken, und wer ähnliche chaotische Verhältnisse hat kann sich unter Umständen mit diesem Trick behelfen. Viele USB-Geräte können nämlich auch andere Schnittstellen.

Tobi

Member
Beiträge: 19
Registriert: 12.01.2006, 12:21

Beitragvon Hausrocker » 29.03.2006, 10:08

al!ve hat geschrieben:frage zum bisher genannten sx-gerät:
wann muss ich das teil einer vm zuweisen? kann ich einmal bei der installation zu meinem betriebssystem sagen "da is was im netz, das nimmst du gefälligst" und ab dann ist es wie ein normaler usb-port zu bedienen, oder muss ich einzelne usb-geräte zuweisen? konkret will ich nen wts aufsetzen und den usern so n teil auf den schreibtisch stellen, damit se nach bedarf nen usb-stick reinstecken können. außerdem spiel ich mit dem gedanken, mir ne vm mit asterisk aufzusetzen, dann würd ich zwei avm fritzcard usb geräte an sowas klemmen und das als voip tk-anlage nutzen. voraussetzung natürlich dass die geräte ohne weiteres zutun auch nach nem eventuellen neustart einwandfrei funktionieren.


was genau willst du wissen, ich versteh die frage nicht ganz.
Das Funktionsprinzip der SX-Geräte ist das, dass du dich per software verbindest, das Gerät dann auf einem eben virtuellen USB Port Treiber erkannt wird, als wenn es lokal angeschlossen ist.
Dafür gibts auch eine Funktion, dass beim Hochfahren automatisch SX-VL gestartet und dann die Verbindung automatisch hergestellt wird.

Mit den USB 2.0 HiSpeed Device Servern SX-2000U2 und SX-2000WG hat man auch quasi USB 2.0 HiSpeed unter VMWare zur Verfügung, eben übers Netzwerk.

Da die SX-Geräte keinen isochronen Datenstrom unterstützen kann man nicht über angeschlossene USB Telefone telefonieren z.B., eine USB ISDN Karte, wie sie in einer Teledat USB 2 a/b drin ist wird aber unterstützt - DFÜ Verbindung und auch Faxe senden klappt. Linux wird nicht unterstützt, die SX-VL Software und die virtuellen USB Port Treiber gibts im Moment nur für Windows XP, 2000, Windows Server 2003 und Mac OS 10.2.8 oder höher.

Benutzeravatar
Member
Beiträge: 40
Registriert: 27.06.2003, 08:48
Wohnort: Sauerland

Beitragvon iPC » 04.08.2006, 08:40

Wenn noch Erfahrungswerte gesucht werden:

VMWare 5.5. Host XP
Gast XP

Bluetooth Gerät von Allnet mit Widcom Treibern (hab ich mal vor Monaten getestet)
Smartphone MDA/XDA Version 3 - läuft mit Activesync zusammen. Denke zwar nicht das die weniger gute Konnektivität für einen Dummuser geeignet ist. Aber mit ein wenig Übrung klappt auch diese Verbindung wie alle anderen.

Gruß
Alex

Member
Beiträge: 3
Registriert: 10.08.2006, 19:11
Wohnort: Sehnde

Kein USB in Gästen

Beitragvon amk » 10.08.2006, 19:44

Hallo!

Ich habe hier auf meiner Kiste als Host Windows XP Prof SP2 (engl.) laufen und VMware WS 5.5.1. Als Gastsysteme habe ich ebenfalls Win XP Prof SP 2, sowie SuSE Linux 10.0.
Leider kann ich in keinem der Gastsysteme auf USB Geräte zugreifen:
- USB 1.1 Memory Stick
- USB 2.0 Memory Stick
- USB 2.0 externe Festplatte
- iPOD nano
- Sony MD Player
- KonicaMinolta Digitalkamera
Laut Handbuch soll es funktionieren, wenn der Host USB 2.0 benutzt. Aber entweder bekomme ich (unter Windows Gastsystem) die Meldung "At least one of the USB devices has malfunctioned..." oder es gibt 3-mal das übliche DING-DONG, als ob man ein USB Gerät rein-, raus- und wieder reinsteckt.
Unter "VM > Removable devices" sind die eingesteckten Geräte allerdings aktiviert (haken ist gesetzt). Klickt man allerdings jetzt auf den entsprechenden Eintrag, schmeißt sich die VM weg. Es sieht fast so aus, als ob mein Host sich die Geräte mit Gewalt wieder holt, denn dort sind sie auch aktiv und ich kann sie benutzen.
Nun kann ich im Host die Geräte ja freigeben, aber leider kann ich auf diese Art die Musikgeräte nicht in einer VM nutzen.
Auf der Arbeit funktioniert USB im Gast, allerdings ist dort der Host nur mit USB 1.1 bestückt und läuft unter SuSE Linux 10.0.
Hat jemand eine Idee, wo man evtl. noch dran drehen kann?

Grüße
Andreas

Benutzeravatar
Member
Beiträge: 40
Registriert: 27.06.2003, 08:48
Wohnort: Sauerland

Beitragvon iPC » 10.08.2006, 20:12

hallo,

ich hatte auch mal Probleme mit USB - deinen ähnlich, jedoch ohne Fehlermeldungen. Hab einiges versucht:

- USB Geräte und Controller aus Host und Gast rausgeschmissen
- VMWare neu installiert
- div. Versuche mit dem Gastsystem

Ich meine zu wissen, daß es daran gelegen hat, daß ich das USB aus der Gastkonfiguration geschmissen habe, Gast gestartet und dann wieder in die Konfig eingebaut. Dann hatte ich in diesem Gast USB.

Ob das allerdings läuft weiß ich leider net. Evtl. würd ich dir empfehlen mal Testweise auf einer anderen Platte dein System neu zu installieren, um Probleme mit dem USB des HOST auszuschließen.

Member
Beiträge: 3
Registriert: 10.08.2006, 19:11
Wohnort: Sehnde

Beitragvon amk » 13.08.2006, 19:00

@iPC

ich werde mal versuchen USB aus der Gastkonf rauszuschmeissen und neu zu konfigurieren.
Da ich in Kürze wohl auch SuSE Linux 10.1 installieren werde, werde ich mal meine Lizenz von der Arbeit mitbringen und schauen, was passiert wenn VMware unter Linux läuft.
Wenn sich da was interessantes tut, werde ich das hier mal schildern.

Bis dahin
Andreas

Member
Beiträge: 6
Registriert: 22.09.2006, 10:02

Beitragvon Tark » 22.09.2006, 13:02

Bei mir klappte USB bisher Problemlos (ok, bisher nur USB Stick getestet).

Host und Gast ist Windows XP SP2.
Der USB 2.0 Stick wurde Problemlos erkannt, vmware gab auch eine Meldung, dass er an einem 2.0 Anschluss schneller sei.
alles funktionierte Reibungslos...
Wie es im Manuel steht 8)

Member
Beiträge: 383
Registriert: 03.10.2005, 03:29

Beitragvon al!ve » 23.10.2006, 12:44

Hat jemand neben dem Keyspan- und dem Silex-Gerät zufällig noch weitere Ideeen für einen Device-Server? Ich such das momentan nämlich mit Linux-Support, und den bieten schließlich beide nicht.

Member
Beiträge: 2
Registriert: 20.11.2006, 17:59

Re: immer wieder: USB in VMware ... Kaufberatung

Beitragvon fortunato » 20.11.2006, 18:09

Hi @ all!
Habe (mea culpa) das Manual auch nicht gelesen. Ein aufmerksames Stöbern in diesem Forum hat mir das aber wahrscheinlich erspart. Danke an alle, deren Tips mir geholfen haben! :grin:

Member
Beiträge: 36
Registriert: 09.08.2006, 01:02

Beitragvon Fenrir » 21.11.2006, 13:27

ich werd auch mal die Keyspan oder silex Tools ausprobieren, zum Glück ist die Lösung nur für Windowsmaschinen gefragt.

Member
Beiträge: 2
Registriert: 20.11.2006, 17:59

Beitragvon fortunato » 24.11.2006, 16:54

Das Stöbern hat mir das Manual tatsächlich erspart. Momentan verwalte ich mein Nokia 6233 über USB unter einem virtuellen WinXP. Ich bin guter Hoffnung, dass das mit Bluetooth ebenfalls hinhaut! Werde demnächst versuchen, den ganzen Kram mit einem VMWare-Player und einem WinXP von einem Stick aus zu machen. Dann kann ich den ganzen Kram in allen Büros veranstalten, ohne lokal irgendwelche Software installieren zu müssen. Super! :D

Experte
Beiträge: 1188
Registriert: 08.11.2005, 13:08
Wohnort: bei Berlin

Beitragvon e-e-e » 25.11.2006, 07:49

Hallo,

ich verwende inzwischen neben den o.g. Geräten noch eine externe LaCie-HDD 250 GB und eine In-coder Mini-HDD 4 GB an meinen USB´s, weiterhin über WinXP- und Win98-Gast und installiertem ActivSync die PDA´s Dell Axim X5 und X50. Die Synchronisation der PDA´s ist zwar äußerst lahm (wahrscheinlich Laufzeitproblem), aber klappt.

Gruß Ronny

P.S. Ich verwende neben dem VMware-Server (wie in Signatur zu sehen) natürlich auch die WS.

Member
Beiträge: 28
Registriert: 13.10.2005, 17:38
Wohnort: Würzburg

Silex USBTOLAN

Beitragvon a-salt » 11.12.2006, 18:25

Hallo, ich benutze auch den Silex.
Ich habe allerdings das Problem dass ich an dem Ding einen Dongle hängen habe.
Da läuft gar nix die Vm erkennt das Ding nicht richtig obwohl ich schon Treiber getauscht habe usw.
Mit allen anderen USB Teilen gibt es überhaupt keine Probleme.
Funz einwandfrei
Gruß Arthur


Zurück zu „Ältere angepinnte Workstation- & Player-Threads“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast