Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

ESXi 4 auf einen USB Stick installieren.

Moderatoren: irix, continuum, Dayworker, Tschoergez

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 15.03.2010, 19:14

Frei nach dem Motto: warum einfach wenn es auch kompliziert geht :lol:

Member
Beiträge: 2
Registriert: 15.03.2010, 17:52

Beitragvon segro21 » 16.03.2010, 09:06

und wenn man anschließend noch anpassungen in dem esx vornehmen will, will man womöglich die vm vom USB booten, bevor man sie irgendow in einen Server steckt, der sich einfach per dhcp ne ip zieht.
http://www.vladan.fr/great-tip-how-to-b ... rkstation/

mit plop von iso image booten und als boot platte dann usb auswählen, fertig ;-)

Member
Beiträge: 101
Registriert: 17.06.2005, 09:39

ESXi 4.1

Beitragvon DschingisKarn » 23.07.2010, 10:03

Ich hatte das ganze mal noch für den neuen 4.1 ein wenig überarbeitet, dort ist die Verzeichnissstruktur und die Dateinamen ein wenig anders.

http://vmware-forum.de/viewtopic.php?t= ... highlight=

Hatte es leider unter ESX und nicht ESXi gepostet.

Member
Beiträge: 62
Registriert: 05.04.2008, 15:09

Re: ESXi 4.1

Beitragvon brigadeleiter » 26.02.2011, 00:47

DschingisKarn hat geschrieben:Ich hatte das ganze mal noch für den neuen 4.1 ein wenig überarbeitet, dort ist die Verzeichnissstruktur und die Dateinamen ein wenig anders.

http://vmware-forum.de/viewtopic.php?t=20762&start=0&postdays=0&postorder=asc&highlight=

Hatte es leider unter ESX und nicht ESXi gepostet.


vielen dank für die anleitung, ich habs statt mit winrar mit 7ZIP durchgeführt und alles hat wunderbar funktioniert. wir hatten heute nämlich mit 2 verschiedenen pata dvd-roms und einem dvd-brenner über usb immer wieder folgenden fehler

Code: Alles auswählen

ESXi 4.1: unable to find the system image to install

dvd: esxi 4.1.0 (build.348481)

ciao,
david

Member
Beiträge: 7
Registriert: 09.09.2008, 16:56

Beitragvon tekknokrat » 26.02.2011, 09:04

Wo ich hier immer von der Vergewaltigung von USB Sticks höre. Wie sieht es denn aus mit einer Ausweichstrategie bei Performanceengpässen im SAN? Ein Windowskollege konnte sich bspw. hierbei retten in dem er VMs per svMotion auf seinen lokalen Storage gemoved hatte. Mit einem USB Stick hätte er hier alt ausgesehen. Hm, jetzt kommt bestimmt SAN Performanceprobleme gibt es nicht :roll:

P.S. Ich denke selber über ein Konzept nach ESXi irgendwann mal über iLO (HP Proliant) zu laden, also den Grundgedanken finde ich ja nett...

Jenseits von Gut & Böse
Beiträge: 10957
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 26.02.2011, 10:17

Was hat das eine (USB) mit dem anderen (lokaler DS) zutun? Das schliesst sich doch nicht aus!

- Auf lokalem DS kann man Templates, Replikas oder VMs betreiben wenn die Performance nicht reicht bzw. Latzenprobleme vorhanden sind. Unsere Netware 4.11 VM mochte das EQL iSCSI SAN garnicht
- keine 1MB Blocksizeproblematik


Trotzdem startet der ESXi von USB/SD.

Gruss
Joerg

Benutzeravatar
Moderator
Beiträge: 3476
Registriert: 23.02.2005, 09:14
Wohnort: Burgberg im Allgäu
Kontaktdaten:

Beitragvon Tschoergez » 26.02.2011, 13:06

Auch für die Swap-Dateien können lokale Platten interessant sein, bei SSD-Platten kann man sogar ganz anders an die Memory-Berechnung gehen.

Beim booten vom USB-Stick sollte man aber ausführlichst die USB-Sticks testen. Ich hab schon zusammengeschmolzene Sticks gesehen, die den thermischen Belastungen im Server nicht gewachsen waren (beim Anschluss an nen internen USB-Port), und hatte schon mal die fiese Situation, dass alles gut funktioniert hat bis auf das nachinstallieren von EMC-SATP. Nach nem wechsel des Sticks (mit sonst identischer Konfiguration) gings ohne Probleme.

Aber ansonsten hat die USB-Variante sehr praktische Vorteile. Wird nur noch übertroffen vom direkten Booten aus dem Netz, was wohl in den nächsten ESX-Versionen kommen soll (ala VirtualIron).
Grüße,
jörg

Member
Beiträge: 6
Registriert: 14.03.2011, 01:04

Beitragvon Scott » 14.03.2011, 01:08

Hallo,

schon seit längerer Zeit setze ich den ESX 4.1 Hypervisor erfolgreich auf einem USB-Stick ein. Das System läuft wirklich sehr gut! Nun würde ich gerne eine Kopie bzw. ein Klon von dem Stick erstellen. Leider war ich bisher nicht erfolgreich. Probiert habe ich Clonezilla und HDClone. Der 'neue' USB-Stick war jeweils nicht bootfähig. Wäre super, wenn jemand einen Tipp hat. Vielen Dank.

Guru
Beiträge: 2461
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 14.03.2011, 07:12

Scott hat geschrieben:Hallo,

schon seit längerer Zeit setze ich den ESX 4.1 Hypervisor erfolgreich auf einem USB-Stick ein. Das System läuft wirklich sehr gut! Nun würde ich gerne eine Kopie bzw. ein Klon von dem Stick erstellen. Leider war ich bisher nicht erfolgreich. Probiert habe ich Clonezilla und HDClone. Der 'neue' USB-Stick war jeweils nicht bootfähig. Wäre super, wenn jemand einen Tipp hat. Vielen Dank.


Unter der Bedingung das dein neue Stick kein Problem als bootdevice hat solle ein dd unter linux reichen.
Vielleicht nehem die Tools ja auch einfac nich die Flags der Partitionen mit.

Member
Beiträge: 11
Registriert: 30.07.2008, 11:54

Beitragvon herrbert » 14.03.2011, 09:01

Hallo,

zum clonen von USB-Sticks bzw. SD-Karten versuch mal
Securepoint Imaging Tool
http://download.securepoint.de/?d=imagingtool/v2.2

Klappt prima.

Member
Beiträge: 6
Registriert: 14.03.2011, 01:04

Beitragvon Scott » 16.03.2011, 21:58

Hallo,

leider kann ich das erst wieder am WE testen. Kann es denn passieren, dass ein USB-Stick nicht boot-fähig ist? Ich dachte das passiert nur noch bei alten Modellen. Der Stick ist ca. 1 Jahr alt.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 17.03.2011, 00:29

ich clone ESXi-sticks mit einer Knoppix -CD

ich stecke beide sticks in einen beliebigen Rechner, boote den von Knoppix und mach dann in einer root-shell

dd if=/dev/sda of=/dev/sdb

vorher mit gparted nachschauen als was die sticks erkannt werden
hier ist /dev/sda das original und /dev/sdb der Clone

Unter Windows ist das problematisch weil Windows bei USB-removable devices keine Partitionen mag

Member
Beiträge: 6
Registriert: 14.03.2011, 01:04

Beitragvon Scott » 21.03.2011, 01:11

Mit dd hat es geklappt. Aber auch erst nachdem ich einen anderen Stick genommen habe.
Danke!

Member
Beiträge: 100
Registriert: 12.05.2011, 08:04

Auf einem Werbegeschenk

Beitragvon Torsten.E » 12.05.2011, 10:13

Bei mir läuft ESXi auf einem stink normalen USB-Stick. Ich weis auch nicht woran man einen "hochwertigen" USB-Stick erkennt.

Also wählerisch ist das Teil nicht, weshalb auch, es muss vermutlich nur die paar Daten einmal laden und fertig.

Benutzeravatar
King of the Hill
Beiträge: 12046
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 12.05.2011, 16:05

Das wählerisch und hochwertig ist hier relativ zu verstehen. ;)

Wählerisch: Meist scheitert es am Rechner-Bios (keine Ahnung ob das UEFI dort besser aufgestellt ist), weil dieses den USB-Boot nur von einem USB-Stick mit deaktivem Removable-Bit erlaubt. Ich hatte schon USB-Sticks mit mehr als 4GB gesehen, bei denen dieses Bit gesetzt war.
Ich hab auch einen 2GB-Stick, bei dem dieses Bit fehlt. Das äußert sich dann unter Windows darin, daß er erstmal unter Lokaler Datenträger auftaucht, nicht wie sonst als Wechseldatenträger und zum anderen kann man ihn nicht auswerfen, da sich lokalen Datenträger halt nicht auswerfen lassen. Als weitere Krönung legt Windows dann sogar noch versteckte Ordner für Papierkorb und System Volume Information an...

Hochwertig: Je nach verwendetem Controller-Chip im USB-Stick ist es mit der Kompatibilität im Rechner-Bios zum Bootzeitpunkt nicht weit her. Das der Stick ansonsten problemlos funktioniert, hängt mit den erst später geladenen OS-Treibern zusammen.


Zurück zu „ESXi 4“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast