Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

SAS Tape-Library an ESX 3.5.0

Hilfe bei Problemen mit Installation & Benutzung des VMware ESX/ESXi Server 3.

Moderatoren: irix, continuum, Dayworker, Tschoergez

Member
Beiträge: 3
Registriert: 10.02.2014, 17:08

SAS Tape-Library an ESX 3.5.0

Beitragvon dleewen » 11.02.2014, 11:01

Hallo zusammen,
ich versuche schon seit Tagen einen "Tandberg StrorageLoader LTO 4" (Bandlaufwerk / Tape-Library) per SAS an eine virtuelle Maschine (Gastbetriebssystem: RedHat Enterprise Linux Server, 6.5) durchzureichen.
Die TapeLibrary wird als SCSI BlockDevice vom ESX-Kernel erkannt (und in der Liste der "Speicheradapter" aufgeführt).
Wenn ich jedoch die TapeLibrary als "Generic SCSI Device" zu meiner VM hinzufüge, so wird dieses nicht vom Gastbetriebssysteme der VM erkannt.
"lsscsi" (bzw. "cat /proc/scsi/scsi") listet mir nur die virtuelle Festplatte und das CD/DVD-ROM Laufwerk als vorhandene SCSI-Geräte auf. In den Kernel-Nachrichten vom Gastsystem ("dmesg") kann ich auch nichts verdächtiges feststellen.

Hat irgendjemand eine Idee, was hier falsch läuft!?

Beste Grüße
Daniel

Member
Beiträge: 339
Registriert: 12.04.2009, 20:21

Beitragvon JMcClane » 12.02.2014, 20:46

Nun, Tapes waren nie supportet in VMWare ESX. SCSI Geräte haben unter Umständen funktioniert. SAS aber auf dem Wege noch nie, und schon gar keine Library. Abgesehen davon würde die Performance unterirdisch sein.
Und PCI Geräte konnte der ESX3 noch nicht weiterreichen, also geht das damit auch nicht.
Das was du vorhast wird so nicht klappen.

Member
Beiträge: 3
Registriert: 10.02.2014, 17:08

Beitragvon dleewen » 13.02.2014, 12:43

Hallo,
erstmal: Vielen Dank für die schnelle Antwort.
Ich bin ein wenig erstaunt, das der Kram nicht funktionieren soll.
Der ESX-Kernel erkennt sowohl die Tape-Library ("Tape", als "vmhba2:0:0") als auch den Tapewechsel-Roboter ("Media changer", als "vmhba2:0:1").
Im Dateisystem des ESX-Hosts befinden sich auch die entsprechenden Einträge:
    * /vmfs/devices/genscsi/vmhba2:0:0:0
    * /vmfs/devices/genscsi/vmhba2:0:1:0


Wenn ich diese in meiner *.vmx Konfigurationsdatei Eintrage,
bekkome ich die Meldung "Unable to open SCSI device '/vmfs/devices/genscsi/vmhba2:0:0:0' (scsi0:4): Generic error."
Im Logfile der VM steht:

Code: Alles auswählen

[msg.scsi.esxpassthru.linuxDevOpenFailed] Unable to open SCSI device '/vmfs/devices/genscsi/vmhba2:0:0:0' (scsi0:4): Generic error.
vmx| [msg.vmxlsilogic.poweronFailed]
vmx| Failed to configure scsi0.


Meine *.vmx-Datei:

Code: Alles auswählen

# Tape Library
scsi0:4.present = "true"
scsi0:4.deviceType = "scsi-passthru"
scsi0:4.fileName = "/vmfs/devices/genscsi/vmhba2:0:0:0"
scsi0:4.allowGuestConnectionControl = "false"

# Tape Media-Changer
scsi0:5.present = "true"
scsi0:5.deviceType = "scsi-passthru"
scsi0:5.fileName = "/vmfs/devices/genscsi/vmhba2:0:1:0"
scsi0:5.allowGuestConnectionControl = "false"


Die Tape-Library wir ja schinbar erkannt, aber ein Zugriff ist trotzdem nicht Möglich!?
Warum?

Beste Grüße
Daniel

Member
Beiträge: 339
Registriert: 12.04.2009, 20:21

Beitragvon JMcClane » 13.02.2014, 12:45

Weil SCSI != SAS
Das Generic SCSI verbarbeitet keine SAS Geräte.

Member
Beiträge: 3
Registriert: 10.02.2014, 17:08

Beitragvon dleewen » 13.02.2014, 12:48

Aber der SAS-Controller im ESX-Host sollte doch von wie ein ganz normales SCSI-Gerät angesprochen werden können, oder nicht?

Member
Beiträge: 339
Registriert: 12.04.2009, 20:21

Beitragvon JMcClane » 13.02.2014, 12:55

Der ESX gibt das aber nicht an die VM weiter.
Dafür gibt es VMDirectPath I/O, um z.B. eine PCI Karte an eine VM weiterzureichen. Aber das wurde erst mit ESX4 eingeführt und unterstützt auch nicht sämtliche Karten und die CPU muss auch VT-d können.


Zurück zu „ESX 3 & ESXi 3“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste