Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

VMFS Data Recovery (rm * -rf)

Hilfe bei Problemen mit Installation & Benutzung des VMware ESX/ESXi Server 3.

Moderatoren: irix, continuum, Dayworker, Tschoergez

Member
Beiträge: 30
Registriert: 06.09.2007, 10:45

VMFS Data Recovery (rm * -rf)

Beitragvon reinilein » 11.03.2008, 19:23

Hallo zusammen,

es ist ein GAU. Ein vmfs wurde ziemlich wild mittels rm * -rf platt gemacht. Die Backups sind auch unbrauchbar... :shock:

Hat wer von Euch schon Erfahrungen mit dem Recovery auf vmfs gemacht bzw machen müssen? Wer kennt Dienstleister die sowas anbieten? Ist VmWare da eine Hilfe?

Benutzeravatar
Profi
Beiträge: 838
Registriert: 06.04.2006, 14:36
Wohnort: bei Mainz
Kontaktdaten:

Beitragvon Heros » 11.03.2008, 19:37

Das hört sich garnicht gut an! Ich hab keine Erfahrungen damit aber da bringt wohl nur ein Call bei VMware etwas. Würde mir aber keine große Hoffnungen machen das die das retten können!

Member
Beiträge: 35
Registriert: 05.03.2004, 07:42
Wohnort: Schorndorf

Beitragvon kugman » 12.03.2008, 10:11

nun, ich hatte mal ein ähnliches Problem. Bei der Installation eines zusätzlichen ESXes wurde der ESX-Server versehentlich ins SAN (vmfs) installiert. Recovery? Nada, Null, Nix.
Ich möchte nichts über den Punkt "wissen was man tut" sagen. Aber eines sag ich an dieser Stelle immer wieder.
Es ist absolut sinnlos nachts eine Datensicherung zu fahren, wenn man nicht vorher detailliert und exzessiv den Way-Back testet. Das schönste Backup taugt nichts, wenn man es nicht zurückspielen kann.
Also bitte für die Zukunft: Nicht nur das Backup testen sondern auch das Backup-Recovery.

brauchbare ESX-Backup-Lösungen gibts einige z.Bsp: esxPress - das setzen wir ein. Da ist der Way-Back absolut pillepalle-einfach. Jedes Backup ist executable und enthält alles, was benötigt wird um von einer Konsole aus wiederhergestellt werden zu können - notfalls auf nem VMWare Server oder ähnlichem...

also ich glaub auch nicht, dass man da noch was machen kann... vielleicht mit viel Glück. Und das wünsch ich Dir :-)

Member
Beiträge: 30
Registriert: 06.09.2007, 10:45

Beitragvon reinilein » 12.03.2008, 15:06

Hast schon recht kugman. Es wird hier durchaus mit professionellen Ansprüchen gearbeitet. Der Faktor "Mensch" spielt aber immer eine erhebliche Rolle. Und Menschen neigen manchmalzu Handlungen, die mit logischen Ansätzen nicht nachvollziehbar sind.

Ich bitte um keine weitere Diskusion über das Warum und Wieso, da ich mich in dieser Runde nicht aufklärend äußern kann.

Trotzdem Vielen Dank für Deine Glückwünsche! :grin:

Benutzeravatar
Profi
Beiträge: 838
Registriert: 06.04.2006, 14:36
Wohnort: bei Mainz
Kontaktdaten:

Beitragvon Heros » 12.03.2008, 23:07

Solltest du ein Ticket bei VMware aufmachen wäre es dennoch interessant zu hören was die Jungs sagen.

Member
Beiträge: 30
Registriert: 06.09.2007, 10:45

Beitragvon reinilein » 12.03.2008, 23:14

logisch.. :-)

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 12.03.2008, 23:47

Was war denn auf dem vmfs fuer ein Inhalt ?

Wenn es ZB nur um windows-vmdks ging - wuerde ich das filesystem in NTFS umdeklarieren und dann nach lost-files suchen ...

Member
Beiträge: 30
Registriert: 06.09.2007, 10:45

Beitragvon reinilein » 02.04.2008, 01:26

..aalso:

Das mit dem VmWare - Support hat sich hingezogen.. Der Snapshot ist mir dann schon vollgelaufen, dank Fragmentierung war dann da nix mehr zu machen... Der Einfall, den Snapshot per dd auf eine Platte zu Spiegeln, ist mir zu spät gekommen. :roll:

Aber:

Ich habe den Tipp von continuum "gefressen" und mir den Snapshot in eine Windows - Maschine gemappt. Dann bin ich mit R-Tools http://www.data-recovery-software.net/ drauf losgegangen. Und erfreulicher Weise konnte ich alles Wichtige von dieser einen VM retten!

DANKE CONTNUUM! DU BIST EIN HELD!! :grin:

Ach ja: Mit Ontrack habe ich telefoniert, die haben mir ein Angebot geschickt und hätten den Job auf die gleiche Weise erledigt. Kosten BIS ZU 20k€....

Member
Beiträge: 5
Registriert: 12.07.2009, 15:37

Beitragvon test.it » 12.07.2009, 15:44

Hallo Zielgruppe,

mir ist das gleiche Malör passiert, deshalb an dieser Stelle mal eine Nachfrage:
Was meint Ihr mit "das filesystem in NTFS umdeklarieren " & "den Snapshot in eine Windows - Maschine gemappt"?

Gruß
test.it

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 12.07.2009, 15:55

Hallo Zielgruppe,
- hallo Einzelperson 8)
Du machst per dd ein image deiner VMFS partition und kopierst diese dd-image auf einen Windows-rechner - danach gibt es dann mehrere Wege ...

ruf doch mal eben an - das geht schneller

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 12.07.2009, 17:28

... ist wohl nicht so wichtig 8)

Member
Beiträge: 5
Registriert: 12.07.2009, 15:37

Beitragvon test.it » 12.07.2009, 19:25

:)

Nee, is mir schon wichtig, aber die "Hausgemeinschaft" verlangte nach Betreuung, sprich ich war nicht mehr online! :oops:
Würde es jetzt noch passen?

Gruß & Dank
test.it

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 12.07.2009, 20:27

yep

Member
Beiträge: 30
Registriert: 06.09.2007, 10:45

Beitragvon reinilein » 12.07.2009, 23:41

ich drück euch die Daumen!

Member
Beiträge: 48
Registriert: 04.07.2009, 21:59

Beitragvon ollfried » 14.07.2009, 21:23

Hoi,
Was ist denn mit vmfs-undelete? Ich hab das noch nie benutzt, aber nach einem einfachem rm* sollte das doch gehen, oder? (Übrigens gibts das nicht mehr für das neue VMFS von vSphere4) Oder haben die ESXe fleißig weiter auf die LUN geschrieben?

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 14.07.2009, 23:09

vmfs-undelete wuerde hier nicht helfen.

Von dem VMFS-volume das auf einem iSCSI-SAN liegt sind die ersten 4 Gb quasi geschreddert - d.h alle vmfs-metadaten sind weg

Member
Beiträge: 5
Registriert: 12.07.2009, 15:37

Beitragvon test.it » 14.07.2009, 23:50

sind die ersten 4 Gb quasi geschreddert

:oops:
Gut gemerkt, leider!

In einem sektorbasierten Image sind zwar einige "lost" files zu finden aber die VMDK's sind wech :cry:
Aber selbst Schuld!

Gruß
test.it

Member
Beiträge: 13
Registriert: 10.09.2009, 22:38

Bitte um Hilfe Continuum!

Beitragvon Katta » 10.09.2009, 22:42

Hallo!

Ich habe folgendes Problem und denke es passt in diesen Kontext - ich hoffe es ordentlich zu beschreiben ;)

Ausgangsituation: Single ESXhost & local Storage only(! im RAID1-Verbund jeweils 2x250GB + 2x500GB) - Stand ESX 3.5 Update 3 (123630) - auch Vcenter im Einsatz - Plan mit Update Manager akt. Patches einzuspielen - startet gut, bei 41% verliert Vcenter "Kontakt" (Reboot wahrscheinlich) - anschließend Chaos: Vcenter kann zwar den Host wieder finden, alle VMs (disconnected) - man denkt nichts böses, disconnected & connect ESXhost -> keine Änderung, bis auf die Meldung "Add Storage ..." :shock:

Fakt & IST-Stand: die Partitionen sind da, ESXhost kann sie anscheinend(?) nicht mehr mounten (also IDs, symbolic links), ein ls drauf sagt "..no files or not a directory..."

Nach einer fast durchgemachten Nacht (vmkfstools -V z.B., etc.) läuft derzeit ein dd :)

Ich hoffe Du wirst mehr jetzt sagen - es besteht noch Hoffnung :? , nachdem letzte Woche der Backup-Server verstorben ist und ich nicht dazu gekommen bin :roll:

Was soll ich sagen die Woche war busy, daher auch wichtige Daten drauf :oops:

Vielen Dank im Voraus! :-)

Stefan.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 11.09.2009, 00:39

Hmmm ... schwierig zu sagen aus der ferne ...

Hast du schon mal ein Rescan probiert - Stichwort: Enable.Resignature = 1

Ich wuerde mir das dd-image nehmen und es als zweite Platte in eine ESX oder ESXi VM unter Workstation einbinden - dann musst du evtl noch Enable.Resignature = 1 setzen - vielleicht sieht der was

Falls das nicht moeglich ist - versuch den Server mit einer LinuxLiveCD mit Java-support zu booten - evtl findet der Fvmfs-treiber was nuetzliches

Member
Beiträge: 13
Registriert: 10.09.2009, 22:38

Wiederherstellungsversuch

Beitragvon Katta » 11.09.2009, 09:48

DANKE für deine Unterstützung & rasche Antwort! :)

continuum hat geschrieben:Hmmm ... schwierig zu sagen aus der ferne ...

Hast du schon mal ein Rescan probiert - Stichwort: Enable.Resignature = 1


Ja (gesetzt/gescannt/weg genommen/gescannt) - in Verbindung mit dem vmkfstools - leider erfolglos :(

continuum hat geschrieben:Ich wuerde mir das dd-image nehmen und es als zweite Platte in eine ESX oder ESXi VM unter Workstation einbinden - dann musst du evtl noch Enable.Resignature = 1 setzen - vielleicht sieht der was


Werde ich machen ;)

continuum hat geschrieben: Falls das nicht moeglich ist - versuch den Server mit einer LinuxLiveCD mit Java-support zu booten - evtl findet der Fvmfs-treiber was nuetzliches


Mit welcher LiveDistro hast Du gute Erfahrungen gemacht?

Ich werde auch folgendes Probieren: Das neu Aufsetzen von ESX 3.5 U3, und bette das er dann was findet -> hab 2 vmfs-Partitions eine davon mit ESXhost-Partitions auf dem 250GB-Verbund, da "kübel" ich alles und hoffe er erkennt dann was im 500er Verbund(?)

FYI:
Vielleicht nicht uninteressant und schon wieder vergessen:
Vor knapp 14 Tagen ist mir der adaptec3805 inkl. BatteryPack ;) abgeraucht; Baugleiches Gerät rein (niedrigere BIOS-Ver. als ursprünglicher Adapter) -> gestartet, keinerlei, offensichtliche Fehler.
Zur Wiederholung: während des Updates - futsch und weg, die vmfs Partitionen seitens Zugriff.


Halte Dich/euch auf dem Laufenden & bedanke mich schon jetzt für dein/euer Feedback - sollte Lösung gefunden sein/werden, werd ich sie natürlich auch so gut als möglich hier dokumentieren ;)

--- AKTUALISIERUNG:
Folgendes ist mir nun aufgefallen:
(durch das hin & her KVM-Switch - manchmal dann auch ein zu ungenaues Nachsehen in den LOGs, Services - noch immer in anhaltender Panikattacke & übermüdet ;) )

Folgende Daemons/Services starten nicht ordentlich beim Booten:
Firewall
IPMI
vmware-late
- manuell, nachträglich ausgeführt gibt es keine Fehlermeldung retour (startet sauber);
--> war nur einmal der Fall ;) - jetzt findet er bei vmware-late kein binary-file mehr zum Ausführen.

Hab auch folgendes miteinbezogen VMware KB Article: 1002168 (Suche nach KB 10002168 - vielleicht hilft es wem?) - hat mir meine vmfs-Partition auf 250GB zerschossen :) -> macht Neuinstallation ja auch - hoffe auf verwertbare Daten auf der vmfs-Partition auf den 500ertern.

Schaut nicht gut aus -> gehe jetzt zu Neuaufsetzen über -> mir läuft die Zeit davon

Member
Beiträge: 13
Registriert: 10.09.2009, 22:38

vielleicht mach ich nur was falsch

Beitragvon Katta » 12.09.2009, 17:31

Hallo!

Hab mich mal kurz meinem Image der 500er Partition gewidmet und per
fdisk -u -l /Path-To-Imagefile/Imagefile ...folgende Ausgabe erhalten:

Disk /BACKUP/storage2.img: 0 MB, 0 bytes
255 heads, 63 sectors/track, 0 cylinders, total 0 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x00000000

Disk /BACKUP/storage2.img doesn't contain a valid partition table

Schaut damit wertlos für mich aus, oder gibt es noch Optionen - etwa beim Erstellen des Imagefiles per dd die ich übersehen habe?

Freue mich über Rückmeldungen :) - Danke!

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 13.09.2009, 03:55

Kennst du "testdisk" ? - probier das mal

ansonsten was sagt der Fvmfs treiber ?

Member
Beiträge: 13
Registriert: 10.09.2009, 22:38

Never give up :-)

Beitragvon Katta » 13.09.2009, 11:33

continuum hat geschrieben:Kennst du "testdisk" ? - probier das mal

ansonsten was sagt der Fvmfs treiber ?


Katta hat geschrieben: Testdisk sagt mir ad-hoc mal nichts (?).

Jetzt schon - sollte Testdisk von http://www.cgsecurity.org/wiki/TestDisk sein. :) - ist inkludiert auf der http://www.sysresccd.org/Main_Page ;)

Das mit dem FVMFS-Treiber hab ich noch nicht so ganz durchblickt - bin ja auch in anderen Foren über deine Beiträge gestoßen und auch schon selbst Mal über dein (gerade draufgekommen :lol:) MOA-Projekt.

Irgendwie hab ich aber hierzu die Zusammenhänge noch nicht ganz kapiert - übermüdet(?) - darum erlaube mir folgende Frage betr. meines Verständnisses:

Ziel wäre es meinen ESXhost über ein LiveLinuxISO zu starten, das den FVMFS Treiber von (sanbarrow.com?) inkludiert um damit dann die "tote Partition" per mount -t fvmfs ... (wahrscheinlich?) zu mounten & hoffentlich darauf Daten zu finden. - Richtig?

Wenn die Antwort ja ist - gibt es schon eine fertige BootDistro (ISO) die das bietet?

Da ist die MOA-Seite für mich nämlich ein wenig erschlagend, wie gesagt ich Blick da noch nicht ganz durch im Moment :roll:

Da für mich im Moment alles dringend ist - sprich ich parallel, mehrere Server aufsetzen muss - rechne ja mit kompletten Datenverlust - bitte ich um dein Verständnis, das meine Hoffnung immer noch da ist - meine Fragen ein wenig fordernd sind. - Danke!

Freue mich schon auf dein Feedback. - Vielen Dank - Ulli!

Member
Beiträge: 13
Registriert: 10.09.2009, 22:38

Erfolglos & irritierend

Beitragvon Katta » 13.09.2009, 23:12

So hab nun von http://code.google.com/p/vmfs/ den fvmfs-Treiber geladen und gegen meine 500er mit folgender Befehlsfolge unter Knoppix 5.3.1 angewandt:

Code: Alles auswählen

root@Knoppix:/ramdisk/home/knoppix/fvmfs_r81_dist/vmfs_r81# java -jar fvmfs.jar /dev/sdb webdav
VMFSTools (C) by fluid Operations (v0.9.8.14 r81 / 2009-03-27_21-26-53)
http://www.fluidops.com

java.lang.Exception: No VMware File System detected
   at com.fluidops.tools.vmfs.VMFSDriver.readVmfsInfo(VMFSDriver.java:521)
   at com.fluidops.tools.vmfs.VMFSDriver.openVmfs(VMFSDriver.java:777)
   at com.fluidops.tools.vmfs.VMFSTools.cli(VMFSTools.java:165)
   at com.fluidops.tools.vmfs.VMFSTools.main(VMFSTools.java:355)
   at java.lang.reflect.Method.invoke0(Method.java)
   at java.lang.reflect.Method.invoke(Method.java:525)
   at org.kaffe.jar.ExecJarName.main(ExecJarName.java:64)
   at org.kaffe.jar.ExecJar.main(ExecJar.java:57)
root@Knoppix:/ramdisk/home/knoppix/fvmfs_r81_dist/vmfs_r81# java -jar fvmfs.jar /dev/sdb1 webdav
VMFSTools (C) by fluid Operations (v0.9.8.14 r81 / 2009-03-27_21-26-53)
http://www.fluidops.com

java.lang.Exception: No VMware File System detected
   at com.fluidops.tools.vmfs.VMFSDriver.readVmfsInfo(VMFSDriver.java:521)
   at com.fluidops.tools.vmfs.VMFSDriver.openVmfs(VMFSDriver.java:777)
   at com.fluidops.tools.vmfs.VMFSTools.cli(VMFSTools.java:165)
   at com.fluidops.tools.vmfs.VMFSTools.main(VMFSTools.java:355)
   at java.lang.reflect.Method.invoke0(Method.java)
   at java.lang.reflect.Method.invoke(Method.java:525)
   at org.kaffe.jar.ExecJarName.main(ExecJarName.java:64)
   at org.kaffe.jar.ExecJar.main(ExecJar.java:57)


Nicht schön - irritierend nun ist aber wenn ich gleiches gegen meinen 250er-Verbund laufen lasse, auf dem es bereits wieder eine funktionierende ESX-Installation gibt inkl. lokalem Storage & VMs:

Code: Alles auswählen

root@Knoppix:/ramdisk/home/knoppix/fvmfs_r81_dist/vmfs_r81# fdisk -l

Platte /dev/sda: 249.8 GByte, 249865175040 Byte
255 Köpfe, 63 Sektoren/Spuren, 30377 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x00000000

    Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14         650     5116702+  83  Linux
/dev/sda3             651       30041   236083207+  fb  Unbekannt
/dev/sda4           30042       30377     2698920    f  W95 Erw. (LBA)
/dev/sda5           30042       30110      554211   82  Linux Swap / Solaris
/dev/sda6           30111       30364     2040223+  83  Linux
/dev/sda7           30365       30377      104391   fc  Unbekannt

Platte /dev/sdb: 499.2 GByte, 499279462400 Byte
255 Köpfe, 63 Sektoren/Spuren, 60700 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x55555555

    Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sdb1   *           1       60701   487580718+  fb  Unbekannt
root@Knoppix:/ramdisk/home/knoppix/fvmfs_r81_dist/vmfs_r81# java -jar fvmfs.jar /dev/sda3 webdav
VMFSTools (C) by fluid Operations (v0.9.8.14 r81 / 2009-03-27_21-26-53)
http://www.fluidops.com

java.lang.Exception: VMFS records not found
   at com.fluidops.tools.vmfs.VMFSDriver.readVmfsInfo(VMFSDriver.java:566)
   at com.fluidops.tools.vmfs.VMFSDriver.openVmfs(VMFSDriver.java:777)
   at com.fluidops.tools.vmfs.VMFSTools.cli(VMFSTools.java:165)
   at com.fluidops.tools.vmfs.VMFSTools.main(VMFSTools.java:355)
   at java.lang.reflect.Method.invoke0(Method.java)
   at java.lang.reflect.Method.invoke(Method.java:525)
   at org.kaffe.jar.ExecJarName.main(ExecJarName.java:64)
   at org.kaffe.jar.ExecJar.main(ExecJar.java:57)


Ist da schon Erfahrung da? - mich beunruhigt "java.lang.Exception: VMFS records not found"?

Für jeglichen weiteren Input schon im Voraus vielen Dank!!!

Continuum, welche Tests hättest Du jetzt noch mit Testdisk gegen /dev/sdb gefahren?

LG.,
Stefan

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 13.09.2009, 23:22

Hi
in der Tat etwas verwirrend deine Ergebnisse.

Zur Zeit sehe ich den Fvmfs Treiber etwas zwie-spaeltig. Ich hatte selber bei einigen funktionierenden ESX-installationen keinen Erfolg bei der Anwendung des Treibers.

Ich sehe ihn daher auch nicht als verlaessliches Analysetool - sondern eher als ein Mittel der Verzweiflung. So nach dem Motto - wenn nichts sonst mehr geht probier Fvmfs.

Bin etwas ratlos in diesem Fall - wenn es geht - konsultier den VMware-support :cry:

Ulli


Zurück zu „ESX 3 & ESXi 3“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste