Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

VMware Player startet nicht nach Installation

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 4
Registriert: 14.12.2006, 00:18

VMware Player startet nicht nach Installation

Beitragvon luckyduke » 14.12.2006, 01:21

Guten, hab gerade mein VMPlayer installiert. Installation war easy. fehler hab ich auch keine gemacht. Programm lässt sich ausführen. Beim Programm start produziert er jedoch fehler im terminal. Lediglich die Enduser agreement wird angezeigt, dann bleibts stehen.
Folgende Fehler sind dann in der console:

/usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)

(vmplayer:8019): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:8019): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:8019): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:8019): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:8019): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:8019): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

Wäre cool wenn mir da jemand weiter helfen könnte :)

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 14.12.2006, 01:37

Code: Alles auswählen

vmware-config.pl


Dann "q" eintippen.

Hast du das gemacht? Wenn nein, dann war es zu easy.

Member
Beiträge: 4
Registriert: 14.12.2006, 00:18

Jab

Beitragvon luckyduke » 14.12.2006, 02:00

Fragt der ja während der Installation ob ich das machen will. Hab ich auch gemacht. Sogar die Korrekten header Dateien für meinen Kernel angegeben. der Installiert auch erfolgreich

Member
Beiträge: 4
Registriert: 14.12.2006, 00:18

Beitragvon luckyduke » 14.12.2006, 02:08

Starting VMware services:
Virtual machine monitor done
Virtual ethernet done
Bridged networking on /dev/vmnet0 done
Host-only networking on /dev/vmnet8 (background) done
NAT service on /dev/vmnet8 done

The configuration of VMware Player 1.0.3 build-34682 for Linux for this running
kernel completed successfully.

You can now run VMware Player by invoking the following command:
"/usr/bin/vmplayer".

Enjoy,

--the VMware team

abba

Member
Beiträge: 4
Registriert: 14.12.2006, 00:18

Beitragvon luckyduke » 14.12.2006, 02:08

Starting VMware services:
Virtual machine monitor done
Virtual ethernet done
Bridged networking on /dev/vmnet0 done
Host-only networking on /dev/vmnet8 (background) done
NAT service on /dev/vmnet8 done

The configuration of VMware Player 1.0.3 build-34682 for Linux for this running
kernel completed successfully.

You can now run VMware Player by invoking the following command:
"/usr/bin/vmplayer".

Enjoy,

--the VMware team

abba geht trotzdem net

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 14.12.2006, 17:32

Dann schreibe mal alles zu Hard und Software auf, vor allem die Distribution.

Member
Beiträge: 3
Registriert: 14.12.2006, 21:50

Könnte das gleiche Problem sein

Beitragvon thomasthd » 14.12.2006, 22:50

Hallo erst mal an alle,
ich denke ich bin auf das gleiche Problem wie schon luckyduke gestoßen.

Erst mal etwas zu meinem System:
uname -a: Linux 2.6.18.2-34-default #1 SMP Mon Nov 27 11:46:27 UTC 2006 i686 athlon i386 GNU/Linux

Die Distro ist openSuse 10.2.

VMPlayer Version: 1.0.3 build-34685

Hardware ist bei beiden Rechner fast identisch (warum auf beiden, da komme ich gleich noch zu),
AMD64 3200+/4400+X2 1/2 GB RAM Asus Board's.

Auf dem einen Rechner mit x11-video-nvidia:xgl:compiz:KDE, startet der vmplayer bis auf diese Meldung ganz normal:

Code: Alles auswählen

./vmplayer
/usr/local/lib/vmware/bin/vmplayer: /usr/local/lib/vmware/lib/libpng12.so.0/libp
ng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)


Auf dem anderen Rechner ist x11-video-nvidia:xgl:compiz:Gnome drauf. Da sieht die Sache schon etwas anders aus:

Code: Alles auswählen

 ./vmplayer
/usr/local/lib/vmware/bin/vmplayer: /usr/local/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_ref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_ref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_get_file_info_uri_cancellable: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_ref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri != NULL' failed
(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_ref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_get_file_info_uri_cancellable: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_ref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_ref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_get_file_info_uri_cancellable: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_to_string: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_to_string: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-CRITICAL **: gnome_vfs_uri_to_string: assertion `uri != NULL' failed

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1
: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))

(vmplayer:16702): libgnomevfs-WARNING **: Cannot load module `/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/local/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))


Die GUI zeigt dann noch zwei Fenster mit dieser Meldung:

Code: Alles auswählen

Der Ordnerinhalt konnte nicht angezeigt werden
VFS error: Ungültige Parameter

und

Code: Alles auswählen

Es konnten keine Informationen zu dieser Datei abgerufen werden
VFS error: Ungültige Parameter


Der Dateibrowser kann dann nicht auf das Dateisystem zugreifen, also kann man keine VM auswählen.

Wenn man auf der Gnome Kiste den vmplayer mit ./vmplayer /pfad/zur/VM.vmx aufruft, startet die VM ganz normal. Nur diese Meldung gibt die Konsole zurück:


Code: Alles auswählen

/usr/local/lib/vmware/bin/vmplayer: /usr/local/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".


Hoffe diese Infos reichen euch zur einer Fehleranalyse und/oder Lösung.

Wenn ihr mehr braucht sagt Bescheid.

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 15.12.2006, 08:13

Ich hatte bei Qemu Probleme mit compiz/xgl. Es half, vorher folgenden Befehl einzuklimpern:

Code: Alles auswählen

export XLIB_SKIP_ARGB_VISUALS=1


Falls nicht: Wenn du auf der Gnome-Kiste den 3d-Desktop abschaltest, geht es dann?

Member
Beiträge: 3
Registriert: 14.12.2006, 21:50

Beitragvon thomasthd » 15.12.2006, 11:27

Habe den Export gemacht, leider keine Besserung.

Auch das Abschalten der 3D Effekte hatte keinen Effekt auf die/den Fehler.

Member
Beiträge: 3
Registriert: 14.12.2006, 21:50

Habe eine Lösung

Beitragvon thomasthd » 15.12.2006, 12:35

In diesem Thread habe ich eine Lösung gefunden.

Habe mich dabei an diesen Eintrag von "activewire" gehalten:

Here is a workaround for Workstation 5.5.3 on OpenSUSE10.2:

cd /opt/vmware/lib/vmware/lib/libpng12.so.0
mv libpng12.so.0 libpng12.so.0.old
ln -sf /usr/lib/libpng12.so.0 libpng12.so.0

cd /opt/vmware/lib/vmware/lib/libgcc_s.so.1
mv libgcc_s.so.1 libgcc_s.so.1.old
ln -sf /lib/libgcc_s.so.1


Die Pfade habe ich natürlich an meine Installation angepasst und einen kleinen Fehler in den Anweisungen von "activewire" verbessert (siehe roten Text):

cd /opt/vmware/lib/vmware/lib/libpng12.so.0
mv libpng12.so.0 libpng12.so.0.old
ln -sf /usr/lib/libpng12.so.0 libpng12.so.0

cd /opt/vmware/lib/vmware/lib/libgcc_s.so.1
mv libgcc_s.so.1 libgcc_s.so.1.old
ln -sf /lib/libgcc_s.so.1libgcc_s.so.1

Jetzt läuft der Vmplayer.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast