Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

serial port und paralell port funktioniert nicht

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 48
Registriert: 05.11.2006, 22:50

serial port und paralell port funktioniert nicht

Beitragvon lino16 » 05.11.2006, 22:58

Hallo,

es kommen folgende Fehlermeldungen. Was kann ich tun um das Problem zu lösen?

Code: Alles auswählen

serial0: Unable to open the "COM1" serial port: No such file or directory.

Failed to connect virtual device serial0.

Code: Alles auswählen

Cannot open LPT1: No such file or directory
Failed to connect virtual device parallel0.


Vielen Dank schon im Voraus.

Gruß Lino16

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 05.11.2006, 23:01

Genaue Infos!

Host, Gast, vmx-Datei.

Member
Beiträge: 48
Registriert: 05.11.2006, 22:50

Beitragvon lino16 » 05.11.2006, 23:12

Host: Ubuntu 6.10 AMD64
Gast: Windows XP Home

Code: Alles auswählen

#!/usr/bin/vmplayer

# Filename: Windows_XP_Home.vmx
# Generated 2006-11-05;11:07:57 by EasyVMX!
# http://www.easyvmx.com

# This is a Workstation 5 or 5.5 config file
# It can be used with Player
config.version = "8"
virtualHW.version = "4"

# Selected operating system for your virtual machine
guestOS = "winxphome"

# displayName is your own name for the virtual machine
displayName = "Windows_XP_Home"

# These fields are free text description fields
guestinfo.vmware.product.url = "http://www.easyvmx.com/"
guestinfo.vmware.product.class = "virtual machine"

# Number of virtual CPUs. Your virtual machine will not
# work if this number is higher than the number of your physical CPUs
numvcpus = "1"

# Memory size and other memory settings
memsize = "320"
MemAllowAutoScaleDown = "FALSE"
MemTrimRate = "-1"

# Unique ID for the virtual machine will be created
uuid.action = "create"

# Remind to install VMware Tools
# This setting has no effect in VMware Player
tools.remindInstall = "TRUE"

# Startup hints interfers with automatic startup of a virtual machine
# This setting has no effect in VMware Player
hints.hideAll = "TRUE"

# Enable time synchronization between computer
# and virtual machine
tools.syncTime = "TRUE"

# USB settings
# This config activates USB
usb.present = "TRUE"
usb.generic.autoconnect = "FALSE"

# First serial port, physical COM1 is available
serial0.present = "TRUE"
serial0.fileName = "COM1"
serial0.hardwareFlowControl = "TRUE"

# Optional second serial port, physical COM2 is not available
serial1.present = "FALSE"

# First parallell port, physical LPT1 is available
parallel0.present = "TRUE"
parallel0.fileName = "LPT1"
parallel0.bidirectional = "TRUE"

# Sound settings
sound.present = "TRUE"
sound.virtualdev = "es1371"

# Logging
# This config activates logging, and keeps last log
logging = "TRUE"
log.fileName = "Windows_XP_Home.log"
log.append = "TRUE"
log.keepOld = "1"

# These settings decides interaction between your
# computer and the virtual machine
isolation.tools.hgfs.disable = "FALSE"
isolation.tools.dnd.disable = "FALSE"
isolation.tools.copy.enable = "TRUE"
isolation.tools.paste.enabled = "TRUE"

# First network interface card
ethernet0.present = "TRUE"
ethernet0.virtualDev = "e1000"
ethernet0.connectionType = "bridged"
ethernet0.addressType = "generated"
ethernet0.generatedAddressOffset = "0"

# Settings for physical floppy drive
floppy0.present = "FALSE"

# Settings for physical CDROM drive
ide1:0.present = "TRUE"
ide1:0.deviceType = "cdrom-raw"
ide1:0.startConnected = "TRUE"
ide1:0.fileName = "auto detect"
ide1:0.autodetect = "TRUE"

# First IDE disk, size 10Gb
ide0:0.present = "TRUE"
ide0:0.fileName = "Windows_XP_Home.vmdk"
ide0:0.mode = "persistent"
ide0:0.startConnected = "TRUE"
ide0:0.writeThrough = "TRUE"

# END OF EasyVMX! CONFIG

ide0:0.redo = ""
ethernet0.generatedAddress = "00:0c:29:07:6d:ae"
uuid.location = "56 4d 23 23 0e eb 18 85-5f b5 41 4f 7a 07 6d ae"
uuid.bios = "56 4d 23 23 0e eb 18 85-5f b5 41 4f 7a 07 6d ae"
checkpoint.vmState = ""

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 05.11.2006, 23:39

Wen wunderts. Du hast Windows Devicenamen in der vmx-Datei.

Seriell: /dev/ttyS0
Parallel: /dev/lp0 (oder /dev/parport0)

Com1 und lpt1 gehen natürlich nicht.

Member
Beiträge: 48
Registriert: 05.11.2006, 22:50

Beitragvon lino16 » 06.11.2006, 00:04

danke für die schnelle Hilfe.

der Seriel Port funktioniert jetzt..

aber der Paralell Port zeigt folgendes an:

Code: Alles auswählen

Cannot open /dev/parport0: No such file or directory
Failed to connect virtual device parallel0.


ich habe sowohl lp0 als auch parport0 versucht.
Obwohl ich aktuell /dev/lp0 eingestellt habe kommt obige Fehlermeldung.

Jetzt wird auf einmal die Soundkarte nicht mehr erkannt. Was ist da passiert?

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 06.11.2006, 07:35

Sound: Vermutlich ein Ressourcenkonflikt im Gast. Versuch mal im Gerätemanager des Gastes die EInstellungen manuell zu ändern. Alternativ in die vmx-Datei "sb16" statt "es1371" eintragen.

Zum Parallelport: Ist das eventuell im Bios des Hosts nicht korrekt eingetragen? Oder ist der Kernel ohne Support für den Parallelport übersetzt? Alternativ einfach mal "modprobe -k lp" bzw. "modprobe -k parport" als root vor dem Start von VMWARE eingeben.

Zuletzt noch eine Bemerkung: Ich würde mir mal den VMWARE Server installieren. Dann kannst du die Einstellungen per GUI wählen statt im Editor zu ändern.

Lizenz ist gleich (kostenlos, aber nicht frei im GPL-Sinn).

Member
Beiträge: 48
Registriert: 05.11.2006, 22:50

Beitragvon lino16 » 06.11.2006, 10:13

der Sound war ein Ressourcenkonflikt. War mit einen Neustart vom Host behoben.

benutze Ubuntu und der Drucker funktioniert damit tadellos.
Das würde doch heißen das im BIOS und Kernel alles ok ist, oder?

Habe trotzdem testweise mal das mit modprobe versucht.
Hilft aber leider nicht.

Gruß Lino16

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 06.11.2006, 19:20

Was sagt den "lsmod | grep lp" bzw. "lsmod | grep parport"?

BTW: Habe mich vertan, das Modul heisst "parport_pc". Versuch also mal "modprobe -k parport_pc". Und dann die Infos posten.

Member
Beiträge: 48
Registriert: 05.11.2006, 22:50

Beitragvon lino16 » 06.11.2006, 22:04

lino@lino-desktop:~$ modprobe -k parport_pc
lino@lino-desktop:~$ lsmod|grep parport
parport_pc 43560 1
parport 49932 2 lp,parport_pc

funktioniert leider immernoch nicht... selbe fehlermeldung.

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 06.11.2006, 22:40

Wird der Parallelport denn vom Druckdienst gebraucht? Wenn ja, muss der ansonsten gestoppt werden.

Außerdem könnte es ein Rechteproblem sein (chmod +w /dev/lp0 (parport0))

Aber:

Bevor du zu viel Zeit investierst: Wofür brauchst du den Parallel Port im Gast? Wenn es für den Drucker ist: Richte dir einfach im Gast einen Netzwerkdrucker ein.

Die Netzwerklösung ist stressfrei.

Siehe auch:

http://www.linuxforen.de/forums/showthr ... adid=47553

Member
Beiträge: 48
Registriert: 05.11.2006, 22:50

Beitragvon lino16 » 07.11.2006, 16:31

danke...

Drucken übers Netzwerk funktioniert jetzt

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 07.11.2006, 19:40

Freut mich! Die Netzwerklösungen sind eh besser, weil der parallele Zugriff zweier Betriebssysteme auf die gleiche Ressource immer problematisch ist.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 1 Gast