Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

USB-Dilemma

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 13
Registriert: 02.08.2006, 16:53

USB-Dilemma

Beitragvon Claudio » 03.11.2006, 11:31

halli hallo liebes forum

ich habe folgendes problem:
host winXP SP2 standalone (USB2 Pentium D3.2GHz 2048MB RAM)
guest: winXP SP2 in domäne

nun habe ich das problem dass im guest die usb sticks zum teil nicht erkannt werden. manchmal reicht auch ein neustart der ganzen maschin und dann werden die usb sticks erkannt. nun habe ich im logfile folgendes gefunden (kurz nachdem der stick sich mit dauerleuchten verabschiedet hat)

Nov 02 17:03:54: vmx| USBGW: Submit IO failed (0xe000100a)
Nov 02 17:03:54: vcpu-0| USBG warning: failed to abort pipe usbioerr 'DEVICE_NOT_PRESENT'
Nov 02 17:03:54: vcpu-0| USBG warning: failed to abort pipe usbioerr 'DEVICE_NOT_PRESENT'
Nov 02 17:03:54: vcpu-0| C:/ob/bora-19317/bora/devices/usb/usbGenericWin32.c:480 vmusb get desc st e000100a
Nov 02 17:03:54: vmx| Try to find endpoint addr 0
Nov 02 17:03:54: vcpu-0| C:/ob/bora-19317/bora/devices/usb/usbGenericWin32.c:480 vmusb get desc st e000100a
Nov 02 17:03:54: vmx| SCSI PASS-THRU (scsi0:0): requested 8 returned 4
Nov 02 17:03:54: vmx| SCSI PASSTHRU: Successful operation w/ non-zero residual 4
Nov 02 17:03:54: vmx| SCSI PASS-THRU (scsi0:0): requested 8 returned 0
Nov 02 17:03:54: vmx| SCSI PASS-THRU (scsi0:0): requested 8 returned 0
Nov 02 17:03:55: vmx| Try to find endpoint addr 0
Nov 02 17:03:55: vcpu-0| C:/ob/bora-19317/bora/devices/usb/usbGenericWin32.c:480 vmusb get desc st e000100a
Nov 02 17:03:55: vmx| SCSI PASS-THRU (scsi0:0): requested 8 returned 4
Nov 02 17:03:55: vmx| SCSI PASSTHRU: Successful operation w/ non-zero residual 4
Nov 02 17:03:55: vmx| Try to find endpoint addr 0
Nov 02 17:03:55: usbEnum| USB: Disconnecting device 0xe400000610438012
Nov 02 17:03:55: vmx| USB: Found device [name:Realtek\ Semiconductor\ USB\ device vid:0bda pid:0111 path:1/4/5 autoclean:1]
Nov 02 17:03:55: vmx| VMXVmdbLoadUsbDevices: New set of 1 USB devices

der usb stick bleibt unsichtbar. hat jemand ne idee?

cheers
Dateianhänge
1LOG FILE A14 usb nichrt erkannt schule stick.txt
(72.91 KiB) 4-mal heruntergeladen

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 05.11.2006, 17:07

Gibt die Laufwerke am Host frei und nutze im Gast die Shared Folders oder die Netzwerkumgebung.

USB Krempel ist zumeist problematisch in der VM bei Direktzugriff.

Member
Beiträge: 23
Registriert: 18.05.2006, 15:23

Beitragvon feuerstein » 08.11.2006, 10:50

Hallo,

ich habe die Erfahrung gemacht, dass man beim USB-Zugriff auf die Rechte achten muss, die der am Host angemeldete Benutzer besitzt. Bei meinem USB-Problem hatte sich folgende Lösung angeboten: im Host den User in die Gruppe der VMware-User verschieben und diese Gruppe in die Gruppe der Administratoren verschieben. Solltest du nur den Admin als einzigen User auf deinem Rechner haben und keine eingeschränkten User, mit denen du arbeitest, macht diese Vorgehensweise natürlich wenig Sinn.

Gruß

feuerstein

PS: Feedback wäre nett

Member
Beiträge: 13
Registriert: 02.08.2006, 16:53

Beitragvon Claudio » 08.11.2006, 17:56

hallo

der user auf dem host ist admin und in der gruppe vmware zugeordnet. die user im guest os haben lokale admin rechte. es sollte also kein rechte problem vorliegen.
ich habe auch schon versucht im bios den usb port auf fillspeed zurückzustufen, dies hat aber auch nichts gebracht.

die lösung mit den freigaben funktioniert nur wenn der usb stick schon vor dem start der vm eingesteckt ist und das ist leider nicht der fall, der usb stick wird wie beim normalen betrieb erst später eingesteckt.

cheers

Benutzeravatar
Moderator
Beiträge: 14645
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 08.11.2006, 18:45

Hi
kannst du nicht erst einmal mit nur einem USB-geraet probieren ?

Warum nimmst du direkt 2 ?

Hast du schon mal probiert ob dein custom nic-bios eine Rolle spielt?
Was willst du eigentlich mit dem SCSI-passtyhru erreichen ?????

Member
Beiträge: 13
Registriert: 02.08.2006, 16:53

Beitragvon Claudio » 09.11.2006, 08:41

hallo

ich habe nur ein usb stick angeschlossen.
wobei, es könnte seind dass der interne card reader, welcher zwar nicht an vmware weitergeleitet wird per usb angeschlossen ist.

ich werde das custom nic-bios mal durch ein standard vm bios ersetzen und schauen was das bringt.
der scsi-passthrough ist ein fehler von mir in der vmx-datei. ich werd den auch mal abschalten.

vielen dank für die hilfe


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste