Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Drucker am 1.Parallel-Port, Linux host, Windows 98SE-guest

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Benutzeravatar
Member
Beiträge: 19
Registriert: 19.02.2006, 16:21

Drucker am 1.Parallel-Port, Linux host, Windows 98SE-guest

Beitragvon Siegelfriedel » 15.07.2006, 21:27

Hallo,

ich habe auf einem Linux-Guest ein Windows 98SE laufen und will auf den Drucker am Parallel-Port zugreifen.
In meiner start_linux.vmx habe ich folgende Einträge gemacht:

parallel0.present "true"
parallel0.startConnected = "true"
parallel0.bidirection = "true"
parallel0.fileType = "device"
parallel0.fileName = "LPT1"

(analog zu http://sanbarrow.com/vmx-parallel-ports.html )

Der Drucker startet aber "disconnected" und die Fehlermeldung lautet
"Cannot open LTP1: No such file or directory"

Auf meinem Linux-Host ist der Drucker unter /dev/lp0 eingerichtet und läuft.

Wenn ich jetzt letzte Zeile auf

parallel0.fileName = "/dev/lp0"

ändere, bekomme ich die Meldung

Cannot open /dev/
parport0: Permission denied.

Wenn ich vmplayer als "root" starte sagt er mir auch permission denied und erklärt sinngemäß, dass "das device offenbar von einem anderen Programm benutzt wird, z.B. lp", was ja auch richtig so ist.

Kann mir jemand weiter helfen?

Danke

Siegfried Haas

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 15.07.2006, 22:04

http://www.linuxforen.de/forums/showthr ... adid=47553


Nutze das virtuelle Netz per IPP oder Samba. Das ist stressfreier als Schnittstellen mit 2 OS parallel zu nutzen.

Benutzeravatar
Member
Beiträge: 19
Registriert: 19.02.2006, 16:21

Beitragvon Siegelfriedel » 16.07.2006, 07:37

Hallo,

danke für die Antwort.
Ich versuche es gerade mit dem IPP-Protokoll, habe das entsprechende Programm downgeloaded und in Win98SE installiert.
Auf dem Linux-Host(Suse 10.0) läuft Cups, und der Drucker ist /printers/Standarddrucker.

Leider erhlate ich, wenn ich jetzt im Guest im Assistenten für Druckerinstallation den Netzwerkpfad eingebe:

http://192.168.82.2:631/printers/Standarddrucker

die Meldung

Ihnen fehlen die erforderlichen Zugriffsrechte für diesen Drucker.
Wo liegt der Fehler? Bei Cups?
Wie stelle ich das in Cups ein?
Oder auf der Guest-Seite?

Danke

Siegfried Haas

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 16.07.2006, 12:15

Du musst am Gast ein Login mit Kennwort 1:1 zur aktuellen Anmelöung haben.

Member
Beiträge: 3
Registriert: 28.07.2006, 18:23

Scanner

Beitragvon nicht_schlecht » 28.07.2006, 18:28

Bei einem Drucker kann an das Umgehen, aber was macht man wenn man einen Scanner ansteuern möchte und dabei auf den /dev/lp0 angewiesen ist. Welches Programm nutzt in Linux den LPT und wie kann man dieses deaktivieren.

Währe super wenn da jmd eine Lösung hätte

Benutzeravatar
Moderator
Beiträge: 1598
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 28.07.2006, 23:30

Scanner kann man auch mit dem Netz betreiben, ich habe aber einen HP Scan Jet 5p der läuft über SCSI 8)

Stichwort heist SANE

Member
Beiträge: 3
Registriert: 28.07.2006, 18:23

SANE

Beitragvon nicht_schlecht » 29.07.2006, 13:11

Aber SANE unterstützt laut aussage von dem YAST-Kontrollzentrum meinen Scanner nicht. Außerdem habe ich gelesen das LPT Scanner in Linux eigentlich nicht unterstützt werden, SCSI schon. Der Scanner ist ein "Mustek 1200 CP". Aus den oben genannten Gründen hatte ich ja vor den Scanner über das Gastsystem zu betreiben.

Member
Beiträge: 3
Registriert: 28.07.2006, 18:23

Linux

Beitragvon nicht_schlecht » 29.07.2006, 13:21

Aber wenn der Scanner unter Linux läuft dann muss ich mich mal nach einer RPM umschauen. Oder weiß einer wo eine RPM zufinden ist.

Benutzeravatar
Moderator
Beiträge: 1598
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 29.07.2006, 14:13

http://www.linuxforen.de/forums/showthr ... ?p=1389623

Das Howto ist etwas älteren Datums....
Die Kompeliererei sollte daher unnötig sein

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 05.08.2006, 16:51

Guter Hinweis, muss ich aktualisieren.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast