Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

VMPlayer Kompilierungsfehler bzw Install-Abbruch unter FC4

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 2
Registriert: 15.06.2006, 17:33

VMPlayer Kompilierungsfehler bzw Install-Abbruch unter FC4

Beitragvon Onkel Hotte » 15.06.2006, 17:48

Hallo Gemeinde,

mein erster Beitrag hier und dann gleich solch Problem?!

Beim kompilieren der VM-Module bricht das Install- Script ab:

Building for VMware Player 1.0.x or VMware Workstation 5.5.x.
Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config5/vmmon-only'
make -C /lib/modules/2.6.16-1.2115_FC4smp/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/kernels/2.6.16-1.2115_FC4-smp-i686'
CC [M] /tmp/vmware-config5/vmmon-only/linux/driver.o
CC [M] /tmp/vmware-config5/vmmon-only/linux/hostif.o
CC [M] /tmp/vmware-config5/vmmon-only/common/cpuid.o
CC [M] /tmp/vmware-config5/vmmon-only/common/hash.o
CC [M] /tmp/vmware-config5/vmmon-only/common/memtrack.o
CC [M] /tmp/vmware-config5/vmmon-only/common/phystrack.o
CC [M] /tmp/vmware-config5/vmmon-only/common/task.o
gcc: installation problem, cannot exec 'cc1plus': Datei oder Verzeichnis nicht gefunden
make[2]: *** [/tmp/vmware-config5/vmmon-only/common/task.o] Fehler 1
make[1]: *** [_module_/tmp/vmware-config5/vmmon-only] Fehler 2
make[1]: Leaving directory `/usr/src/kernels/2.6.16-1.2115_FC4-smp-i686'
make: *** [vmmon.ko] Fehler 2
make: Leaving directory `/tmp/vmware-config5/vmmon-only'
Unable to build the vmmon module.


System
Fedora Core 4
2x XEON 2,66 CPU
2.6.16-1.2115_FC4smp #1 SMP Mon Jun 5 15:01:58 EDT 2006 i686 i686 i386 GNU/Linux


Der Any-Any Patch ist installiert (ohne Probleme).

Hat einer eine Idee?

MfG

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 15.06.2006, 21:01

Hallo,
welchen any-any patch? Probier mal den neuesten. Müsste min. Version 101 sein.
Und auch:

su -
cd /usr/src/kernels/2.6.16-1.2115_FC4-smp-i686/linux
make cloneconfig && make modules_prepare

vor vmware-config.pl ausgeführt? -> siehe Handbuch
Beim Server war das nicht nötig fällt mir gerade auf... Hmm
Grüße, Martin

Benutzeravatar
Moderator
Beiträge: 1598
Registriert: 16.10.2002, 20:13
Wohnort: Köln

Beitragvon minimike » 15.06.2006, 21:57

Stimmt habe eben den Server mit Kernel 2.6.16.20 + Bootsplashpatch installiert. Lief ohne Patch recht ordentlich. Gerade installiere ich WIndows Vista...

Member
Beiträge: 2
Registriert: 15.06.2006, 17:33

Beitragvon Onkel Hotte » 16.06.2006, 10:11

es ist der Any Patch 101 drauf.
Ich habe aber gcc-c++ und libstdc++-devel nach installiert, nun änderte sich schon mal der Fehler:

CC [M] /tmp/vmware-config7/vmmon-only/linux/driver.o
CC [M] /tmp/vmware-config7/vmmon-only/linux/hostif.o
CC [M] /tmp/vmware-config7/vmmon-only/common/cpuid.o
CC [M] /tmp/vmware-config7/vmmon-only/common/hash.o
CC [M] /tmp/vmware-config7/vmmon-only/common/memtrack.o
CC [M] /tmp/vmware-config7/vmmon-only/common/phystrack.o
CC [M] /tmp/vmware-config7/vmmon-only/common/task.o
cc1plus: Warnung: Kommandozeilenoption "-Wstrict-prototypes" ist gültig für Ada/C/ObjC, aber nicht für C++
cc1plus: Warnung: Kommandozeilenoption "-Wdeclaration-after-statement" ist gültig für C/ObjC, aber nicht für C++
cc1plus: Warnung: Kommandozeilenoption "-Wno-pointer-sign" ist gültig für C/ObjC, aber nicht für C++
cc1plus: Warnung: Kommandozeilenoption "-Wstrict-prototypes" ist gültig für Ada/C/ObjC, aber nicht für C++
cc1plus: Warnung: Kommandozeilenoption "-ffreestanding" ist gültig für C/ObjC, aber nicht für C++
/tmp/vmware-config7/vmmon-only/common/task_compat.h: In function »void Task_Switch_V45(VMDriver*, Vcpuid)«:
/tmp/vmware-config7/vmmon-only/common/task_compat.h:1713: Warnung: »sysenterState$validEIP« könnte in dieser Funktion uninitialisiert verwendet werden


Was ich nicht verstehe ist, ich habe schon einen Rechner mit vmplayer am laufen, genau die selbe Softwareumgebung, nur keine Xeon CPU's sondern AMD MP CPU's verbaut. Dort lief alles von Beginn an. ???

cd /usr/src/kernels/2.6.16-1.2115_FC4-smp-i686/linux

das Verzeichnis linux existiert in diesem Pfad bei mir nicht.
Sollte mir das zu denken geben?


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast