Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Start VM über VMware Player als "Nicht-Adminstrator&quo

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 7
Registriert: 01.04.2006, 17:19

Start VM über VMware Player als "Nicht-Adminstrator&quo

Beitragvon sanhal » 01.04.2006, 17:28

Hallo zusammen,

VMs laufen bei mir recht stabil, teilweise wurden diese unter VMware 5.5 in der 30 Tage Frist erstellt, oder fertige VMs geladen.
Es gelingt mir jedoch nicht, von einem eingeschränkten Benutzer Konto unter Windows XP eine VM zu starten.
Es würden immer irgendwelche Rechte fehlen. Gibt es einen Weg, als Nicht-Admin über den VMware Player eine VM zu starten?

Danke und viele Grüße

Dietrich

P.S. Falls das eine Luschen-Frage ist, bitte Nachsicht. :lol: :D

Benutzeravatar
Profi
Beiträge: 992
Registriert: 07.08.2003, 09:32

Beitragvon looping » 01.04.2006, 17:48

Es würden immer irgendwelche Rechte fehlen. Gibt es einen Weg, als Nicht-Admin über den VMware Player eine VM zu starten?


seit vmware 5 gibt es einen dafür zuständigen dienst, der das ausführen als normaler benutzer ermöglicht - es handelt sich dabei um den "VMware Authorization Service". schau mal bitte nach, ob dieser dienst bei dir existiert bzw. gestartet wird

Member
Beiträge: 7
Registriert: 01.04.2006, 17:19

Beitragvon sanhal » 02.04.2006, 19:49

Hallo looping,

danke für den Hinweis. Ich habe es überprüft, der Dienst wird bei mir automatisch gestartet.

Die Meldung, die mir der VMware Player liefert beim Startversuch lautet:

Cannot open/create log file 'D:\Windows XP VM_1\Windows XP VM\vmware.log': Zugriff verweigert
Unable to open log file "D:\Windows XP VM_1\Windows XP VM\vmware.log". Check your configuration to make sure that the path specified for the log file is valid, and that you have write privileges in this directory.
The current log file is still 'C:\Dokumente und Einstellungen\Familie\Lokale Einstellungen\Temp\vmware-Familie\vmware-Familie-2464.log'.

Vielleicht gibt Dir das einen Hinweis, woran es liegen könnte.

Ich bin unter der Woche selten erreichbar, es kann somit immer etwas dauern, bis ich mich melde.

Schönen Sonntag noch und danke,

Dietrich

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 03.04.2006, 19:13

Schreib/Lesezugriffe auf den Ordnder der VM und alle Files dort sind natürlich nötig, weshalb Du Deinem Account diese Rechte geben musst.

Member
Beiträge: 7
Registriert: 01.04.2006, 17:19

Beitragvon sanhal » 06.04.2006, 10:07

Danke, das werde ich mal probieren, ob es daran liegt, bzw. ich das hinbekomme.

Dietrich

Member
Beiträge: 7
Registriert: 01.04.2006, 17:19

Beitragvon sanhal » 06.04.2006, 11:43

Hallo zusammen,

leider hängt es nicht an fehlenden Schreibzugriffen.

Der Player findet einfach, oder nimmt einfach nicht die richtige Log-Datei. In einer früheren Antwort habe ich die Meldung mal aufgeführt. Die Nummer am Ende des VMware-familie-xxxx.log files ändert sich, das Kopieren des vmware.log files aus dem Verzeichnis der VM bringt leider auch nichts.

Über jeden Tipp bin ich dankbar.

Viele Grüße

Dietrich

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 06.04.2006, 19:58

hä??
der nimmt jedesmal eine neues Log!!
Du musst natürlich Schreibrechte nicht nur auf die Files sondern auf den ganzen Ordner geben. Oder das Logfile woanders hinpacken.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 06.04.2006, 21:11

Der Player findet einfach, oder nimmt einfach nicht die richtige Log-Datei.


Check your configuration to make sure that the path specified for the log file is valid,


Du und der Player - ihr habt unterschiedliche Ansichten ueber die richtige Log-Datei :(

... um des lieben Friedens willen: einigt euch oder gebt das loggen ganz dran!

Guck mal auf meiner vmx-seite - der Player spricht denselben slang.

Ulli

Member
Beiträge: 7
Registriert: 01.04.2006, 17:19

Beitragvon sanhal » 09.04.2006, 17:48

Hallo Msueper,

auch nachdem die ganze VM in den Ordner "gemeinsame Dateien", wo alle Benutzer Zugriff haben, kommen dieselben Fehlermeldungen.

Hallo coninuum,

Deinen Hinweis mit "demselben slang" habe ich nicht kapiert, :-(, auch nach einem Blick in Deine Site nicht. Kannst Du noch genauer angeben, wo da was zu dem Thema steht?

Danke allen und ein schönes WE, trotz des Dauerregens.

Dietrich

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 09.04.2006, 17:56

Hallo,
continuum meint wahrscheinlich
logging = "FALSE"
in die vmx Datei zu schreiben. Das wird der Player kein Log mehr erzeugen wollen.
Grüße, Martin

Member
Beiträge: 7
Registriert: 01.04.2006, 17:19

Beitragvon sanhal » 15.04.2006, 18:06

Hallo,

das Einfügen von "logging = false" läßt die oben beschriebene Fehlermeldung bzgl. Log-File nicht mehr erscheinen, es taucht aber nun folgender Fehler auf:

Cannot open the disk 'C:\Dokumente und Einstellungen\All Users\Dokumente\Windows XP VM_1\Windows XP VM\Windows XP Home Edition.vmdk' or one of the snapshot disks it depends on.
Reason: Insufficient permission to access file.

Vielleicht wißt Ihr Bescheid, was ich da noch versuchen könnte.

Danke und frohe Ostern.

Dietrich

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 16.04.2006, 11:39

Hallo,
gibt es das angemerkte File? Hast Du nun wirklich die Schreib/Lese-Rechte darauf?
Wenn beide male JA, dann fehlt wohl ein Snapshot wie die Meldung oben besagt. Hast Du welche mit der WS angelegt?
Grüße und frohe Osten,
Martin

Member
Beiträge: 7
Registriert: 01.04.2006, 17:19

Beitragvon sanhal » 16.04.2006, 13:17

Hallo,

ja, das File gibt es, und es erscheint auch die gleiche Fehlermeldung, wenn ich dem Benutzer kurzfristig Admin-Rechte gebe.
Angelegt wurden die VMs mit der WS Version 4.5 (seinerzeit aus c´t Heft). Dann habe ich aber WS 5.5. drübergespielt, und da lief es auch (allerdings nur als Admin probiert).
Nach Ablauf der 30 Tage von WS 5.5 dann die VMs nur noch mit dem Player genutzt.

I´m lost,

Dietrich


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste