Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Benötige dringend Hilfe VM lässt sich nicht mehr öffnen.

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 19
Registriert: 03.05.2014, 16:48

Benötige dringend Hilfe VM lässt sich nicht mehr öffnen.

Beitragvon wellersberg » 12.05.2014, 11:04

VM-Machine lässt sich nicht mehr öffnen.

Wirt WIN 7
VM-Machine WIN XP
In der VM-Machine mit WIN XP wurde eine CD eingelegt
zur Programminstallation.
Der Installationsvorgang wurde auch gestartet.
Das Programm wurde allerdings vom / im WIN 7 Rechner
installiert.
Dies wäre auch kein Beinbruch, aber das VM-Symbol in der
Taskleiste von WIN 7 ist verschwunden.
Ein Umschalten iin die VM ist mir nicht mehr möglich.
Starte ich den Player und versuche von dort umzuschalten
erscheint die Meldung ( sinngemäß )
Die VM scheint in Gebrauch zu sein. Will you take the
ownership of the VM. The VM may be damaged.
Dies habe ich erstmal nicht gemacht.
Status : WIN 7 läuft, VM ist nicht erreichbar.
Was ist zu tun ?
mfg Georg

Experte
Beiträge: 1274
Registriert: 04.10.2011, 14:06

Beitragvon JustMe » 12.05.2014, 11:54

Findet sich im Windows-Taskmanager noch ein VM-Prozess?
Laesst sich die IP-Adresse des VM-Gastbetriebssystems noch anpingen?

Wie sieht's aus mit Administrator-Rechten?

Wenn die ersten Punkte nicht helfen:
Laesst sich der Host rebooten?

Member
Beiträge: 19
Registriert: 03.05.2014, 16:48

Beitragvon wellersberg » 12.05.2014, 12:15

Findet sich im Windows-Taskmanager noch ein VM-Prozess?
Nein
Laesst sich die IP-Adresse des VM-Gastbetriebssystems noch anpingen?
Leider weis ich nicht wie das geht. Könnte das Anpingen
noch ein Vorteil sein ?

Wie sieht's aus mit Administrator-Rechten?
Einzelplatz-Rechner ( neu ). Werde wohl Administrator sein.

Wenn die ersten Punkte nicht helfen:
Laesst sich der Host rebooten?
Was Tun : Rebbot oder im VM-Player " Task übernehmen " ?
Wird wohl beides Risiko sein.
Die VM wird wohl nicht " supspended " sein.
Die VM wurde bisher immer mit " suspended " beendet.
mfg Georg

Member
Beiträge: 19
Registriert: 03.05.2014, 16:48

Beitragvon wellersberg » 12.05.2014, 13:47

Zur Information : Der GAU ist vorbei

Zunächst wurde versucht im VM-Player ( WIN 7 ) die
" ownership " zu übernehmen. Hier erschien eine
Fehlermeldung.
Dann wurde WIN 7 neu gebootet.
Nach dem Booten wurde der VM-Player aufgerufen.
WIN XP war " powered off ".
Die VM-WinXP wurde aufgerufen.
Dies gelang. Bisher läuft alles.
Ich hoffe es bleibt so.
mfg Georg

Experte
Beiträge: 1274
Registriert: 04.10.2011, 14:06

Beitragvon JustMe » 12.05.2014, 13:48

Könnte das Anpingen noch ein Vorteil sein ?

Klar doch :-)
Wuerde der Gast noch erreichbar sein, wuerde das anzeigen, dass da noch jemand lebt, den man vielleicht auch zu einem geordneten Rueckzug ueberreden koennte (RDP etc.).

Einzelplatz-Rechner ( neu ). Werde wohl Administrator sein.

Das war schon bei XP lediglich eine begruendete Hoffnung, aber keine gesicherte Aussage mehr. Unter Win7 stimmt das grundsaetzlich nicht mehr, bzw. muss durch geeignete gezielte Massnahmen hervorgerufen werden.

Wird wohl beides Risiko sein.

Stimmt. Aber irgendwie moechte man ja schon mal wieder an die VM ran. Probier's doch einfach mal aus, wenn der VM-Gast ja offensichtlich nicht mehr aktiv ausgefuehrt wird.

Die VM wurde bisher immer mit " suspended " beendet.

Mit "suspended" wird weder die VM noch deren Gastsystem "beendet". Es wird lediglich der Hypervisor-Prozess beendet. Alles andere, was die VM so ausmacht, inkl. Zugriffsrechten auf die weiterhin bestehenden Dateien, bleibt dabei doch erhalten...

Member
Beiträge: 19
Registriert: 03.05.2014, 16:48

Beitragvon wellersberg » 12.05.2014, 14:09

Falls du noch helfen willst : Wie geht das Anpingen ?
In der Hilfe finde ich unter " ping " nichts.

" Suspend " heißt doch : die ganze VM auf die Festplatte
sichern. Das dürfte doch standardmäßig beim Beenden
das Sicherste sein.
mfg Georg

Experte
Beiträge: 1274
Registriert: 04.10.2011, 14:06

Beitragvon JustMe » 12.05.2014, 15:13

Eijeijeijei, dann wird's schwer...
Nicht DEINE Schuld! Aber ich fuerchte, dass ich dann manchmal das eine oder andere zuviel erwarte, und Erlaeuterungen nicht wirklich erlaeuternd daherkommen.

Also:
"ping" ist ein Befehl auf der Eingabeaufforderung. Dadurch wird ein Informationspaket von einem Netzwerkteilnehmer in Richtung eines anderen (i.A. dessen IP-Adresse) gesandt, und auf dessen Antwort gelauscht. Wenn eine solche Antwort kommt, weiss man, dass dieser andere Teilnehmer die Anfrage bearbeiten konnte, und somit zumindest in bestimmten Teilen noch "lebt" (und die Verbindung dahin ok usw.usf.).

Code: Alles auswählen

H:\>ping 169.254.0.1

Ping wird ausgeführt für 169.254.0.1 mit 32 Bytes Daten:
Allgemeiner Fehler.

Ping-Statistik für 169.254.0.1:
    Pakete: Gesendet = 1, Empfangen = 0, Verloren = 1
    (100% Verlust),


Das "Beenden/Suspenden" von dem Du sprichst schreibt nicht "die ganze VM auf die Festplatte", sondern den Hauptspeicherinhalt des "virtuellen Computers". Es entspricht also eher dem Windows-Ruhezustand, und nicht einem Herunterfahren, und das dann mit allen impliziten Komplikationen wie geoeffneten Dateien, auf Antwort wartenden Prozessen, etc.pp. im Gastbetriebssystem der VM, sowie auch den Dateien auf der Host-Festplatte, die der VMware Player als Hypervisor der VM erstellt hat, und im Zugriffsrechtekontext des aufrufenden Benutzers bearbeitet.

Sehr viel "sicherer" ist somit auf jeden Fall das "Herunterfahren" des Gastbetriebssystems.

Ich kann und will es nicht versprechen, aber ich vermute mal, dass in Deinem Fall ein ausfuehrliches Backup sinnvoll waere, und dann der Versuch, den Besitz der VM zu uebernehmen (Take Ownership wie eingangs geschrieben). Falls das nicht helfen sollte, hast Du immer noch das Backup, um an dem momentanen Stand jemand mit mehr Erfahrung weiterbasteln zu lassen.

Viel Glueck!

Member
Beiträge: 19
Registriert: 03.05.2014, 16:48

Beitragvon wellersberg » 12.05.2014, 15:33

Vielen Dank für deine ausführlichen Erläuterungen.

Zunächst einmal. Der GAU ist vorbei. Alles ist wieder in Ordnung.

Der Gau wurde ausgelöst indem in der VM-XP eine Installations-CD
eingelegt wurde. Natürlich für das XP in der VM gedacht.
Unglücklichsterweise wurde die Installation von WIN 7 übernommen.
Wieso weiß ich nicht. Ich muß das ganze Vorgehen erst noch
analysieren und wieder testen.

Ich bin nur ein einfacher WIN XP Einzelplatz Anwender, der derzeit
versucht sein XP auf einen neuen WIN 7 Rechner zu retten.
Allzusehr hardwarenah ( mit Ping ) darf es bei mir nicht werden.

Wie du ausgeführt hast ist das normale Herunterfahren die
sicherere Art die VM zu beenden.

Ein Komplettbackup mache ich einmal die Woche auf eine externe
Festplatte. Dies reicht für mich aus. Vom Freiitag wäre also noch
eine funktionierende VM verfügbar gewesen.

mfg Georg

Benutzeravatar
Member
Beiträge: 2
Registriert: 13.05.2014, 15:39

gleiches problem, andere konfiguration...

Beitragvon curtis » 13.05.2014, 16:02

sodele und moin, moin...
dann hänge ich mich doch gleich mal an das thema 'ran.

bei mir läuft der VMware player für mein altes XP auf der festplattensektion G unter windows 8.1 und war bis heute problemlos...

den XP guest beende ich immer durch "korrektes" herunterfahren des XP betriebssystems. heute jedoch blieb der player beim herunterfahren hängen und reagierte überhaupt nicht mehr. daraufhin habe ich ihn per task manager zwangsbeendet.

seitdem ist der zugriff auf den XP guest nicht mehr möglich (meldung: This virtual machine appears to be in use. If this virtual machine is not in use, press the "Take Ownership" button to obtain ownership of it. Otherwise, press the "Cancel" button to avoid damaging it. Configuration file: G:\XPextend.vmx.)

die "ownership" lässt sich jedoch nicht übernehmen. laut task manager sind keine VMware-prozesse mehr am laufen (jedenfalls keine, die ich als solche identifizieren kann - es sei denn, sie hießen anders). ein herunter- und wieder herauffahren des rechners hat auch nix genützt. offenbar muss irgendwo die info hinterlegt sein, dass ding sei noch am laufen (was es de facto jedoch wohl nicht mehr ist)...

hat jemand 'n tip für mich, wie ich die maschine wieder zum laufen kriege...? eine anmerkung zum pingen: wie soll ich den guest anpingen, wenn ich seine adresse nicht weiß?

vielen dank im voraus,
curtis

Jenseits von Gut & Böse
Beiträge: 10996
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 13.05.2014, 16:13

Schau mal ob *.lck (Lock) herum liegen und wenn ja dann loesche diese.

Gruss
Joerg

Benutzeravatar
Member
Beiträge: 2
Registriert: 13.05.2014, 15:39

Beitragvon curtis » 13.05.2014, 16:31

yup, da lag tatsächlich ein .lck herum. habs geloscht --> alles gut macht der reboot...
das merke ich mich für eventuell zukünftige abstürze...

geilomat, es läuft wieder. muchas gracias, irix, danke!

gruß, curtis

Jenseits von Gut & Böse
Beiträge: 10996
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 13.05.2014, 16:35

Das Problem kommt auch vor wenn der Host mal nicht sauber herunterfahren kann bzw. die VM halt im "Betrieb" unsanft beendet wird. VMware verwendet hier *.lck Dateien um zu verhindern das eine VM doppelt ausgefuehrt wird. Das kann dann halt mal einen Neustart verhindern.

Gruss
Joerg


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast