Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Parallel-Port funktioniert nur einmal

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 2
Registriert: 08.04.2014, 17:43

Parallel-Port funktioniert nur einmal

Beitragvon Photogregor » 08.04.2014, 18:53

Hallo Forum,

ich versuche wegen EOL von Windows XP für den Weiterbetrieb einer uralten Etikettier-Software eine PCIE-Parallel-Port-Karte an eine XP-VM durchzureichen. Der Player (6.0.1) läuft auf einem W8.1 Pro, in der VM läuft XP Pro SP3, die aktuellen Tools sind installiert. Auf dem Host wird LPT1 im Gerätemanager sauber erkannt und ein Testdruck landet auch korrekt auf dem Etikettendrucker.

Wenn ich den VMPlayer frisch installiere, dann anschließend die XP-VM einbinde und starte, ist der Etikettendrucker in der VM auch online und funktioniert. Sobald ich die VM aber reboote, ist der Drucker offline. Weitere Reboots ändern daran nichts mehr. In den VM-Settings ist der Parallel-Port eingerichtet als "Autodetect" und die Häkchen bei "Connected" und "Connect at Power On" sind gesetzt. Testweises Umstellen von "Autodetect" auf "LPT1" ändert nichts am Problem.

Bin leider VMware-Frischling und würde mich über einen guten Tipp sehr freuen.

LG
Stefano

Benutzeravatar
King of the Hill
Beiträge: 12011
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 08.04.2014, 19:37

Verlinke mal bitte das "vmware.log" aus dem Ordner der XP-VM auf einen Freehoster oder eigenen Webspace. Mit etwas Glück enthält das Log irgendwelche Einträge zum Parallelport.

Member
Beiträge: 2
Registriert: 08.04.2014, 17:43

Anders gelöst

Beitragvon Photogregor » 12.04.2014, 20:57

Hallo Dayworker,

vielen Dank für deine Antwort - sorry, dass ich erst jetzt dazu komme, zu reagieren. Ich habe das Problem mittlerweile gelöst, indem ich die Guest-Option "Printer" (oder so ähnlich) aktiviert habe. Damit werden sämtliche Drucker, die auf dem Host installiert sind, an den Gast weitergegeben, sodass ich die explizite Durchreichung des Parallelports gar nicht mehr benötige. Ich hatte bei meinen Versuchen zwar diese Option schon einmal getestet, allerdings ohne sichtbares Ergebnis. Erst, nachdem ich diese Option ein zweites Mal gesetzt und anschließend die Tools ERNEUT installiert habe, tauchten plötzlich in der Druckersteuerung des Gastes sämtliche Host-Drucker auf und der am Parallelport angeschlossene Etikettendrucker ratterte los.

Besten Dank und LG,
Stefano


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast