Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

VMWare Player autostart hängt

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 7
Registriert: 25.02.2013, 11:06

VMWare Player autostart hängt

Beitragvon silverspirit » 27.03.2014, 09:37

Hallo,
ich habe meinen VMWare player samt image im Autostart hinterlegt. Leider wird das Image ca jedes 2mal nicht gestartet. Der VMWare Player bleibt bei dem schwarzen (start) bildschirm "hängen" es erscheint auch keine Fehlermeldung. Ich kan den VMWare Player (6.0.1) dann noch noch per Task manager beenden.
Dasselbe verhalten habe ich bei einen XP als auch bei einen Windows 7 Image.

Mit diesen Startup/Autostart Eintrag starte ich das Image:
"C:\_Data\.......\Windows 7.vmx"

Hat vielleicht jemand eine idee ?
Thanks

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 27.03.2014, 10:02

Die Fehlermeldungen sind wichtig.
Ebenso können wir bei editierten Pfaden nicht wissen ob du weisst wie man mit Pfaden mit Leerzeichen klar kommst.

Am bestens nimmst du eine cmd - dann kann vorher aufgeräumt werden : alte Lockfiles entfernen ... usw

Member
Beiträge: 7
Registriert: 25.02.2013, 11:06

Beitragvon silverspirit » 27.03.2014, 13:29

Naja, es wird ja keine fehlermeldung angezeigt, auch die vmware.log ist noch leer zu diesen Zeitpunkt.
Den Pfad zur *.vmx musste ich editieren, er steht allerdings in anführungszeichen, ich denke das dürfte nicht zu einen problem führen.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 27.03.2014, 18:15

erstell eine cmd mit

"voller pfad\vmplayer.exe" "voller pfad\zur\name.vmx"

Member
Beiträge: 7
Registriert: 25.02.2013, 11:06

Beitragvon silverspirit » 28.03.2014, 15:58

ok, ich habe ein cmd file wie beschrieben erzeugt. Es lief dennoch nicht.
Erst als ich einen timeout von 45 sekunden eingebaut habe ging es. Weitere starts sind aber noch notwendig, um zu sehen ob es jetzt immer klappt.

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 28.03.2014, 20:47

Dir ist aber schon klar, daß du damit nur den VM-Autostart geregelt bekommen hast und das das über einen Win-Autostart-Eintrag immer schon ging?
Was ist mit dem sicheren VM-Shutdown bei Host-Shutdown?

Member
Beiträge: 7
Registriert: 25.02.2013, 11:06

Beitragvon silverspirit » 01.04.2014, 11:17

Es klappt leider immer noch nicht (zumindest meistens nicht). Der VM ware player samt Image wird egal ob über Windows autostart eintrag direkt oder dort mit cmd file zwar angestartet, hängt aber dann.
Das image in der VM wird immer per hand sauber heruntergefahren (shutdown guest), somit sollte der Automatische start eigentlich klappen. Starte ich es manuell (über doppelklick auf autostart cmd file) funktioniert es tadellos....

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 01.04.2014, 19:02

Ich würde weitere zeile in der cmd verwenden um das VM-verzeichnis vor dem Start aufzuräumen.

Die vmx kann man auch so editieren dass die Wahrscheinlichkeit für einen Start steigt

Member
Beiträge: 7
Registriert: 25.02.2013, 11:06

Beitragvon silverspirit » 02.04.2014, 10:00

ich hänge mal zwei files an:
a) ein auszug des verzeichnisses wo die VM liegt.
-> Was könnte man da löschen vor dem VM Start ?
b) die VM.vmx datei
-> Welche Optimierung könnte man da vornehmen ?

Besten Dank.

Ich kann leider keine Attachments einfügen, dann hänge ich den Text hier rein:

a) ################### dir.txt ###########################
Volume in drive C is CSC ESOE
Volume Serial Number is 501D-A4D4

Directory of c:\_Data\BMW Sod\Virtual Machine\Windows 7

02.04.2014 09:54 <DIR> .
02.04.2014 09:54 <DIR> ..
19.03.2014 16:10 <DIR> caches
02.04.2014 09:54 0 dir.log
31.03.2014 09:00 132 Startup.cmd
01.04.2014 16:00 288.194 vmware-0.log
01.04.2014 11:33 263.539 vmware-1.log
01.04.2014 11:20 498.293 vmware-2.log
02.04.2014 09:38 266.393 vmware.log
02.04.2014 09:38 121.483 vprintproxy.log
02.04.2014 09:38 2.060.255.232 Windows 7-s001.vmdk
02.04.2014 09:38 2.141.716.480 Windows 7-s002.vmdk
02.04.2014 09:38 2.145.583.104 Windows 7-s003.vmdk
02.04.2014 09:38 2.146.697.216 Windows 7-s004.vmdk
02.04.2014 09:38 2.146.762.752 Windows 7-s005.vmdk
02.04.2014 09:38 1.701.511.168 Windows 7-s006.vmdk
02.04.2014 09:38 1.459.748.864 Windows 7-s007.vmdk
02.04.2014 09:38 1.094.451.200 Windows 7-s008.vmdk
02.04.2014 09:38 1.139.998.720 Windows 7-s009.vmdk
02.04.2014 09:38 327.680 Windows 7-s010.vmdk
02.04.2014 09:38 2.082.209.792 Windows 7-s011.vmdk
02.04.2014 09:38 1.205.141.504 Windows 7-s012.vmdk
02.04.2014 09:38 327.680 Windows 7-s013.vmdk
02.04.2014 09:38 327.680 Windows 7-s014.vmdk
02.04.2014 09:38 327.680 Windows 7-s015.vmdk
02.04.2014 09:38 327.680 Windows 7-s016.vmdk
02.04.2014 09:38 327.680 Windows 7-s017.vmdk
02.04.2014 09:38 327.680 Windows 7-s018.vmdk
02.04.2014 09:38 327.680 Windows 7-s019.vmdk
02.04.2014 09:38 327.680 Windows 7-s020.vmdk
02.04.2014 09:38 131.072 Windows 7-s021.vmdk
02.04.2014 09:38 8.684 Windows 7.nvram
02.04.2014 09:23 1.319 Windows 7.vmdk
19.03.2014 08:41 0 Windows 7.vmsd
02.04.2014 09:38 3.179 Windows 7.vmx
02.04.2014 09:44 <DIR> Windows 7.vmx.lck
26.03.2014 12:11 3.934 Windows 7.vmxf
33 File(s) 19.328.611.374 bytes
4 Dir(s) 277.094.785.024 bytes free

b) ############### VMX File #######################
.encoding = "windows-1252"
config.version = "8"
virtualHW.version = "10"
scsi0.present = "TRUE"
scsi0.virtualDev = "lsisas1068"
sata0.present = "TRUE"
memsize = "1500"
mem.hotadd = "TRUE"
scsi0:0.present = "TRUE"
scsi0:0.fileName = "Windows 7.vmdk"
sata0:1.present = "TRUE"
sata0:1.fileName = "D:"
sata0:1.deviceType = "cdrom-raw"
ethernet0.present = "TRUE"
ethernet0.connectionType = "nat"
ethernet0.virtualDev = "e1000"
ethernet0.wakeOnPcktRcv = "FALSE"
ethernet0.addressType = "generated"
usb.present = "TRUE"
ehci.present = "TRUE"
ehci.pciSlotNumber = "35"
sound.present = "TRUE"
sound.virtualDev = "hdaudio"
sound.fileName = "-1"
sound.autodetect = "TRUE"
mks.enable3d = "TRUE"
serial0.present = "TRUE"
serial0.fileType = "thinprint"
pciBridge0.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
vmci0.present = "TRUE"
hpet0.present = "TRUE"
usb.vbluetooth.startConnected = "TRUE"
displayName = "Windows 7"
guestOS = "windows7"
nvram = "Windows 7.nvram"
virtualHW.productCompatibility = "hosted"
gui.exitOnCLIHLT = "TRUE"
powerType.powerOff = "soft"
powerType.powerOn = "soft"
powerType.suspend = "soft"
powerType.reset = "soft"
extendedConfigFile = "Windows 7.vmxf"
gui.lastPoweredViewMode = "fullscreen"
uuid.bios = "56 4d 96 e6 78 74 a6 45-e2 12 83 42 6d 8a 1d f2"
uuid.location = "56 4d 96 e6 78 74 a6 45-e2 12 83 42 6d 8a 1d f2"
replay.supported = "FALSE"
replay.filename = ""
scsi0:0.redo = ""
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
scsi0.pciSlotNumber = "160"
usb.pciSlotNumber = "32"
ethernet0.pciSlotNumber = "33"
sound.pciSlotNumber = "34"
vmci0.pciSlotNumber = "36"
sata0.pciSlotNumber = "37"
scsi0.sasWWID = "50 05 05 66 78 74 a6 40"
ethernet0.generatedAddress = "00:0c:29:8a:1d:f2"
ethernet0.generatedAddressOffset = "0"
vmci0.id = "1434728404"
vmotion.checkpointFBSize = "134217728"
cleanShutdown = "TRUE"
softPowerOff = "TRUE"
usb:1.speed = "2"
usb:1.present = "TRUE"
usb:1.deviceType = "hub"
usb:1.port = "1"
usb:1.parent = "-1"
sata0:1.startConnected = "TRUE"
tools.syncTime = "FALSE"
unity.wasCapable = "FALSE"
tools.remindInstall = "FALSE"
toolsInstallManager.updateCounter = "3"
isolation.tools.hgfs.disable = "FALSE"
usb.generic.autoconnect = "FALSE"
sharedFolder0.present = "TRUE"
sharedFolder0.enabled = "TRUE"
sharedFolder0.readAccess = "TRUE"
sharedFolder0.writeAccess = "TRUE"
sharedFolder0.hostPath = "C:\_Data\XXXX"
sharedFolder0.guestName = "XXXX"
sharedFolder0.expiration = "never"
sharedFolder.maxNum = "1"
hgfs.mapRootShare = "TRUE"
checkpoint.vmState = ""
floppy0.present = "FALSE"
usb:0.present = "TRUE"
usb:0.deviceType = "hid"
usb:0.port = "0"
usb:0.parent = "-1"

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 02.04.2014, 18:35

Löschen vor VM-Start kannst du nur alle LCK-Dateien und -Ordner. Wenn du die VM aber normal runterfährst, werden diese Dateien vom VMware-Produkt im Normalfall selbständig gelöscht. Fals bei dir ein Virenscanner etc werkelt, würde ich auf alle Fälle sämtliche Gast-Ordner auf dessen Ausnahmeliste setzen. Der Virenscanner sperrt für seine Arbeit eine Datei für jedweden Zugriff und das Gast-OS steht dann ohne Datenträger da.
Mit etwas Glück löst sich dann auch dein Problem mit den LCK-Dateien bzw -Ordnern von selbst.

Deine VM ist mit 1500MB RAM konfiguriert und beim VM-Start wird eine VMEM-Datei gleicher Grösse angelegt. Je nach Geschwindigkeit des Host-Datenträgers dauert es dann, bis die Datei zum einen geschrieben und zum anderen vom VMware-Produkt getestet sowie schlußendlich genutzt wird. Falls dein Virenscanner dann auch noch zuschlägt, könnte das ebenfalls die unterschiedlichen Start-Zeiten bzw Start-Probleme der VM erklären.

Die SharedFolders würde ich nur im absoluten Notfall nutzen, da diese bekanntermaßen unzuverlässig sind und im VMTN finden sich auch einige Thread zu Datenkorruption bei Nutzung von SharedFolders. Daher mach auf dem Host-OS einfach eine stinknormale Netzwerkfreigabe, die funktioniert immer.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast