Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

management agent klonen suse 11

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 38
Registriert: 12.09.2012, 08:57

management agent klonen suse 11

Beitragvon Locke85 » 28.09.2012, 09:54

Hallo
beim Klonen von ma muss ich wieder das Netwerk konfigurieren.
Ich mache das mit Hilfe von:

/etc/udev/rules.d/70-persistent-net.rules file.

Code: Alles auswählen

# PCI device 0x8086:0x10f5 (e1000e)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:ac:ee:0d:d5", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x8086:0x10f5 (e1000e)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:ac:e0:fd:23", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1021624

Im ersten Eintrag eth0 >> eth1 Umbenennen
und Lösche Komplett den zweiten Teil, doch wenn ich es wieder Klone habe ich im neuen ma das selbe und muss es nochmal Konfigurieren.


Gibt es eine möglichkeit die Einstellungen zu behalten?

MfG
Locke85

Jenseits von Gut & Böse
Beiträge: 10902
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 28.09.2012, 09:57

Dein Template darf keine Regel enthalten so das automatisch eine erstellt wird basierend auf der neuen akt. MAC der neuen VM.

Gruss
Joerg

Member
Beiträge: 38
Registriert: 12.09.2012, 08:57

Beitragvon Locke85 » 28.09.2012, 10:08

irix hat geschrieben:Dein Template darf keine Regel enthalten so das automatisch eine erstellt wird basierend auf der neuen akt. MAC der neuen VM.

Gruss
Joerg


Danke für die Antwort.
Meine dumme Frage:
Wie stell ich das an bzw was muss ich ändern?

MfG
Locke85

Jenseits von Gut & Böse
Beiträge: 10902
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 28.09.2012, 10:13

Die Datei loeschen.

Gruss
Joerg

Member
Beiträge: 38
Registriert: 12.09.2012, 08:57

Beitragvon Locke85 » 28.09.2012, 11:02

irix hat geschrieben:Die Datei loeschen.

Gruss
Joerg


Servus Jörg

Danke für deine schnelle Antwort.

Schritt 1 falls man keine Netzwerkverbindung hat nachdem Klonen, ansonsten direkt Schritt 2

/etc/udev/rules.d/70-persistent-net.rules file.

# PCI device 0x8086:0x10f5 (e1000e)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:ac:ee:0d:d5", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x8086:0x10f5 (e1000e)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:ac:e0:fd:23", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

Im ersten Eintrag eth0 >> eth1 Umbenennen
Im zweiten Eintrag eth1 Löschen und nur "" stehen lassen.

Neustart mit init 0

Schritt 2
Jetzt die Datein Löschen damit es nicht immer wieder NEU generiert wird.

cd /lib/udev
rm rule_generator.functions

cd /etc/udev/rules.d/
rm 70-persistent-net.rules file


rule_generator.functions generiert 70-persistent-net.rules file immer wieder neu.

MfG
Locke85

Jenseits von Gut & Böse
Beiträge: 10902
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 28.09.2012, 11:15

Beim Reboot... wenn sie nicht da ist.

In deiner Template VM
1. Datei loeschen
2. VM herunterfahren
3. In Template konvertieren
4. VM von Template erstellen und sicherstellen das vNic vorhanden und Haken auch aktiv gesetzt ist

Beim ersten Boot merkt deine Suse das die Datei fehlt und erstellt sie neu un sollte automatisch einen Eintrag erstellen mit der akt. MAC.

So sollte es zumind. sein.

Gruss
Joerg


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste