Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Windows Dualboot mit virtueller Festplatte

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 7
Registriert: 26.04.2012, 07:18

Windows Dualboot mit virtueller Festplatte

Beitragvon Chris1 » 26.04.2012, 07:33

Hallo!

Ich möchte mit verschiedenen Bootmanagern experimentieren und verwende deshalb den VMware Player.
Dazu habe ich eine virtuelle Festplatte mit 100 GB angelegt (2 Primäre Partitionen, eine erweiterte Partition) und Windows XP installiert. Als ersten Test wollte wollte ich zusätzlich zum bereits installierten XP Windows 7 installieren. Windows 7 sollte ja die Windows XP Installation erkennen und einen Bootmanager konfigurieren.
Leider findet das Setup von Windows 7 die Festplatte nicht. ("keine Festplatte gefunden")
Also wieder eine neue Virtuelle Maschine erstellt und Windows 7 installiert (diesmal hat Windows 7 die Festplatte gefunden). Allerdings findet das Setup von XP jetzt keine Festplatte.
Google liefert leider nur Dualboot-Lösungen mit RAW-Festplatten, nicht aber mit virtuellen Laufwerken.
Ist ein Dualboot in VMware nicht möglich?

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 26.04.2012, 10:06

Ist ein Dualboot in VMware nicht möglich?


doch das ist moeglich. Poste mal Details

Member
Beiträge: 7
Registriert: 26.04.2012, 07:18

Beitragvon Chris1 » 26.04.2012, 21:02

Host: Windows 7 Prof. 64bit

VMware 4.0.2 build-591240

Gastsystem: Windows XP 32bit
4 GB Arbeitsspeicher
100GB HDD

Mit VMware 4.0.0 hat es auch nicht funktioniert.

Ich habe mal ein Screenshot der Partitionierung des XP Gastsystems und einen Screenshot des selben Gastsystems mit gebooteter Win7 Setup-CD gemacht.

Bild

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 26.04.2012, 21:50

Hast du als IDE oder Buslogic installiert ?

Ideal waere LSIlogic mit F6 Treiber-floppy-image fuer die XP-installation

Member
Beiträge: 7
Registriert: 26.04.2012, 07:18

Beitragvon Chris1 » 26.04.2012, 22:08

Bei der Erstellung der virtuellen Maschine habe ich "I will install the operating system later" gewählt und XP über ein bootfähiges XP ISO-Image installiert. VMware Player hat dann die Standardeinstellungen SCSI (Recommended) für die virtuelle HDD benutzt.
In den "Hard Disk Advanced Settings" steht folgendes:

SCSI 0:0 Hard Disk (SCSI)

Man kann scheinbar keinen LSIlogic oder andere Controller auswählen, jedenfalls bin ich nicht fündig geworden.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 27.04.2012, 08:34

dann verwendest du also Buslogic - das wird fuer Win7 auf keinen Fall gehen.

wie schon gesagt: entweder installierst du auf IDE oder verwendest

scsi0.virtualDev = "lsilogic"

dann musst du dir aber auch das F6 floppy-image von LSI besorgen

Member
Beiträge: 7
Registriert: 26.04.2012, 07:18

Beitragvon Chris1 » 27.04.2012, 11:19

Der Hinweis auf SCSI hat mir weitergeholfen. Hätte nicht erwartet, dass standardmäßig SCSI verwendet wird, da ja auch die die Installationen auf die frische HDD immer ohne Treiber funktioniert haben.

Vielen Dank!

Mit dem Floppy-Image vmscsi.flp (bei VMware Player dabei) konnte Windows 7 mit den SCSI-Treibern erfolgreich installiert werden. Auch der Dualboot klappt jetzt.
Danach habe ich Ubuntu installiert, was diesmal auch ohne SCSI-Treiber funktioniert hat. Dies verwendet den Bootmanager GRUB und ich kann Windows 7 oder Ubuntu starten (Windows XP ist leider nicht mehr zur Auswahl). Allerdings hängt sich Windows 7 beim Bootvorgang auf. Somit hat Ubuntu beide Microsoft-Systeme gekickt...

Dann teste ich mal IDE.
Das ist vielleicht kompatibler als das in die Jahre gekommenen SCSI.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 27.04.2012, 11:23

ein dualboot Linux und Windows ist problematisch.

Gibt man Windows als GastOS funktioniert meistens unter Linux die Maus nicht mehr.

Du installierst ja doch Buslogic ! (vmscsi)
Das taugt nicht - besorg dir ein Treiberfloppy von LSI - das ist zeitgemaesser

Member
Beiträge: 7
Registriert: 26.04.2012, 07:18

Beitragvon Chris1 » 27.04.2012, 11:45

Ich möchte auf SCSI verzichten, da das System (wenn es läuft) auf einem S-ATA System nachgebaut werden soll.
Also XP+7+Linux auf einer Platte mit Bootmenü. Eine Möglichkeit, die ich gerade überlege wäre:
1. XP installieren
2. Wubi installieren (Ubuntu in einer virtuellen Disk auf der XP-Partition, ohne XP zu booten)
3. Windows 7 installieren

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 27.04.2012, 12:15

mit IDE kannst du alle 3 normal installieren ...

erklaer mal was beim letzten Versuch schief gegangen ist

Member
Beiträge: 7
Registriert: 26.04.2012, 07:18

Beitragvon Chris1 » 28.04.2012, 06:54

Das Problem war: nach der Linux-Installation tauchte Windows XP nicht mehr im Bootmenü auf. Windows 7 tauchte zwar in GRUB auf, hängte sich aber beim Booten auf.

Ich habe nun eine funktionierende Lösung für ein Multiboot mit WinXP+Win7+Ubuntu gefunden:

1. IDE verwenden, anstatt von SCSI

2. Windows XP in die erste Primäre Partition (sda1) installieren und den Rest der Festplatte unpartitioniert lassen

3. Nach der erfolgreichen Installation von XP eine zweite primäre partition erstellen, in die später Win7 soll. Es muss hinter der zweiten primären Partition noch eine erweiterte Partition (sda3) für Linux vorhanden sein. Dazu kann man die Datenträgerverwaltung von XP verwenden.

4. Linux in den freien Bereich hinter der zweiten primären Partition installieren. Nun kann man mit dem automatisch erstellten Bootmenü von GRUB zwischen Windows XP und Linux wählen.

5. Windows 7 in die zweite primäre Partition (sda2) installieren. Nun kann man beim Booten nur noch zwischen Win7 und XP wählen, da Win7 Windows XP erkennt, aber GRUB überschreibt.

6. GRUB reparieren mit einer Linux-Live-CD (z.B. Ubuntu)
- Live-System starten und überprüfen, in welche Partition sich Linux installiert hat (z.B. mit GParted). Hier war es sda5.
- In der Konsole eingeben:
sudo mount /dev/sda5 /mnt
sudo mount -o bind /dev /mnt/dev
sudo grub-install /dev/sda

Ergebnis: nun wird GRUB in den MBR installiert und man kann beim Booten zwischen Linux und Windows wählen. Wählt man Windows, hat man die Wahl zwischen XP oder Windows 7.

Member
Beiträge: 7
Registriert: 26.04.2012, 07:18

Beitragvon Chris1 » 28.04.2012, 07:09

Ein kleiner Fehler hat sich in die Anleitung eingeschlichen:
vor der Engabe von
sudo grub-install /dev/sda
muss man evtl. noch
sudo chroot /mnt
eingeben, um ins Wurzelverzeichne si zu wechseln. So hat es jedenfalls bei mir geklappt.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast