Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Serielle Schnittstelle Fehlermeldung

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 21
Registriert: 12.07.2010, 16:43

Serielle Schnittstelle Fehlermeldung

Beitragvon mc-12 » 16.03.2012, 15:25

Hallo,
ich habe eine VM im Player. Dieser VM sind die beiden seriellen Schnittstellen COM 2 und COM 3 des Host fest zugewiesen. Sobald Daten über die Schnittstellen gehen erscheint diese Fehlermeldung: "serial0:Unable to readfrom the COM2 serial port: Überlappender E/A-Vorgang wird verarbeitet. The device will be disconnected."
Im log steht noch: Unknown error 997 (0x3e5)

Wer kennt eine Lösug oder hat Vorschläge?
Bin für jeden Hinweis dankbar.

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 16.03.2012, 16:29

Verlinke mal bitte das "vmware.log" dieser VM auf einen Freehoster.

Member
Beiträge: 21
Registriert: 12.07.2010, 16:43

Beitragvon mc-12 » 19.03.2012, 12:17

hier die aktuelle log Datei .

http://ifile.it/hbxndre/vmware.log

VM gestartet, serieller Port automatisch verbunden, angeschlossenes Modem angeschaltet, Fehlermeldung aufgetaucht, VM heruntergefahren.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 19.03.2012, 13:01

du hast deiner VM nur folgendes zugewiesen:

serial0.present = TRUE
serial0.fileName = COM2

Les dir mal hier auf meiner Seite durch
http://sanbarrow.com/vmx/vmx-serial-ports.html
wie man com-ports einbindet

Member
Beiträge: 21
Registriert: 12.07.2010, 16:43

Beitragvon mc-12 » 19.03.2012, 14:10

Danke für die schnelle Antwort,
Ich habe folgendes eingetragen

serial0.present = "TRUE"
serial0.fileType = "device"
serial0.fileName = "COM1"
serial0.tryNoRxLoss = "FALSE"
serial0.autodetect = "FALSE"

Ohne Erfolg. Poblem besteht noch immer.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 19.03.2012, 14:21

lad nochmal das aktuelle vmware.log hoch

Member
Beiträge: 21
Registriert: 12.07.2010, 16:43

Beitragvon mc-12 » 19.03.2012, 14:36


Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 19.03.2012, 14:47

Hi
startest du die VM per rechtsklick "run as admin" oder als normaler user ?
probier mal als Admin

Member
Beiträge: 21
Registriert: 12.07.2010, 16:43

Beitragvon mc-12 » 19.03.2012, 15:08

die VM wird immer als Admin gestartet.
Ich verstehe nicht warum, sobald Daten über die serielle kommen, diese Schnittstelle abgeschaltet wird. Wo doch die Meldung besagt, daß er nicht davon lesen kann.
Die Meldung erscheint auch, wenn das Modem bereits während des booten eingeschaltet ist. Die serielle wird beim booten abgefragt und erzeugt die Fehlermeldung.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 19.03.2012, 15:12

versuch mal
serial0.yieldOnMsrRead = "TRUE"
serial0.hardwareFlowControl = "TRUE"

Member
Beiträge: 21
Registriert: 12.07.2010, 16:43

Beitragvon mc-12 » 19.03.2012, 15:33

Habe ich eingetragen. leider ohne Erfolg. Problem besteht noch.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 19.03.2012, 15:36

Als naechstes wuerde ich VMplayer 3.1.4 probieren - weiss aber nicht ob das eine Option fuer dich ist ?

Member
Beiträge: 21
Registriert: 12.07.2010, 16:43

Beitragvon mc-12 » 20.03.2012, 19:08

Mit Version 3.1.5 funktioniert es.

Vielen Dank für die schnellen Antworten.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast