Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

[gelöst] Unable to initialize module building library

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 15
Registriert: 18.02.2010, 08:41

[gelöst] Unable to initialize module building library

Beitragvon AnJo » 24.07.2011, 21:46

Hallo zusammen,

ich habe ein x86_64 Debian-System mit Kernel 3.0 am laufen.
vmware-player 3.1.4.
Mit Kernel 2.6.39 nach Anwenden eines Patches lief vmware-player ohne Probleme.

In der Regel kam nach jedem Kernelupdate der Hinweis, dass die Module neu gebaut werden müssen. Nach Bestätigung von "OK" wurden diese dann gebaut oder auch nicht.
Im letzteren Fall wurde dann nach einem entsprechenden Patch gesucht und angewendet.
Das war es aber dann auch schon

Nun kommt es sofort zu obiger Fehlermeldung.
In der Konsole sieht das dann so aus:

Code: Alles auswählen

root@pc:/# vmplayer
»/desktop/gnome/interface/accessibility« wurde kein Wert zugewiesen
»/desktop/gnome/interface/accessibility« wurde kein Wert zugewiesen
Logging to /tmp/vmware-root/setup-3542.log
Unable to initialize module building library
Fontconfig error: "conf.d", line 1: no element found
Fontconfig warning: line 73: unknown element "cachedir"
Fontconfig warning: line 74: unknown element "cachedir"


In der setup-3542.log steht:

Code: Alles auswählen

Jul 24 21:25:43.467: app-140346266490624| Log for VMware Workstation pid=3542 version=7.1.4 build=build-385536 option=Release
Jul 24 21:25:43.467: app-140346266490624| The process is 64-bit.
Jul 24 21:25:43.467: app-140346266490624| Host codepage=UTF-8 encoding=UTF-8
Jul 24 21:25:43.467: app-140346266490624| Logging to /tmp/vmware-root/setup-3542.log
Jul 24 21:25:43.527: app-140346266490624| Unable to initialize modconf query library

In der appLoader-3542.log ist folgendes zu finden:

Code: Alles auswählen

Jul 24 21:25:41.235: app-140346266490624| Log for VMware Workstation pid=3542 version=7.1.4 build=build-385536 option=Release
Jul 24 21:25:41.235: app-140346266490624| The process is 64-bit.
Jul 24 21:25:41.235: app-140346266490624| Host codepage=UTF-8 encoding=UTF-8
Jul 24 21:25:41.235: app-140346266490624| Calling: "/usr/lib/vmware/bin/vmware-modconfig --launcher=/usr/bin/vmware-modconfig --appname=VMware Player --icon=vmware-player"
Jul 24 21:25:41.235: app-140346266490624| Using configuration file /etc/vmware/config.
Jul 24 21:25:41.235: app-140346266490624| Using library directory:  /usr/lib/vmware.
LOG NOT INITIALIZED | Created dependency tree.
LOG NOT INITIALIZED | -- Processing libgtkmm-2.4.so.1 --
LOG NOT INITIALIZED | Unable to dlopen libgtkmm-2.4.so.1 on the system.  libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory
LOG NOT INITIALIZED | Using the shipped version of libgtkmm-2.4.so.1.
LOG NOT INITIALIZED | -- Finished processing libgtkmm-2.4.so.1 --
LOG NOT INITIALIZED | Accessibility is not enabled.
LOG NOT INITIALIZED | Accessibility is not enabled.
LOG NOT INITIALIZED | -- Processing libgtk-x11-2.0.so.0 --
LOG NOT INITIALIZED | -- libgtk-x11-2.0.so.0 has already been processed. --
LOG NOT INITIALIZED | libpangoxft-1.0.so.0 is marked to use the shipped library version.
LOG NOT INITIALIZED | libpangox-1.0.so.0 is marked to use the shipped library version.
LOG NOT INITIALIZED | libart_lgpl_2.so.2 is marked to use the shipped library version.
LOG NOT INITIALIZED | libXft.so.2 is marked to use the shipped library version.
LOG NOT INITIALIZED | librsvg-2.so.2 is marked to use the shipped library version.
LOG NOT INITIALIZED | libgnomecanvas-2.so.0 was not in the library set.
LOG NOT INITIALIZED | libgnomecanvasmm-2.6.so.1 was not in the library set.
LOG NOT INITIALIZED | libglade-2.0.so.0 was not in the library set.
LOG NOT INITIALIZED | -- Processing libglib-2.0.so.0 --
LOG NOT INITIALIZED | -- libglib-2.0.so.0 has already been processed. --
LOG NOT INITIALIZED | libgthread-2.0.so.0 is marked to use the shipped library version.
LOG NOT INITIALIZED | libgmodule-2.0.so.0 is marked to use the shipped library version.
LOG NOT INITIALIZED | libglibmm_generate_extra_defs-2.4.so.1 is marked to use the shipped library version.
LOG NOT INITIALIZED | libgobject-2.0.so.0 is marked to use the shipped library version.
LOG NOT INITIALIZED | System libcurl.so.4 has version 7.21.6 (need 7.19.5) and has NOT been compiled with c-ares support.
LOG NOT INITIALIZED | libsexy.so.2 <SHIPPED>
LOG NOT INITIALIZED | libart_lgpl_2.so.2 <SHIPPED>
LOG NOT INITIALIZED | libXrandr.so.2 <SHIPPED>
LOG NOT INITIALIZED | libssl.so.0.9.8 <SYSTEM>
LOG NOT INITIALIZED | libXfixes.so.3 <SHIPPED>
LOG NOT INITIALIZED | libgobject-2.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libgiomm-2.4.so.1 <SHIPPED>
LOG NOT INITIALIZED | libgmodule-2.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libXft.so.2 <SHIPPED>
LOG NOT INITIALIZED | libgthread-2.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libvmware-modconfig.so <SHIPPED>
LOG NOT INITIALIZED | libgvmomi.so.0 <SHIPPED>
LOG NOT INITIALIZED | libXdamage.so.1 <SHIPPED>
LOG NOT INITIALIZED | libXcomposite.so.1 <SHIPPED>
LOG NOT INITIALIZED | librsvg-2.so.2 <SHIPPED>
LOG NOT INITIALIZED | libview.so.2 <SHIPPED>
LOG NOT INITIALIZED | libglibmm-2.4.so.1 <SHIPPED>
LOG NOT INITIALIZED | libpangox-1.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libcds.so <SHIPPED>
LOG NOT INITIALIZED | libstdc++.so.6 <SHIPPED>
LOG NOT INITIALIZED | libpango-1.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libatkmm-1.6.so.1 <SHIPPED>
LOG NOT INITIALIZED | libXrender.so.1 <SHIPPED>
LOG NOT INITIALIZED | libgdk-x11-2.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libcairo.so.2 <SHIPPED>
LOG NOT INITIALIZED | libxml2.so.2 <SHIPPED>
LOG NOT INITIALIZED | libcairomm-1.0.so.1 <SHIPPED>
LOG NOT INITIALIZED | libvmwareui.so.0 <SHIPPED>
LOG NOT INITIALIZED | libXinerama.so.1 <SHIPPED>
LOG NOT INITIALIZED | libglib-2.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libsigc-2.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libgtk-x11-2.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libpangoxft-1.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libpangoft2-1.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libz.so.1 <SHIPPED>
LOG NOT INITIALIZED | libgdkmm-2.4.so.1 <SHIPPED>
LOG NOT INITIALIZED | libXcursor.so.1 <SHIPPED>
LOG NOT INITIALIZED | libXdmcp.so.6 <SYSTEM>
LOG NOT INITIALIZED | libXau.so.6 <SYSTEM>
LOG NOT INITIALIZED | libgdk_pixbuf-2.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libsexymm.so.2 <SHIPPED>
LOG NOT INITIALIZED | libpangomm-1.4.so.1 <SHIPPED>
LOG NOT INITIALIZED | libfreetype.so.6 <SHIPPED>
LOG NOT INITIALIZED | libgtkmm-2.4.so.1 <SHIPPED>
LOG NOT INITIALIZED | libvmwarebase.so.0 <SHIPPED>
LOG NOT INITIALIZED | libglibmm_generate_extra_defs-2.4.so.1 <SHIPPED>
LOG NOT INITIALIZED | libfontconfig.so.1 <SHIPPED>
LOG NOT INITIALIZED | libexpat.so.0 <SHIPPED>
LOG NOT INITIALIZED | libpng12.so.0 <SHIPPED>
LOG NOT INITIALIZED | libcurl.so.4 <SHIPPED>
LOG NOT INITIALIZED | libatk-1.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libcrypto.so.0.9.8 <SYSTEM>
LOG NOT INITIALIZED | libgcc_s.so.1 <SHIPPED>
LOG NOT INITIALIZED | libpangocairo-1.0.so.0 <SHIPPED>
LOG NOT INITIALIZED | libgio-2.0.so.0 <SYSTEM>
LOG NOT INITIALIZED | Loading system version of libssl.so.0.9.8.
LOG NOT INITIALIZED | Loading system version of libXdmcp.so.6.
LOG NOT INITIALIZED | Loading system version of libXau.so.6.
LOG NOT INITIALIZED | Loading system version of libcrypto.so.0.9.8.
LOG NOT INITIALIZED | Loading system version of libgio-2.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libgcc_s.so.1.
LOG NOT INITIALIZED | Loading shipped version of libstdc++.so.6.
LOG NOT INITIALIZED | Loading shipped version of libXinerama.so.1.
LOG NOT INITIALIZED | Loading shipped version of libXrender.so.1.
LOG NOT INITIALIZED | Loading shipped version of libXfixes.so.3.
LOG NOT INITIALIZED | Loading shipped version of libXcursor.so.1.
LOG NOT INITIALIZED | Loading shipped version of libXrandr.so.2.
LOG NOT INITIALIZED | Loading shipped version of libexpat.so.0.
LOG NOT INITIALIZED | Loading shipped version of libz.so.1.
LOG NOT INITIALIZED | Loading shipped version of libfreetype.so.6.
LOG NOT INITIALIZED | Loading shipped version of libfontconfig.so.1.
LOG NOT INITIALIZED | Loading shipped version of libXft.so.2.
LOG NOT INITIALIZED | Loading shipped version of libglib-2.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libgmodule-2.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libgobject-2.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libgthread-2.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libatk-1.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libpango-1.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libpangoft2-1.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libpangoxft-1.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libpangox-1.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libpng12.so.0.
LOG NOT INITIALIZED | Loading shipped version of libcairo.so.2.
LOG NOT INITIALIZED | Loading shipped version of libpangocairo-1.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libXcomposite.so.1.
LOG NOT INITIALIZED | Loading shipped version of libXdamage.so.1.
LOG NOT INITIALIZED | Loading shipped version of libgdk_pixbuf-2.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libgdk-x11-2.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libgtk-x11-2.0.so.0.
LOG NOT INITIALIZED | Running post-configure on libgtk-x11-2.0.so.0.
LOG NOT INITIALIZED | Saving variable LD_LIBRARY_PATH with value 0 to VMWARE_LD_LIBRARY_PATH.
LOG NOT INITIALIZED | Saving variable LD_PRELOAD with value 0 to VMWARE_LD_PRELOAD.
LOG NOT INITIALIZED | Saving variable PANGO_RC_FILE with value 0 to VMWARE_PANGO_RC_FILE.
LOG NOT INITIALIZED | Saving variable GDK_PIXBUF_MODULE_FILE with value 0 to VMWARE_GDK_PIXBUF_MODULE_FILE.
LOG NOT INITIALIZED | Saving variable GTK_IM_MODULE_FILE with value 0 to VMWARE_GTK_IM_MODULE_FILE.
LOG NOT INITIALIZED | Saving variable FONTCONFIG_PATH with value 0 to VMWARE_FONTCONFIG_PATH.
LOG NOT INITIALIZED | Saving variable GTK2_RC_FILES with value 1/etc/gtk-2.0/gtkrc:/home/usr/.gtkrc-2.0::/home/usr/.kde/share/config/gtkrc-2.0 to VMWARE_GTK2_RC_FILES.
LOG NOT INITIALIZED | Saving variable GTK_EXE_PREFIX with value 0 to VMWARE_GTK_EXE_PREFIX.
LOG NOT INITIALIZED | Saving variable GTK_PATH with value 0 to VMWARE_GTK_PATH.
LOG NOT INITIALIZED | Saving variable GTK_PATH64 with value 0 to VMWARE_GTK_PATH64.
LOG NOT INITIALIZED | Loading shipped version of libsigc-2.0.so.0.
LOG NOT INITIALIZED | Loading shipped version of libglibmm-2.4.so.1.
LOG NOT INITIALIZED | Loading shipped version of libglibmm_generate_extra_defs-2.4.so.1.
LOG NOT INITIALIZED | Loading shipped version of libatkmm-1.6.so.1.
LOG NOT INITIALIZED | Loading shipped version of libcairomm-1.0.so.1.
LOG NOT INITIALIZED | Loading shipped version of libpangomm-1.4.so.1.
LOG NOT INITIALIZED | Loading shipped version of libgdkmm-2.4.so.1.
LOG NOT INITIALIZED | Loading shipped version of libgtkmm-2.4.so.1.
LOG NOT INITIALIZED | Loading shipped version of libart_lgpl_2.so.2.
LOG NOT INITIALIZED | Loading shipped version of libxml2.so.2.
LOG NOT INITIALIZED | Loading shipped version of librsvg-2.so.2.
LOG NOT INITIALIZED | Loading shipped version of libview.so.2.
LOG NOT INITIALIZED | Loading shipped version of libgiomm-2.4.so.1.
LOG NOT INITIALIZED | Loading shipped version of libsexy.so.2.
LOG NOT INITIALIZED | Loading shipped version of libsexymm.so.2.
LOG NOT INITIALIZED | Loading shipped version of libcurl.so.4.
LOG NOT INITIALIZED | Loading shipped version of libvmwarebase.so.0.
LOG NOT INITIALIZED | Loading shipped version of libcds.so.
LOG NOT INITIALIZED | Loading shipped version of libgvmomi.so.0.
LOG NOT INITIALIZED | Loading shipped version of libvmwareui.so.0.

Die angeblich fehlende libgtkmm-2.4.so.1 ist vorhanden.
Hat hierzu jemand eine Idee ?
M.E. muss das nicht unbedingt mit dem Kernel zusammenhängen

Gruß
Anjo

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 26.07.2011, 11:38

Das hängt mit Sicherheit mit der Kernelversion zusammen. Durch den langsameren VMware-Releasezyklus brauchst du für fast jede Kernelversion einen Patch. Schuld daran sind die sich bisher bei jeder neuen Kernelversion geänderten Kernelschnittstellen.
Damit gilt weiterhin, daß propitäre Software und Releasewahn der Kernelhacker auf keinen gemeinsamen Nenner kommen.

Member
Beiträge: 15
Registriert: 18.02.2010, 08:41

Beitragvon AnJo » 08.08.2011, 13:18

Da fehlt wohl nur die dritte Stelle in der Kernerversion:
früher 2.6.35 , 2.6 37 etc. -> nun 3.0 (muss eigendlich ja 2.6.40 heißen)

Da hilft es nur die "fehlende" dritte Stelle durch Kernel-neu-compilation anzufügen:

-Kernelsourcen herunterladen und entpacken (Debian: apt-get source linux-image-xx)

-in das source-Verzeichnis wechseln

-fakeroot make-kpkg --append-to-version .0-irgendwas --revision 3.0.0-xx --initrd kernel-image

-fakeroot make-kpkg --append-to-version .0-irgendwas --revision 3.0.0-xx kernel-headers

Habe ich für mich so durchgeführt und vmware-player funktioniert prima :-)

Gruß
AnJo

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 08.08.2011, 23:00

AnJo hat geschrieben:Da fehlt wohl nur die dritte Stelle in der Kernerversion:
früher 2.6.35 , 2.6 37 etc. -> nun 3.0 (muss eigendlich ja 2.6.40 heißen)

Da hilft es nur die "fehlende" dritte Stelle durch Kernel-neu-compilation anzufügen:

-Kernelsourcen herunterladen und entpacken (Debian: apt-get source linux-image-xx)

-in das source-Verzeichnis wechseln

-fakeroot make-kpkg --append-to-version .0-irgendwas --revision 3.0.0-xx --initrd kernel-image

-fakeroot make-kpkg --append-to-version .0-irgendwas --revision 3.0.0-xx kernel-headers

Habe ich für mich so durchgeführt und vmware-player funktioniert prima :-)

Gruß
AnJo
Keine Ahnung was Debian da gebastelt hat, ABER der Kernel 3.0 meldet sich, um nicht angepaßte SW mit der zweitstelligen Versionsnummer nicht zu verwirren, absichtlich mit der Kernel-Version 3.0.0 ;)

Member
Beiträge: 15
Registriert: 18.02.2010, 08:41

Beitragvon AnJo » 09.08.2011, 09:17

und genau das, tut er eben nicht :?
Von einer speziellen Anpassung der Kernel diesbezüglich für die Anwendung unter Debian
ist mir nichts bekannt.
Sei es drum, ein uname -r gibt bei mir (und vielen anderen) eben ein 3.0-irgendwas aus und nicht ein 3.0.0-irgendwas.

Daher die Anpassung.

Was für einen Kernel verwendest Du ?
Würde ich bei Gelegenheit gerne testen.

Gruß
AnJo

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 09.08.2011, 09:34

Meine Ubuntu-Büchse läuft noch mit 2.6.27-17 und auf Kernel.org wird 3.0.1 als aktuell gelistet.
Eventuell liegt da ja ein Fehler vor und wurde jetzt gepatcht.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast