Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

vmware client, DNS geht nicht

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 15
Registriert: 17.04.2011, 14:21

vmware client, DNS geht nicht

Beitragvon SimplyBrain » 30.05.2011, 16:14

Guten Tag!

Ich habe ein Problem. Auf einem Linux Server (ubuntu) habe ich vmware player und darin windows server 2008 laufen.

Ich kann den Windows mit RDP erreichen, ich kann von dem Windows Server auf die IP von google oder anderen Seiten pingen. Ich kann aber nicht auf die domain "www.google.de" oder "google.de" pingen und natürlich auch nicht im Browser öffnen.

Mein Hoster ist server4you, ich musste MASQUERADING machen, damit der Windows Client zumindest pingen kann. Aber wieso funktioniert dann nur das PINGen und nicht die DNS Auflösung?

BTW: ich habe als DNS Server einen Server von der Liste http://provider-stoerung.de/blog/ubersicht-dns-server/ und dann noch einen (alle 3 versucht) von Hetzner - 213.133.98.98, 213.133.99.99 und 213.133.100.100

Ich kann auch die obigen DNS Server pingen, kein Problem. Aber die Namensauflöstung klappt einfach nicht. Muss ich noch was bei Windows etwa einstellen oder kann etwas verhindern, daß ich rauskomme? Es ist noch nichts installiert, der Windows Server ist Vanilla.

Benutzeravatar
Moderator
Beiträge: 14659
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 30.05.2011, 17:40

ich wuerde es mit wireshark testen

in der VM "nslookup www.google.de" ausführen - dann siehst du ja wo es haengt

Member
Beiträge: 15
Registriert: 17.04.2011, 14:21

Beitragvon SimplyBrain » 30.05.2011, 19:35

Den Wireshark darauf zu bekommen wird womöglich etwas schwierig.

nslookup sagt:
*** www.google.de wurde von ns1.hansenet.de nicht gefunden: Query refused.


Ich möchte etwas ergänzen. Wenn ich google oder andere domäne pingen will, dann kommt folgende Fehlermeldung in der cmd:
Ping-Anforderung konnte Host "www.google.de" nicht finden. Überprüfen Sie den Namen, und versuchen Sie es erneut.

Benutzeravatar
Moderator
Beiträge: 14659
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 30.05.2011, 19:48

Query refused.


Ok - sieht so aus als muesstest du bei dem Host noch mal das Masquerading ueberpruefen.

Was passiert denn genau mit dns Anfragen - port 53 TCP und UDP ?

Member
Beiträge: 15
Registriert: 17.04.2011, 14:21

Beitragvon SimplyBrain » 30.05.2011, 19:58

Hmmmmmm.

Wo finde ich den Log für iptables unter Ubuntu? Das ist auch so eine Sache, die mir helfen würde. Also unter /var/log gibt es wohl nichts was damit zu tun haben dürfte.

Edit:
Ich habe es. So sieht syslog aus nachdem ich es gelehrt habe zu horchen (debug):

Code: Alles auswählen

May 30 21:21:39 svx920549 kernel: [98531.725668] OUTPUTIN= OUT=eth0 SRC=YY.YY.YY.YY DST=XX.XX.XX.XX LEN=40 TOS=0x00 PREC=0x00 TTL=64 ID=52785 DF PROTO=TCP SPT=5902 DPT=48061 WINDOW=46 RES=0x00 ACK URGP=0
May 30 21:21:39 svx920549 kernel: [98531.958436] INPUTIN=eth0 OUT= MAC=00:21:09:c34f:d1:45:c6:1f:a1:d2:00:18:00 SRC=XX.XX.XX.XX DST=YY.YY.YY.YY LEN=40 TOS=0x00 PREC=0x00 TTL=118 ID=10575 DF PROTO=TCP SPT=47714 DPT=22 WINDOW=64700 RES=0x00 ACK URGP=0

May 30 21:21:40 svx920549 kernel: [98532.135045] OUTPUTIN= OUT=eth0 SRC=YY.YY.YY.YY DST=XX.XX.XX.XX LEN=61 TOS=0x00 PREC=0x00 TTL=64 ID=52786 DF PROTO=TCP SPT=5902 DPT=48061 WINDOW=46 RES=0x00 ACK PSH URGP=0

May 30 21:21:40 svx920549 kernel: [98532.179493] INPUTIN=eth0 OUT= MAC=00:21:09:c34f:d1:45:c6:1f:a1:d2:00:18:00 SRC=XX.XX.XX.XX DST=YY.YY.YY.YY LEN=50 TOS=0x00 PREC=0x00 TTL=118 ID=10576 DF PROTO=TCP SPT=48061 DPT=5902 WINDOW=259 RES=0x00 ACK PSH URGP=0

May 30 21:21:40 svx920549 kernel: [98532.179565] OUTPUTIN= OUT=eth0 SRC=YY.YY.YY.YY DST=XX.XX.XX.XX LEN=40 TOS=0x00 PREC=0x00 TTL=64 ID=52787 DF PROTO=TCP SPT=5902 DPT=48061 WINDOW=46 RES=0x00 ACK URGP=0
May 30 21:21:40 svx920549 kernel: [98532.278459] INPUTIN=eth0 OUT= MAC=00:21:09:c34f:d1:45:c6:1f:a1:d2:00:18:00 SRC=XX.XX.XX.XX DST=YY.YY.YY.YY LEN=92 TOS=0x00 PREC=0x00 TTL=118 ID=10577 DF PROTO=TCP SPT=47714 DPT=22 WINDOW=64700 RES=0x00 ACK PSH URGP=0

Member
Beiträge: 15
Registriert: 17.04.2011, 14:21

Beitragvon SimplyBrain » 31.05.2011, 14:51

Hi, ich habe noch mit anderen Möglichkeiten geschaut:

Code: Alles auswählen

nmap -v xx.xx.xx.xx

Starting Nmap 5.00 ( http://nmap.org ) at 2011-05-31 14:32 CEST
NSE: Loaded 0 scripts for scanning.
Initiating Parallel DNS resolution of 1 host. at 14:32
Completed Parallel DNS resolution of 1 host. at 14:32, 0.14s elapsed
Initiating SYN Stealth Scan at 14:32
Scanning xx.xx.xx.xx.inaddr.intergenia.de (xx.xx.xx.xx) [1000 ports]
Discovered open port 22/tcp on xx.xx.xx.xx
Discovered open port 6001/tcp on xx.xx.xx.xx
Discovered open port 5902/tcp on xx.xx.xx.xx
Discovered open port 6002/tcp on xx.xx.xx.xx
Completed SYN Stealth Scan at 14:32, 0.19s elapsed (1000 total ports)
Host xx.xx.xx.xx.inaddr.intergenia.de (xx.xx.xx.xx) is up (0.000090s latency).
Interesting ports on xx.xx.xx.xx.inaddr.intergenia.de (xx.xx.xx.xx):
Not shown: 996 closed ports
PORT     STATE SERVICE
22/tcp   open  ssh
5902/tcp open  vnc-2
6001/tcp open  X11:1
6002/tcp open  X11:2

Read data files from: /usr/share/nmap
Nmap done: 1 IP address (1 host up) scanned in 0.47 seconds
           Raw packets sent: 1000 (44.000KB) | Rcvd: 2004 (84.176KB)


tcpdump -i eth0:1

Code: Alles auswählen

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0:1, link-type EN10MB (Ethernet), capture size 96 bytes
14:45:52.623703 IP svx920549.hoster.ssh > 123.provider.de.12726: Flags [P.], seq 1590996632:1590996828, ack 1817085313, win 71, length 196
14:45:52.624786 IP static-ip-xx-xx-xx-xx.inaddr.intergenia.de.52290 > 345.provider.de: 45928+ PTR? xxx.xxx.xxx.xxx.in-addr.arpa. (44)
14:45:52.630071 IP svx920549.hoster.5902 > 123.provider.de.12741: Flags [P.], seq 2350567044:2350567065, ack 3159434000, win 148, length 21
14:45:52.632933 IP 345.provider.de > static-ip-xx-xx-xx-xx.inaddr.intergenia.de.52290: 45928 Refused- [0q] 0/0/0 (12)
14:45:52.667456 IP 123.provider.de.12726 > svx920549.hoster.ssh: Flags [.], ack 196, win 257, length 0
14:45:52.673478 IP 123.provider.de.12741 > svx920549.hoster.5902: Flags [P.], seq 1:11, ack 21, win 964, length 10
14:45:52.673616 IP svx920549.hoster.5902 > 123.provider.de.12741: Flags [.], ack 11, win 148, length 0


und netstat -tluepn

Code: Alles auswählen

netstat -tulpen
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode       PID/Program name
tcp        0      0 0.0.0.0:6001            0.0.0.0:*               LISTEN      0          6350        2010/Xvfb
tcp        0      0 0.0.0.0:6002            0.0.0.0:*               LISTEN      0          6383        2018/Xvnc4
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          3842        929/sshd
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      0          5382        1314/master
tcp6       0      0 :::6001                 :::*                    LISTEN      0          6349        2010/Xvfb
tcp6       0      0 :::22                   :::*                    LISTEN      0          3846        929/sshd
tcp6       0      0 :::5902                 :::*                    LISTEN      0          6386        2018/Xvnc4


Kann mir jemand helfen bitte?


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast