Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Win 7 Host-System --> Win XP virtuell (USB Erkennung)

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 3
Registriert: 27.04.2011, 14:35

Win 7 Host-System --> Win XP virtuell (USB Erkennung)

Beitragvon tobe-aurich » 27.04.2011, 14:44

Hallo zusammen,
bin ganz neu hier deshalb nicht wundern wenn diese Frage seltsam klingen sollte. Ich habe einen relativ alten Satellitenreceiver mit eingebauter Festplatte welchen ich an meinen Rechner anschließen möchte um die Daten zu übertragen.
Das Problem ist das Win 7 diese Festplatte nicht erkennt (USB) und die Treiber für Win 7 nicht angeboten werden seitens des Herstellers. Auf Win XP wurde diese Festplatte damals bei mir erkannt bzw. es waren Treiber zur Installation vorhanden. Ich möchte nun mit VMWare Player XP virtuell laufen lassen und erhoffe mir eigentlich dann auch wieder (nach Installation) auf die Festplatte zugreifen zu können.
Was ich mich allerdings Frage ist: Wenn mein Host-System (Win 7) die Festplatte nicht ordnungsgemäß erkennen kann weil Treiber fehlen, erkkent dann das virtuelle XP die angeschlossene Festplatte?
Normalerweise würde ein XP System ja auch nach Treibern (von CD etc.) fragen wenn diese nicht automatisch installiert werden konnten. Ist dies dann auch in der virtuellen Umgebung der Fall? Oder kann ich nur auf USB etc. zugreifen die auch auf dem Host-System erfolgreich installiert werden können, es liegt ja wie gesagt nur an den verdammten Treibern.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 27.04.2011, 15:23

Im Prinzip geht das auch ohne dass der Host die Treiber hat.
Am besten probier es aus und sag Bescheid wenn es Probleme gibt

Member
Beiträge: 3
Registriert: 27.04.2011, 14:35

Beitragvon tobe-aurich » 27.04.2011, 15:39

Vielen Dank erstmal für die schnelle Antwort.
Kann das leider erst am Wochenende ausprobieren, werde mich dann aber bzgl. Erfolg bzw. Misserfolg mal melden.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 27.04.2011, 15:44

vorab schon mal
Dein Win7 host sollte die original USB-root-hub Treiber von Microsoft verwenden - wenn nicht hast du ein problem

Member
Beiträge: 3
Registriert: 27.04.2011, 14:35

Beitragvon tobe-aurich » 30.04.2011, 19:32

Hallo,
Also erstmal es hat letzen Endes GEKLAPPT.
Der Weg dorthin war allerdings sehr umständlich. Ich musste noch in der Registry für die USB-Root Hubs den Upper Filter entfernen da die USB Erkennung bzw. der Dienst hierfür nicht gestartet hatte. Ich denke das war auch das Problem von wegen Treiber nicht von Microsoft etc.
Hier nochmal der Weg den ich zusätzlich gehen musste:

To manually remove the AMD USB controller:
Open the Windows registry, by clicking Start > Run and typing regedit.
Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000} .
In the right hand panel, if the the UpperFilters entry exists, delete it.
Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ .
Delete the usbfilter string.
Close the Registry
Delete this file: %system32%\drivers\usbfilter.sys.
Reboot your computer.
Anmerkung: Ich habe lediglich den "UpperFilters" Eintrag gelöscht. Danach das System neugestartet. Danach VMWare wieder gestartet und es ging. Die Festplatte wurde erkannt bzw. ich wurde zur Installation der benötigten Treiber unter XP (Gast System) aufgefordert. Hat danach alles bestens funktioniert. Der Receiver wird auch wieder richtig angesprochen und ich kann die Daten übertragen.
Der Englische Eintrag stammt aus einem anderen Forum (Quelle: http://kb.vmware.com/selfservice/micros ... Id=1016809), hat meine Probleme das der Dienst nicht gestartet war aber behoben.
Nochmal vielen Dank für die Hilfe.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste