Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

wofür sind die beiden "Netzwerkkarten" im Host?

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 14
Registriert: 02.02.2010, 21:08

wofür sind die beiden "Netzwerkkarten" im Host?

Beitragvon MikeJ » 04.02.2010, 18:46

Hallo

nachdem ich hier gestern schon super Hilfe erhalten habe, hoffe ich auch mit diesem Anliegen hier weiter zu kommen:

Ich habe eigentlich (noch) kein Problem sondern möchte nur gerne verstehen wie die Netzwerkverbindung zwischen Host und Gast funktioniert - und das am Besten für "nicht-Netzwerker" :-)

- Ich habe im Gast eine einzige Netzwerkkarte ("VMware Accelerated AMD PCNet Adapter") dieser bekommt per DHCP eine Private IP (192.168.147.128) und kommuniziert auch munter - meine Frage: mit wem?!? Im Netzwerkanschluß ist nichts eingesteckt.

- Im Host wurden 2 Netzwerkkarten eingefügt ("VMware Network Adapter VMnet1" und "VMware Network Adapter VMnet8") beide sind zwar aktiviert, zeigen aber "nicht Verbunden" an - meine Frage: wofür sind die denn?!?

Viele Grüße
Mike

Benutzeravatar
Experte
Beiträge: 1519
Registriert: 25.04.2005, 17:20
Wohnort: Wiesbaden

Beitragvon McStarfighter » 05.02.2010, 01:40

VMnet1 ist reserviert für den Host-Only-Modus, VMnet8 für NAT ...

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 05.02.2010, 16:45

Ich vermute mal, daß du mit "vmnet8" deinem Gast das NAT-Interface spendiert hast und dafür vergibt der VMware-DHCP-Dienst entsprechende IP-Adressen. Daher auch die Kommunikation.
Anonsten poste mal bitte den Inhalt(!) deiner VMX-Datei, zu finden im Unterordner deines Gastes.

Member
Beiträge: 14
Registriert: 02.02.2010, 21:08

Beitragvon MikeJ » 06.02.2010, 16:52

kann ich denn mit dem Gast irgendwie direkt auf die Netzwerkkarte des Hosts zugreifen?
also über die Einstellung "NAT" kann ich die Netzwerkverbindung des Hosts nutzen - aber kann ich auch wie z.B. bei den USB Geräten die Karte vom Host an den Gast schalten?

Hintergrund: ich muss per S7-LAN-Adapter auf eine Siemens SPS zugreifen. In der Einstellung NAT geht das halbwegs, allerdings ist Verbindung extrem langsam und bricht andauernd ab. Daher würde ich aus dem Virtuellen PC gerne ohne Umwege auf die Hardware zugreifen können...

Viele Grüße
Mike

Benutzeravatar
Experte
Beiträge: 1519
Registriert: 25.04.2005, 17:20
Wohnort: Wiesbaden

Beitragvon McStarfighter » 06.02.2010, 18:37

Du kannst der VM auch einen Netzwerkadapter direkt zuweisen (nennt sich bridgen), damit ist der Adapter dann aber nicht reell in der VM. Das geht auch nicht, zumindest nicht mit den bekannten Virtualisierern. Die einzige Lösung, die PCI-Devices direkt an einen Gast reichen kann, ist KVM (und Xen, wenn ich nicht irre). Und die können das auch nur, wenn der Prozssor VT-d kann ...
Unterm Strich: Du kannst dich an einen bestimmten Netzwerkanschluß hängen, der wird aber innerhalb der VM weiterhin als VMware Network Adapter gesehen (und das ist nicht änderbar).

Ausnahme wäre wiederum irgend ein USB Device für Netzwerkverbindung, das kann man durchschleifen ...

Member
Beiträge: 14
Registriert: 02.02.2010, 21:08

Beitragvon MikeJ » 06.02.2010, 20:27

auf die Idee mit dem USB-Netzwerkadapter bin ich auch gerade gekommen. Hatte sogar noch so ein Teil rumliegen. Das Gerät kann ich auch in der VM installieren und wird mir da als zweite Lan-Verbindung angezeigt. Wenn ich nun die IP auf 192.168.2.10 einstelle und meine Gegenstelle auf 192.168.2.77 eingestellt ist kann ich sie trotzdem nicht anpingen - woran liegt das?! - Hier fehlen mir jetzt wohl die richtigen Netzwerkgrundkenntnisse um sowas einzurichten :-(
Mein realer PC hat übrigens die 192.168.2.201...

Viele Grüße
Mike

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 06.02.2010, 22:28

Ist die Gegenseite auch ein Windows? Wurden dort in der "Win-Firewall" unter "ICMP" auch bei "eingehende Echoanforderungen zulassen" ein Haken gemacht?

Member
Beiträge: 14
Registriert: 02.02.2010, 21:08

Beitragvon MikeJ » 07.02.2010, 09:43

nein, die Gegenstelle ist ein S7-MPI Adapter (Programmierschnittstelle für eine SPS).
Aus dem Host heraus lässt sich der Adapter problemlos Pingen und über das Webinterface einstellen. Wenn ich mir den Status der Lanverbindung ansehe, kann ich auf dem Host sehen, wie sich die Anzahl der Ausgehenden und Eingehenden Bytes erhöht, beim Gast kann ich sehen, dass dieser Sendet, aber vom Adapter nichts zurück kommt.

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 07.02.2010, 12:45

Hast du mal mit Wireshark/Ethereal den Ping mitprotokolliert?
Welche Antwort erhältst du denn auf den Ping aus der VM? Verlinke mal bitte die Ping-Antwort als Bild bei http://ifile.it oder poste den genauen Wortlaut.

Member
Beiträge: 14
Registriert: 02.02.2010, 21:08

Beitragvon MikeJ » 07.02.2010, 20:11

Hallo,

das Problem ist gelöst - fragt aber bitte nicht wie! Ich habe einige Konfigurationsmöglichkeiten durchprobiert - jetzt bin ich wieder bei der ersten Konfiguration und es geht.
(ohne USB2Lan, die Einstellung NAT in der VM - also Standard...)

Ich danke vielmals für die Unterstützung!
Viele Grüße
Mike


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast