Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Probleme mit VMware nach Karmic Kubuntu update

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Probleme mit VMware nach Karmic Kubuntu update

Beitragvon sisqonrw » 05.11.2009, 22:55

Hallo,

habe eben auf Karmic Kubuntu ein upgrade gemacht.
Jetzt wollte ich VMware nutzen.

Der meldet:

Code: Alles auswählen

Before you can run Vmware Player, several modules must be compiled and loaded into the running kernel.


wenn ich auf install klicke, meldet der:

Code: Alles auswählen

unable to build kernel module.
See log file /tmp/vmware-root/setup-11259.log for details

Code: Alles auswählen

Nov 04 22:20:04.585: app| Log for VMware Workstation pid=11259 version=6.5.2 build=build-156735 option=Release
Nov 04 22:20:04.585: app| Host codepage=UTF-8 encoding=UTF-8
Nov 04 22:20:04.585: app| Logging to /tmp/vmware-root/setup-11259.log
Nov 04 22:20:07.218: app| Extracting the sources of the vmmon module.
Nov 04 22:20:07.329: app| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.31-14-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.4.1
Nov 04 22:22:15.666: app| Extracting the sources of the vmmon module.
Nov 04 22:22:15.713: app| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.31-14-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.4.1


Hat jemand eine Idee wie man das Problem lösen kann? Ich brauche VMware dringend beruflich.

Würde mich sehr über eure Hilfen freuen.

Danke

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 06.11.2009, 01:42

im VMTN findest du patche fuer verschiedene Kernel mit Anweisungen wie die zu handhaben sind

http://communities.vmware.com/people/Krellan

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 06.11.2009, 22:18

Hallo,

danke für die Info. Aber wie bekomme ich raus Welche Workstation ich habe. Es gibt Patches für Workstation 6.5.2 und 6.5.3

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 07.11.2009, 00:31

WS 6.5.2 = player 2.5.2
WS 6.5.3 = player 2.5.3
usw

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 07.11.2009, 06:02

ja, aber ich kann VMware nicht mehr öffnen, um zu sehen, welche Version ich habe. Es kommt halt eine Fehlermeldung. Kann man die Version auch anders herausbekommen?

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 07.11.2009, 14:27

Klar, ruf das Paketmanagement auf. So called Synaptic.

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 07.11.2009, 14:29

Oder versuch mal in der Konsole "vmplayer --version".

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 10.11.2009, 16:45

ich habe es mal probiert und bekomme diese Meldung:

Code: Alles auswählen

su
Passwort:
root@salsero-laptop:/media/disk/kubuntu-apps# bash ./vmware-6.5.2-newkernmods.sh
Sorry, installed file content does not match what was expected
for VMware Workstation 6.5.2 /usr/lib/vmware/modules/source/vmblock.tar file.
    Your checksum: 111725518eb37a65e5ad6bc6bd16774b
Expected checksum: 08894c1edd8c7c1c45846768102f3700
root@salsero-laptop:/media/disk/kubuntu-apps# ./vmware-6.5.2-newkernmods.sh
Sorry, installed file content does not match what was expected
for VMware Workstation 6.5.2 /usr/lib/vmware/modules/source/vmblock.tar file.
    Your checksum: 111725518eb37a65e5ad6bc6bd16774b
Expected checksum: 08894c1edd8c7c1c45846768102f3700



was ist das Problem hier?[/code]

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 10.11.2009, 17:40

dein tarball scheint korrupt zu sein - lad nochmal runter

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 11.11.2009, 10:16

was meinst du mit tarball ist korrupt?

meinst du bash ./vmware-6.5.2-newkernmods.sh ? Ich habe bash vmware-6.5.2-newkernmods.sh gerade noch mal runtergelanden. Es kommt wieder die Fehlermeldung.

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 11.11.2009, 19:20

Sind die Kernel Header installiert?

Welche Kernelversion genau?

Welchen Patch genau probiert?

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 12.11.2009, 16:32

Hi,

bei mir ist linux-headers-2.6.31-14 installiert.
ist die kernel version dann nicht 2.6.31-14? oder wie kann man das kontrollieren?
habe nur vmware-6.5.2-newkernmods.sh ausprobiert.

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 12.11.2009, 18:31

Na schau doch mal im Paketmanager nach, da sieht man doch sowas auf Anhieb.

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 12.11.2009, 19:03

das habe ich doch gemacht. der hat mir das halt ausgespuckt. Aber was muss ich machen, damit ich Vmware jetzt nutzen kann?

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 14.11.2009, 12:37

ich würde mich sehr freuen, wenn mir jemand helfen könnte. ich brauche vmware beruflich sehr dringend.

Danke

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 14.11.2009, 13:01


Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 14.11.2009, 13:45

HI,

Ich habe in /etc/vmware/bootstrap

Code: Alles auswählen

export VMWARE_USE_SHIPPED_GTK=yes
export LD_PRELOAD=/lib/libglib-2.0.so.0


eingefügt und das ganze sieht so aus:

Code: Alles auswählen

PREFIX="/usr"
BINDIR="/usr/bin"
SBINDIR="/usr/sbin"
LIBDIR="/usr/lib"
DATADIR="/usr/share"
SYSCONFDIR="/etc"
DOCDIR="/usr/share/doc"
MANDIR="/usr/share/man"
INCLUDEDIR="/usr/include"
INITDIR="/etc"
INITSCRIPTDIR="/etc/init.d"

VMWARE_INSTALLER="/usr/lib/vmware/installer"

VERSION="1.0"
# BUILD_NUMBER ?

export VMWARE_USE_SHIPPED_GTK=yes
export LD_PRELOAD=/lib/libglib-2.0.so.0


wenn ich vmplayer starte kommen die beigefügten Meldungen. Was mache ich falsch?

Code: Alles auswählen

Nov 14 13:41:38.947: app| Log for VMware Workstation pid=16517 version=6.5.2 build=build-156735 option=Release
Nov 14 13:41:38.947: app| Host codepage=UTF-8 encoding=UTF-8
Nov 14 13:41:38.947: app| Logging to /tmp/vmware-root/setup-16517.log
Nov 14 13:41:42.879: app| Extracting the sources of the vmmon module.
Nov 14 13:41:43.019: app| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.31-14-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.4.1


Bild

Bild

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 14.11.2009, 14:14

Poste oder besser verlinke doch mal bitte das genannte Log-File (/tmp/vmware-root/setup-16517.log) aus deinem verlinkten Bild.
Soviel sei dir aber schon mal gesagt, WS6.5.x kommt meines Wissens nach von Hause aus nicht mit dem Linux-Kernel 2.6.31 klar und bedarf daher einiger Anpassungen. Diese werden bestimmt in Ulli's Verlinkung ins VMTN auch dort genannt.
Also einfach abarbeiten oder du schaust bei der hervorragenden Ubuntu-Community vorbei und findest dort alles vor. Mit etwas Glück gibt es von den Ubuntu-Machern auch schon eine an deinen verwendeten Kernel angepaßte VMware-Version. Dann brauchst du dich nicht weiter auseinanderzusetzen. ;)

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 14.11.2009, 15:17

hi. ich habe die log Datei doch hochgeladen:

Code: Alles auswählen

Nov 14 13:41:38.947: app| Log for VMware Workstation pid=16517 version=6.5.2 build=build-156735 option=Release
Nov 14 13:41:38.947: app| Host codepage=UTF-8 encoding=UTF-8
Nov 14 13:41:38.947: app| Logging to /tmp/vmware-root/setup-16517.log
Nov 14 13:41:42.879: app| Extracting the sources of the vmmon module.
Nov 14 13:41:43.019: app| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.31-14-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.4.1


das was im Link stand habe ich doch gemacht. Habe die zwei Zeilen eingefügt. Habe ich was vergessen?

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 14.11.2009, 16:01

oste mal setup-16517.log

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 14.11.2009, 16:14

Code: Alles auswählen

Nov 14 13:41:38.947: app| Log for VMware Workstation pid=16517 version=6.5.2 build=build-156735 option=Release
Nov 14 13:41:38.947: app| Host codepage=UTF-8 encoding=UTF-8
Nov 14 13:41:38.947: app| Logging to /tmp/vmware-root/setup-16517.log
Nov 14 13:41:42.879: app| Extracting the sources of the vmmon module.
Nov 14 13:41:43.019: app| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.31-14-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.4.1

Member
Beiträge: 23
Registriert: 21.03.2009, 17:14

Beitragvon sisqonrw » 15.11.2009, 19:50

Das ist doch die setup-16517.log

Code: Alles auswählen

Nov 14 13:41:38.947: app| Log for VMware Workstation pid=16517 version=6.5.2 build=build-156735 option=Release
Nov 14 13:41:38.947: app| Host codepage=UTF-8 encoding=UTF-8
Nov 14 13:41:38.947: app| Logging to /tmp/vmware-root/setup-16517.log
Nov 14 13:41:42.879: app| Extracting the sources of the vmmon module.
Nov 14 13:41:43.019: app| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.31-14-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.4.1

Benutzeravatar
King of the Hill
Beiträge: 12026
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 15.11.2009, 20:35

Hmm, da steht aber nicht viel hilfreiches drin. Vielleicht weiß ja jemand damit etwas mehr anzufangen als ich, aber eines kann ich dir schon mal sagen.
Der Kernel 2.6.31 wird von der WS 6.5.2 nicht unterstützt und ich vermute mal, daß das auch erst mit der Version 7 hinzukam.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast